Jump to content

HELP TOPIC - further help in chat.osx86.hu/#legacykernel (IRC)

SL ML AMD APU FX Bulldozer

  • Please log in to reply
2075 replies to this topic

#361
Bitcore

Bitcore

    AMD Fanboy

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Producing Music

why HD 5770 not working ? it's a 5000 series no ?

No idea, I'll get that HD5450 :D
But isn't it working at all or just a lot of distortion?
Cause back in the Lion days, i got full QE/CI on 5770!
OOB ;)

#362
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,907 posts
  • Gender:Male

why HD 5770 not working ? it's a 5000 series no ?


I don't know: should work oob, but this is Sparta, oops, AMD hackintoshing.

Try with GraphicEnabler=No
If doesn't work, yes instead of no
If still doesn't work, boot with -x

All the best!


Bitcore, did you get any answer about the other card? Anyway, hope the HD5450 is as easy to get working for you as it was for me: you'll need to edit two kexts with the ID of the card - 0x68F91002.

All the best!

#363
zozourban

zozourban

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
I never edit a kext or dsdt etc. .. :/

#364
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,907 posts
  • Gender:Male

I never edit a kext or dsdt etc. .. :/


This part of the answer was for Bitcore. :)

#365
Bitcore

Bitcore

    AMD Fanboy

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Producing Music

I don't know: should work oob, but this is Sparta, oops, AMD hackintoshing.

Try with GraphicEnabler=No
If doesn't work, yes instead of no
If still doesn't work, boot with -x

All the best!



Bitcore, did you get any answer about the other card? Anyway, hope the HD5450 is as easy to get working for you as it was for me: you'll need to edit two kexts with the ID of the card - 0x68F91002.

All the best!

Nope but i saw a lot "ML wont boot with 4650" topics ;p
Which kext do i need to add it to?

#366
zozourban

zozourban

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
??

#367
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,907 posts
  • Gender:Male
ATI5000Controller.kext and AMDRadeonAccelerator.kext (under AMDCedarRadeonAccelerator).

#368
Bitcore

Bitcore

    AMD Fanboy

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Producing Music

ATI5000Controller.kext and AMDRadeonAccelerator.kext (under AMDCedarRadeonAccelerator).

Thanks :D

#369
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,907 posts
  • Gender:Male

??


Again: I don't know: your card should work oob, but this is Sparta, oops, AMD hackintoshing.

Try with GraphicEnabler=No
If doesn't work,
GraphicEnabler=Yes
If still doesn't work, boot with -x with either of the flags above or only -x

If that doesn't work, i really don't know what else can i advise. Good luck!

All the best!

#370
zozourban

zozourban

    InsanelyMac Protégé

  • Members
  • Pip
  • 23 posts
Ge= YEs no boot no launching GUI
GE =No i boot but i have resolution 1024x768 with 3mo of memory card -> Monitor O_o
-x = any idea =D

#371
kaloar

kaloar

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
i followed the simple mountain lion tutorial and i used a friends mac and was extremely satisfied in the face that i did it all and it booted.
i used my HP G42 and got through all the steps and no errors using
/amd_kernel -f -x -v -arch=i386 -maxmem=2048 -cpus=1
after i get through the disk utility it all seems find and i am happy, then i get to the part were i have too add my kexts....the kexts that i added to the install did not take. the customize screen shows up empty so i decided to go on with the install and it gets all the way through then gives me a screen saying that it did not install
on my 880g mobo with FX4100 it starts goes to the screen were it gets the chamaleon loader is and then goes into the darwin stuff were you choose your addons
i choose
/amd_kernel -f -maxmem=4096 cpus=2 and it goes through then restarts. anything i do on the desktop it will get up until right before when the screen should show up and then it restarts.

#372
mac_carol

mac_carol

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 148 posts
  • Gender:Not Telling

Its a Sapphire HD5450 silent 1GB or a Sapphire HD4650 1GB.

Thanks :D



http://www.hwcompare...radeon-hd-5450/



Ge= YEs no boot no launching GUI
GE =No i boot but i have resolution 1024x768 with 3mo of memory card -> Monitor O_o
-x = any idea =D



To make the GE=Yes works, you have to inject your HW-IDs into the vga kext
and you also have to find/use a proper ATI framebuffer (AtiConfig=...) which matches with both your VGA & monitor's port (CRT/DVI/HDMI)

If you can't find a stock one, you can inject the video path with your own custom personalities based on your VGA BIOS


or if you only need the native resolution for your monitor,
you can only install the vga kext (ATI5000Controller)
and delete the vga accelerator kext & bundles (AMDRadeonAccelerator & AMDRadeonX3000GLDriver)
but of course, you won't get the QE/CI

#373
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,907 posts
  • Gender:Male

http://www.hwcompare...radeon-hd-5450/


There's no doubt which card should perform better, Carol :D I thought perhaps either you or Gilles had a HD4650, but Bitcore recently learned they don't even work properly with OSX.

Some middle-to-high end Radeon cards are paradoxically a bad choice over middle-to-low end ones because of the heavy glitches many of them experience. That's why the personal experience of someone who is actually using a given card under Mountain Lion with an AMD rig will be better than any synthetic benchmark, at least for now.

All the best!

#374
mac_carol

mac_carol

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 148 posts
  • Gender:Not Telling
@theconnactic

:)

as both I & Gilles reported before, we get no major issues (almost :D) with the 4xxx card, not even one tiny glitch
all ports work properly and I can even get the HDMI sound via VoodooHDA, of course by injecting the correct audio & video path

the only issue I get is when I try to perform an OpenGL test under Cinebench

since I'm not a heavy gamer, maybe I will stick with this cheap card for a while
at least until someone find any solution for QE/CI bug under the 64-bit AMD osx


Here are some videos of ATI 4650 under AMD ML (not my videos! :D )

http://www.youtube.com/watch?v=6LghzGh-bhI

http://www.youtube.com/watch?v=_FUqFUlg21Q

#375
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,907 posts
  • Gender:Male
See, Bitcore?

Here's your answer! :D

#376
mac_carol

mac_carol

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 148 posts
  • Gender:Not Telling
@theconnactic

Yup!
ATM, I think the old 46xx/48xx card is still a better option for the 64-bit AMD ML


For a better price per performance ratio
(compared to nvidia cards, only if you can get a cheap used ATI one :D ),
These 2 cards might be considerable:

HD 4870 which is relatively equal with:
- GTX 275 http://www.hwcompare...on-hd-4870-1gb/
- GTX 460 http://www.hwcompare...on-hd-4870-1gb/
- GTX 550Ti http://www.hwcompare...on-hd-4870-1gb/

-or-

HD 4890 which is relatively equal with:
- GTX 560Ti http://www.hwcompare...on-hd-4890-1gb/
- GTX 650 http://www.hwcompare...-hd-4890-1gb/
- GTX 650Ti http://www.hwcompare...on-hd-4890-1gb/


Cons:
- relatively old architecture
- power-hungry devices
- hot & noisy
- no DX11 support (only DX10/10.1) under M$-Win


But that's just my two cents ;)

#377
Bitcore

Bitcore

    AMD Fanboy

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Producing Music

@theconnactic

Yup!
ATM, I think the old 46xx/48xx card is still a better option for the 64-bit AMD ML


For a better price per performance ratio
(compared to nvidia cards, only if you can get a cheap used ATI one :D ),
These 2 cards might be considerable:

HD 4870 which is relatively equal with:
- GTX 275 http://www.hwcompare...on-hd-4870-1gb/
- GTX 460 http://www.hwcompare...on-hd-4870-1gb/
- GTX 550Ti http://www.hwcompare...on-hd-4870-1gb/

-or-

HD 4890 which is relatively equal with:
- GTX 560Ti http://www.hwcompare...on-hd-4890-1gb/
- GTX 650 http://www.hwcompare...-hd-4890-1gb/
- GTX 650Ti http://www.hwcompare...on-hd-4890-1gb/


Cons:
- relatively old architecture
- power-hungry devices
- hot & noisy
- no DX11 support (only DX10/10.1) under M$-Win


But that's just my two cents ;)

thanks! and what about hd5770?
:)


EDIT: SHIIIIT That HD 4890 is beast :D And cheap!

#378
mac_carol

mac_carol

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 148 posts
  • Gender:Not Telling

thanks! and what about hd5770?
:)


unfortunately, the current amd kernel still has some issues with the accelerator kext (AMDRadeonAccelerator.kext) for the latest series of ATI (5xxx/6xxx/7xxx series)

but I read somewhere in this forum,
R:A:W:X86 can manage to boot the osx ML with the old 10.6/10.7 accelerator kext (ATIRadeonX3000)
and he can also play an OpenGL game



EDIT: SHIIIIT That HD 4890 is beast :D And cheap!



Here in my region, a used HD4890 1GB only costs less than $50

#379
Bitcore

Bitcore

    AMD Fanboy

  • Members
  • PipPipPip
  • 150 posts
  • Gender:Male
  • Location:The Netherlands
  • Interests:Producing Music
oke so :
The only thing i want is 1920 x 1080 resolution, and as less distortion as possible.
I dont need heavy gaming or anything. Only thing i would also like is HDMI output
What do you recommend?

HD4650
HD4850
HD4890
HD5450
HD5770

#380
mac_carol

mac_carol

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 148 posts
  • Gender:Not Telling
M$-Win with DX11 = 5xxx/6xxx/7xxx

64-bit AMD osx = 46xx/48xx

HD4650 = me
HD4850 = Gilles

HD4890 = You'll be the first :D
but I'm quite sure that this card will also work since it still uses the ATIRadeonX2000 kext as its accelerator





Also tagged with one or more of these keywords: SL, ML, AMD, APU, FX, Bulldozer


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy