Jump to content

HD 7xxx-Can we eliminate the Sleep Trick?

7970 7xxx sleep trick

  • Please log in to reply
186 replies to this topic

#141
tmaxx320

tmaxx320

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
7970M doesn't seem to work. Device ID: 6800

#142
fatez

fatez

    InsanelyMac Protégé

  • Members
  • PipPip
  • 64 posts
  • Gender:Male
  • Location:Italy - Bolzano

The Mac 7950 uses Hamachi FB.


It's possible to switch mac bios version into my 7950?

#143
gurki

gurki

    InsanelyMac Protégé

  • Members
  • Pip
  • 22 posts

It's possible to switch mac bios version into my 7950?


Hey Fatez,

sorry for hijacking.. I am about to buy the Sapphire 7950 Boost and stumbled upon ur post.
Can you tell me how good/bad the card works for you in hackintosh?

Thanks!!

#144
Scellow

Scellow

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:France
  • Interests:while{true||false}
    {
    dream();
    }
Hi guyz ! i know you hate stuff from tonymacx86 but this can help so many user so i decided to share it here ! i hope i'll don't get banned .. :/

Here is how to fix this White Screen problem :

First, boot with -x or another supported GPU

Get fp-rotate from this site and uncompress it somewhere:
http://modbookish.le...-display-on-os/

Open Automator.app
Select "Application"
Choose "Run shell script" (from the Actions/Utilities)
Paste this script (change de path):


/Users/user/fb-rotate -d 0 -r 90
/Users/user/fb-rotate -d 0 -r 0


Save the script somewhere.

Go to System Preferences -> Accounts -> Login items and add the script.

(Optional: you can set auto login too).

Source : http://www.tonymacx8...html#post579839




EDIT :

Our friend pernacabeluda from olarila.com made an app to make this process easier to do :

http://olarila.com/f...&p=24819#p24821

#145
VultUx

VultUx

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 109 posts
  • Gender:Male
  • Location:Brasil

Here is how to fix this White Screen problem :

Open Automator.app
Select "Application"
Choose "Run shell script" (from the Actions/Utilities)
Paste this script (change de path):

/Users/user/fb-rotate -d 0 -r 90
/Users/user/fb-rotate -d 0 -r 0

Save the script somewhere.

Thanks for the tip scellow, its much better than the sleep trick.

I will stick with this until a hardware or kext solution appear.

Thanks!

#146
Ostrich Egg

Ostrich Egg

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hi guyz ! i know you hate stuff from tonymacx86 but this can help so many user so i decided to share it here ! i hope i'll don't get banned .. :/

Here is how to fix this White Screen problem :


This is excellent, working great. Thanks for posting!

This trick works with multiple monitors, too. Just run ./fb-rotate -i to get the hexadecimal Display_ID for each display, then for each display do the trick as listed above but instead of -d 0 put in -d [Display_ID]

#147
MK500

MK500

    InsanelyMac Protégé

  • Donators
  • 80 posts
  • Gender:Male
  • Location:San Francisco, CA
  • Interests:All things technology.

Tell more exactly what is DeviceID of your card for me to add support into Clover next revision.


Hope you can add my Gigabyte Mhz edition 7970 3GB. It doesn't seem to be working with the rotation trick. It may be that I have to rotate my 4 displays in a certain order. Or maybe with a pause between. Sleep trick is still working.

Posted Image

#148
Mithos

Mithos

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 132 posts
  • Gender:Male
Hi,

I installed iATKOS ML2, after I updated at 10.8.3, after I installed v2 r1208 Clover EFI bootloader in the hdd, I put the dsdt of artur-pt in EFI / ACPI / Patched folder, I added my device id (0x68181002) at the kexts. But the hack stuck after DSMOS has arrived. Only in safe mode the PC starts, and in the System Info, Graphics, says: Monitor 7 Mb

I read the topic, but I did not understand almost nothing, the sleep trick you can do when you get to the screen black or white, but I block before these screens .. and if I press the power button nothing happens.

Here are the files that have changed, you can check that they are correct?



#149
Scellow

Scellow

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:France
  • Interests:while{true||false}
    {
    dream();
    }

Hi,

I installed iATKOS ML2, after I updated at 10.8.3, after I installed v2 r1208 Clover EFI bootloader in the hdd, I put the dsdt of artur-pt in EFI / ACPI / Patched folder, I added my device id (0x68181002) at the kexts. But the hack stuck after DSMOS has arrived. Only in safe mode the PC starts, and in the System Info, Graphics, says: Monitor 7 Mb

I read the topic, but I did not understand almost nothing, the sleep trick you can do when you get to the screen black or white, but I block before these screens .. and if I press the power button nothing happens.

Here are the files that have changed, you can check that they are correct?



Personaly i just installed the latest clover version, nothing more , everything worked out of the box, exept the audio and ethernet

Try to do like i did, reinstall the latest clover then just boot with default flag forget DSDT and other extra stuff

#150
Mithos

Mithos

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 132 posts
  • Gender:Male

Personaly i just installed the latest clover version, nothing more , everything worked out of the box, exept the audio and ethernet

Try to do like i did, reinstall the latest clover then just boot with default flag forget DSDT and other extra stuff

Now i try this!
Do you updated Mountain Lion at 10.8.3? Which boot flag can i use?

Thank you for the reply!

#151
Scellow

Scellow

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 129 posts
  • Gender:Male
  • Location:France
  • Interests:while{true||false}
    {
    dream();
    }

Now i try this!
Do you updated Mountain Lion at 10.8.3? Which boot flag can i use?

Thank you for the reply!

Yes
Nothing, let the default one. Just boot :)

#152
DAXGr

DAXGr

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Location:Thessaloniki - Greece
  • Interests:C#, Game development and hobbyist automation.
Attached File  7970_roms.rar   141.78KB   15 downloadsCan someone make a UEFI vbios for the sapphire 7970 rom include from the gigabyte one? I see in HxD that they have many differences and I am not sure what to do.

#153
k3nny

k3nny

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 538 posts
  • Gender:Male
Try this one: Attached File  sapphire_hd7970.zip   488.79KB   24 downloads
Good luck.

EDIT: Another version to try.

Edited by k3nny, 07 April 2013 - 02:21 PM.


#154
DAXGr

DAXGr

    InsanelyMac Protégé

  • Members
  • PipPip
  • 60 posts
  • Gender:Male
  • Location:Thessaloniki - Greece
  • Interests:C#, Game development and hobbyist automation.
Thanks, Tried with the rom but no display signal(card didn't boot). Thankfully it had bios switch

#155
k3nny

k3nny

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 538 posts
  • Gender:Male
Try again with the same attachment, this time it is an MSI efi vbios.

#156
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,975 posts
  • Gender:Male

Hope you can add my Gigabyte Mhz edition 7970 3GB. It doesn't seem to be working with the rotation trick. It may be that I have to rotate my 4 displays in a certain order. Or maybe with a pause between. Sleep trick is still working.


You have no framebuffer loaded... thats your issue.

#157
amsk98

amsk98

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
how can i install FB or edit kext

my GPU is ASUS ATI HD 7750

#158
Ash P

Ash P

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Having issues getting my card to load os x.

I'm glad device ID's are added to both chameleon and clover I was getting garbled text and instant reboots at first, had to download clovergrower and chameleon source code to edit ati.c

I used to be on 10.8.3, but now using 10.8.4 beta. In Chameleon r2191 or clover r1426 I cannot get my Powercolor AMD 7870 MYST Edition 2GB (same board as Fau7i but different card: - HD 7870 XT (Tahiti LE) - ID 679e.) to work, stuck on spinning wheel.

Tried many combinations different framebuffers GraphicsEnabler/Injection=Yes/No in BIOS tried "Windows 8 Boot"/CSM=off/on, also delete csmvideodxe64 but no go also tried dual gpu no luck.

in ML only safe mode works. Finally had to use my old nVidia GT 240 to get mountain lion to boot

Also sapphire 7950 driver for 10.7.5 works (had to edit ATIFramebuffer.kext and add my device id) but Its very buggy, results in slow os x after sleep. I removed sleepenabler.kext now I get instant reboot.

Any hints appreciated!!

Regards,
Ash

#159
fau7i

fau7i

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 111 posts
  • Gender:Male
  • Location:Malaysia

Having issues getting my card to load os x.

I'm glad device ID's are added to both chameleon and clover I was getting garbled text and instant reboots at first, had to download clovergrower and chameleon source code to edit ati.c

I used to be on 10.8.3, but now using 10.8.4 beta. In Chameleon r2191 or clover r1426 I cannot get my Powercolor AMD 7870 MYST Edition 2GB (same board as Fau7i but different card: - HD 7870 XT (Tahiti LE) - ID 679e.) to work, stuck on spinning wheel.

Tried many combinations different framebuffers GraphicsEnabler/Injection=Yes/No in BIOS tried "Windows 8 Boot"/CSM=off/on, also delete csmvideodxe64 but no go also tried dual gpu no luck.

in ML only safe mode works. Finally had to use my old nVidia GT 240 to get mountain lion to boot

Also sapphire 7950 driver for 10.7.5 works (had to edit ATIFramebuffer.kext and add my device id) but Its very buggy, results in slow os x after sleep. I removed sleepenabler.kext now I get instant reboot.

Any hints appreciated!!

Regards,
Ash


Hi, I'm not guaranteed it will work for your card, but worth to try it when using Clover;

1. Ensure secure boot and multi Lucid Virtu (multi-monitor) are disabled. Then sharing memory is set to 32mb.
2. If your ATI card doesn't support UEFI (I think it does), you have to let CSM enabled, but boot with GraphicsInjector=No and without CsmVideoDxe driver.
3, If it has UEFI vbios, you can disable CSM but boot with GraphicsInjector=Yes. And change FBName (Futomaki, Hamachi, Dashimaki, Aji etc) and number of ports. It can be tested from Clover GUI > Options > Graphics menu.

Here, I can boot with both options (2 and 3). The difference is when I boot with option 2, I need to do sleep trick and generic FB will be used. Anyway, I have its dev ID inside my DSDT.

#160
k3nny

k3nny

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 538 posts
  • Gender:Male
@Ash P:
Describe what happens when you boot in verbose mode.





Also tagged with one or more of these keywords: 7970, 7xxx, sleep trick


1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy