Jump to content

ML 10.8 Sleep and Cold boot and a few other issues.


  • Please log in to reply
4 replies to this topic

#1
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts
Hi,

Due to some work for iPad apps for my clients my developer has advised me to use ML or Lion on my laptop so that I can check if the apps are working properly, Now I have Lion 10.7.4 and ML 10.8 installed .

Lion 10.7.4 sleep works perfectly using Universal sleep kext from osx86 but the same on ML works badly , I can get ML to sleep without any trouble but when I wake it up I get the Desktop and just the mouse can be moved around and the keyboard is working but I cannot do anything else, sometimes I can just see half of the login screen but cannot do anything.

The other issue is when after shutdown I cannot power up the laptop , so I need to remove the battery and reinsert it to start the laptop.

PLEASE NOTE THERE IS A SIMILAR POST UNDER LION POST-INSTALLATION but this is for ML.

All of my hardware is working perfectly except USB 3.0 (Renesas) and the sleep and cold boot.

I AM NOT USING ANYTHING FROM ###### OR ###### BOTH LION AND ML INSTALLATIONS WERE DONE USING MYHACK 3.1.2.
Another issue is I need to use UseKernelCache=No in the boot flag in ML else i get the dreaded "Still waiting for root device" error. I had solved this problem from a post on this forum but as I have not been frequent on this forum lately and had shifted back to my Linux/W7 I have lost / forgotten what that patch was.

Ok almost forgot to mention this but I have noticed continuos HDD activity , so I did stop spotlight and mds from getting started but still the problem persists and Activity Monitor does not show mdworker or mds running.

All help appreciated Thnx.

#2
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

sleep:Proper combination for sleep is:


1) patched HPET, TIMR, RTC, PIC sections

2) patched EHCI/UHCI sections

3) patched AppleLPC kext to match chipset id

4) removed NullCPUPowerManagement,

5) patched AppleRTC kext to solve CMOS reset after sleep


#3
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts

1) patched HPET, TIMR, RTC, PIC sections
2) patched EHCI/UHCI sections
3) patched AppleLPC kext to match chipset id
4) removed NullCPUPowerManagement,
5) patched AppleRTC kext to solve CMOS reset after sleep



ouch sorry did not understand this. i have my dsdt and ssdt's . can you help me with what you have suggested ?

#4
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts
Fixed "still waiting for root device" using AHCI_extended_injector.

Got to get sleep and power up issue fixed.

#5
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts
What is this cold boot thing ? Why do I need to remove the laptop battery and then it powers up ?





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy