Jump to content

Problem 10.8.2 and NVidia 9500M


  • Please log in to reply
25 replies to this topic

#1
nigno21

nigno21

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hi to all,
I'd tried to install mountain lion on my dell studio xps1340...
Previous I had installed Lion 10.7.4 and was all ok, but installing ML2, first the system block in a black screen...
Deactivating NVidia Enabler the ML2 start correctly but the graphics is very slow and the system don't
recognize correctly my two video cards 9400M+9200GS.
I install after system installation the NVidia Kext and the system recognize correctly the video cards like in Lion 10.7.4,
but the graphics in very slow and If I try to launch a simple game like angry birds it says that I didn't load any openGL or similar...

How can I enable my video cards?
Please help...

System detail:
Processore: Intel® Core™2 Duo CPU P9600 @ 2.66GHz
Proprietà della scheda madre
Nome scheda madre Dell Studio XPS 1340
Memoria 2x4GB DDR3-1066
Tipo chipset GeForce 9500M (GF 9400MG + GF 9200MGS) 256MB

#2
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain

http://www.insanelym...nvidia-drivers/


#3
nigno21

nigno21

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

http://www.insanelym...nvidia-drivers/


Ok,
but i don't have a dsdt...
I launch the system with DSDT: default...

#4
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
no man, you need app DarwinDumper and you have your DSDT.aml, post here and I edit this for you

#5
nigno21

nigno21

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

no man, you need app DarwinDumper and you have your DSDT.aml, post here and I edit this for you


you're the best... thanks thanks thanks 10000000 times...
This evening I attach my DSDT...

#6
nigno21

nigno21

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hi,
here there are my two DSDT's:
1) complete DUMP with Lion 10.7.4 where is all ok
2) complete DUMP after update to Mountain Lion 10.8.2 deactivating all video card kext

I post also two pictures about the graphics card state before and after update!
Attached File  DarwinDumper_2.5.8_Chameleon_2.1_Lion_ands.zip   677.95KB   2 downloads
Attached File  DarwinDumper_2.5.8_Chameleon_2.1_ML_ands.zip   479.18KB   9 downloads

here the details with ML
Attached File  Schermata 2013-01-12 alle 11.07.05.png   78.45KB   24 downloads
Attached File  Schermata 2013-01-12 alle 11.07.31.png   85.05KB   24 downloads

here the details with Lion
Attached File  Schermata 01-2456300 alle 09.51.25.png   87.06KB   14 downloads

Attached Files


Edited by nigno21, 12 January 2013 - 10:38 AM.


#7
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
ok, here your DSDT.aml put in Extra, and install the lasted drivers from NVIDIA and repairPermission/Reboot, now install CUDA Drivers/RepairPermissions/Reboot

NVIDIA DRIVERS 304.00.05f02

NVIDIA DRIVERS 5.0.37

Attached File  DSDTPatched.zip   16.18KB   8 downloads

#8
nigno21

nigno21

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

ok, here your DSDT.aml put in Extra, and install the lasted drivers from NVIDIA and repairPermission/Reboot, now install CUDA Drivers/RepairPermissions/Reboot

NVIDIA DRIVERS 304.00.05f02

NVIDIA DRIVERS 5.0.37

Attached File  DSDTPatched.zip   16.18KB   8 downloads


I'm sorry but I have this problems following this steps:

1) I put the DSDT in Extra/ folder
2) when I try to install Nvidia Driver it says that these aren't for my system and the installation is stopped
3) so I use Pacifist and I extracted all kext present in Nvidia driver packet and install it manually.
4) repairPermission and after reboot the system go in black screen (I try to launch it also with -x -v but the result is the same)
5) I start Windows, mount mac osx partition and delete all kext and DSDT
6) reboot in system corretly and now I reisntall DSDT, Nvidia driver and repairPermission without reboot
7) I install also cuda driver directly from installer and repairpermission
8) after reboot the system go in a black screen
9) Trying to start with -x -v the result is the same...

I post last log where the system is blocked:
Attached File  20130112.png   1.49MB   18 downloads

Please Help me... :(
Thanks for all

#9
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
look in the kexts NVIDIA if have device id for yours card , if not present edit this, and in NVDAGF100HAL.kext

#10
nigno21

nigno21

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Can you tell me an example code to add in plist files?
which kext i edit? all that I installed ?
my graphics id card is 0x0866...

Now I try...

Thanks infinitely

#11
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
device id NVIDIA is 1002 and your card 0886 see infoplist of all NVDIA kexts, if not work you can try install from 10.7.4 kexts

Attached File  Captura de pantalla 2013-01-12 a la(s) 20.35.19.png   875.32KB   21 downloads

#12
nigno21

nigno21

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

device id NVIDIA is 1002 and your card 0886 see infoplist of all NVDIA kexts, if not work you can try install from 10.7.4 kexts

Attached File  Captura de pantalla 2013-01-12 a la(s) 20.35.19.png   875.32KB   21 downloads


Ok, but tell me,

in string tag I must add this: 0x086610de&0xff??? and how I chose the correct sequence?
my id card is 0x0866 not 0x0886 or I'm wrong?

#13
nigno21

nigno21

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Sorry,

in my NVDAGF100Hal there are this keys...
in which i add my card?


<key>IOPCIMatch</key>
<string>0x000010de&amp;0x0000ffff</string>
<key>IOPCIClassMatch</key>
<string>0x03000000&amp;0xff000000</string>

#14
nigno21

nigno21

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hi,

I try to add this

<key>IOPCIPrimaryMatch</key>
<string>
0x086610de
0x06e810de
0x019010de&amp;0xfff0ffff
</string>

to all NVidia Kext but nothing...
I replace with 10.7.4 Kext and system start correctly but the graphics is the same: very slow...
I post all Nvidia 10.7.4 kext at this link: http://dl.dropbox.co...10.7.4 kext.zip
I hope you help me... Thanks for all ...

#15
nigno21

nigno21

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts

device id NVIDIA is 1002 and your card 0886 see infoplist of all NVDIA kexts, if not work you can try install from 10.7.4 kexts

Attached File  Captura de pantalla 2013-01-12 a la(s) 20.35.19.png   875.32KB   21 downloads


iFire is correct what I've did? Why the system don't start?

#16
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
look here how to NVIDIA CARDS: Basic guide about nVidia kexts - nVidia - InsanelyMac Forum

and here a Example how to make a EfiString: Asus nVidia GeForce 210 1GB DDR3 Working! - nVidia - InsanelyMac Forum

and install the lasted Enoch boot loader for NVDIA CARDS:Enoch Bootloader

#17
nigno21

nigno21

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Thanks for all iFire... I try all but the result is the same:
EfiString, DSDT, kext Injection and enoch boot loader... I don't know what I can do...

Thanks for your disponibility...

#18
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
THIS IS a patch for OPENCL NVDIA , copy and past in termi9nal app, look if this work for you, make a backup first all NVDIA kexts.


sudo perl -pi -e '$c+=s/\x8b\x81\x1c\x0c\x00\x00\xeb\x06\x8b\x81\x20\x0c\x00\x00/\xb8\x02\x00\x00\x00\x90\xeb\x06\xb8\x00\x00\x00\x00\x90/; END { printf "%s: %d substitution%s made.\n",($c==1 ? "Success" : "Error"),$c,(!$c || $c>1 ? "s" : ""); $?=($c!=1); }' /System/Library/Extensions/GeForceGLDriver.bundle/Contents/MacOS/libclh.dylib



EDIT: you can test this package is NVDIA, I can't test it , I no have NVDIA Cards. Attached File  NV Override for Mountain Lion.zip   2.67MB   5 downloads

#19
nigno21

nigno21

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hi iFire,
I try the script but nothing... the system start but graphics ever slow...
With NV Override I install it but nothing...
In Extension I must rename it removing the suffix override?

PS.
can you give me the link where I can redownload ml?

#20
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
Apple - OS X Mountain Lion - Move your Mac even further ahead.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy