Jump to content

CLOVER bootloader...


  • Please log in to reply
130 replies to this topic

#1
morfy

morfy

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 890 posts
Oggi accorgendomi che il mio imessage non funzionava ho dato un occhiata e praticamente son venuto a conoscenza di questo nuovo bootloader. Volevo provarlo (uso la partizion EFI dove ho installati i file di boot) ma non capisco se è possibile installarlo su una partizione formattata in HFS+ (dalla guida mi sembra di capire che serve mbr).
Mi confermate sta cosa?

#2
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....
http://www.insanelym...uctions/�� vedi se ti può essere utile

#3
morfy

morfy

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 890 posts

http://www.insanelym...uctions/�� vedi se ti può essere utile


Grazie mille giorgio. avevo visto quel link.. vedro di studiarmelo meglio e faro le dovute prove. E' che mi piacerebbe capire se posso sempre usare la mia bella (e nascosta) partizione EFI pure per questo bootloader...

#4
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,575 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Scusate la domanda, ma qualcuno è riuscito ad installarlo?
Volevo provare il boot da usb ma non c'è verso di riuscirci (che niubbo che sono...)

EDIT: sono riuscito a fare il boot da usb, ho notato che nel resoconto di sistema ora la sezione diagnosi non mi dà più l'errore della memoria; come faccio a rendere definitive le modifiche alle selezioni di boot? Modificando il file config?
Ho notato anche che il bootloader identifica il sistema come iMac 12,2, mentre io uso 13,1; devo inserire il mio smbios nel suddetto file?
E' un peccato che non ci sia una guida tradotta in italiano, interpretare le frasi con google translate è una tragedia!

#5
morfy

morfy

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 890 posts
Non so guarda ci ho provato diverse volte ma ahimè senza tanto successo. Possedendo una gigabyte voelvo farlo partire in modalità UEFI (se non sbaglio a scriverlo) ma niente non mi parte e si avvia sempre col vecchio chameleon. MI piacerebbe riuscire a farlo partire anceh da usb in qeusta modalità ma purtrppo non ci son riuscito.

#6
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,575 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Anch'io non sono riuscito ad avviare in modalità UEFI, solo in legacy nonostante abbia apportato le modifiche al bios e scelto i drivers consigliati (a proposito, non ho trovato HFSPlusEFI).
Un'altra cosa che mi lascia perplesso è che il file config non vuole saperne di mantenere certe modifiche... così sono costretto ad entrare sempre nelle opzioni e modificare prima di avviare.

#7
morfy

morfy

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 890 posts
Intendevi questo file? https://github.com/S...les/HFSPlus/x64
Ora riprovo nuovamente ad installar esu pendrive...ma ci credo poco.

Niente appena formattala una pendrive in fat32 e mbr. Installato clover solo driver64uefi e uefi mode (nell'installazione scelgo quella). POi copiato in manuale sia i driver in driver64uefi che i kext (nella cartella 10.8). All'avvio parte automaticamente la pendrive, stavolta la vede, ma quando scelgo di partire ritorna al menù!

#8
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,575 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Si, il file era quello (ma non riesco a fare il download); le stesse cose che descrivi tu riguardo al boot UEFI rispecchiano fedelmente ciò che capita anche a me... rinuncio all'opzione (per ora).
P.S. Finalmente il file config.plist comincia ad ascoltarmi, ora riesco a bootare in automatico dopo 3 secondi, con SMBIOS iMac 13,1, senza Graphics Injector e col mio DSDT. Ora mi resta soltanto da fargli riconoscere correttamente la CPU ( WARNING: IOPlatformPluginUtil: getCPUIDInfo: this is an unknow CPU model 0x3a --Power management may be incomplete or unsupported) e cercare il modo di abilitare lo sleep.

#9
morfy

morfy

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 890 posts

Si, il file era quello (ma non riesco a fare il download); le stesse cose che descrivi tu riguardo al boot UEFI rispecchiano fedelmente ciò che capita anche a me... rinuncio all'opzione (per ora).
P.S. Finalmente il file config.plist comincia ad ascoltarmi, ora riesco a bootare in automatico dopo 3 secondi, con SMBIOS iMac 13,1, senza Graphics Injector e col mio DSDT. Ora mi resta soltanto da fargli riconoscere correttamente la CPU ( WARNING: IOPlatformPluginUtil: getCPUIDInfo: this is an unknow CPU model 0x3a --Power management may be incomplete or unsupported) e cercare il modo di abilitare lo sleep.


Ma quindi sei riuscito a farlo partire? Io appena selezioni il disco e non parte, si ripresenta il menù.

#10
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,575 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Parte solo in modalità normale, non UEFI; se non riesco a risolvere per lo sleep tenterò la via UEFI, per ora lascio perdere e mi concentro su SSDT e power management...

#11
morfy

morfy

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 890 posts
La mia mainboard se non ho letto male non ha bisogno di dsdt. Io non riesco però a capire come mai non parte in modalità uefi...

#12
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,575 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

La mia mainboard se non ho letto male non ha bisogno di dsdt. Io non riesco però a capire come mai non parte in modalità uefi...

Eh già... ci toccherà studiare un po', certo, se ci fosse qualche istruzione in italiano sarebbe più semplice.

#13
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,575 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
QUI ci sono le varie opzioni di avvio UEFI; nel caso di mobo Gigabyte si consiglia l'opzione 1, vedi se riesci ad avviare.

EDIT: ho avviato in modalità UEFI senza dsdt con l'opzione 3 e slide=0, lo sleep non funziona (come prima) e la grafica integrata ha una risoluzione incompatibile col monitor connesso in HDMI (di fatto si intuisce che sotto tutte le righe c'è il desktop, e devo connettere la gtx650). L'audio HDMI funziona.

#14
morfy

morfy

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 890 posts
niente le ho provate di tutti i tipi (strano che anche partendo -v nel config) ma alla fine come se partisse e poi si ferma e ritorna al menù del clover. Ma hai messo qualche opzione? per farlo partire?

#15
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,575 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Le opzioni sono quelle che ti ho indicato, oltre a quello ho impostato Graphics Injector =No

#16
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,575 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

niente le ho provate di tutti i tipi (strano che anche partendo -v nel config) ma alla fine come se partisse e poi si ferma e ritorna al menù del clover. Ma hai messo qualche opzione? per farlo partire?

Ma hai messo "-v slide=0" nelle opzioni boot args?

P.S. Ho deciso di fare un'installazione pulita sul disco di test, ora, partendo con clover in modalità legacy mi dice "this version of mac os x is not supported on this platform"...
Ne sai qualcosa?
Se avvio con la chiavetta di installazione o col disco principale è tutto ok, allora ho installato chameleon sul disco test con la stessa cartella extra del disco principale ma mi si inchioda immediatamente... mistero; mi sa che devo reinstallare di nuovo.

#17
morfy

morfy

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 890 posts

Ma hai messo "-v slide=0" nelle opzioni boot args?


Yes messo ma niente non va. Tipo che parte, diventa nero il schermo (senza far vedere niente) e poo ritorna sempre al menè di clover. Mi sa che per ora passo...

#18
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,575 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Devi provare varie combinazioni, ho dovuto provarne diverse prima di riuscire

#19
friscos

friscos

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 510 posts
  • Gender:Male
  • Location:Roma

Devi provare varie combinazioni, ho dovuto provarne diverse prima di riuscire


Allora, riprendo questo topic senza aprirne uno nuovo.
Facendo delle prove ho visto che l'installazione di ML tramite l'immagine "OS X 10.8.2 Mountain Lion bootable USB for Intel PCs" che è già preparata con Clover sulla mia configurazione (almeno su usb) va a buon fine.
Al riavvio Clover si presenta riconoscendo i vari sistemi e da anche l'input x l'avvio del mio osx in partizione in mod efi (x intenderci con i puntini in progress).
Quella versione però (rEFIt Version 2.01 UEFI By Slice) si installa in auto, invece la versioni che troviamo in Dow. sono un vero e proprio grattacapo come nei post sopra non c'è verso di dar vita a un boot…
Sarebbe opportuna una guida It, anche perchè non tutti sono ben messi con la lingua :P e le cose si complicano..
Inoltre sarebbe interessante sapere quali sono i reali vantaggi di questo loader che francamente non vedo, ma considerando il gran lavoro che si fa intorno suppongo ci debbano essere.

#20
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,575 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Ciao,
sono d'accordo con te che Clover si presenta alquanto complicato rispetto a Chameleon ed una guida in Ita non sarebbe male (Google Translate è una tragedia...)
Le versioni precedenti non le ho provate, ma ti posso dire che l'avvio UEFI non mi soddisfa, mentre con l'avvio da bios sono riuscito a vedere un sistema che non aveva bisogno di AppleACPIPlatform patchato, basta flaggare DropDmar nelle opzioni di avvio.
Altro vantaggio consiste nel fatto di trovare in "Resoconto di Sistema" alla voce diagnosi la parola "Riuscita", cosa che con Chameleon non mi riesce - Errore di Memoria...
C'è da dire che anche con Enoch la diagnosi va a buon fine, ma devo patchare AppleACPIPlatform, altrimenti non arrivo al desktop.
Per adesso mi tengo Clover in modalità bios...
Ah, tra l'altro Clover non mi boota finchè il sistema non è aggiornato almeno alla 10.8.2 ("this version of mac os x is not supported on this platform")





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy