Jump to content

[Aiuto] Triple boot Lion-Win8-Debian


  • Please log in to reply
9 replies to this topic

#1
n1c0la

n1c0la

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
ciao a tutti, mi serve il vostro prezioso aiuto, e quindi vengo subito al dunque

ho seguito la guida di ox86 per eseguire un triple boot su un disco partzionato GUID
Ho installato Iatkos l2 e win 7 ancora a settembre, e con i dovuti accorgimenti tutto funizonava, ho fatto l'upgrade a win 8, cioè installandolo da zero sulla partizione di windows dove c'era prima il 7 e ancora tutto ok!

ho deciso di installare debian 7, installando il bootloader grub nella partizione di linux, seguendo sempre la guida e quindi come era previsto dopo l'installazione mi sono trovato con un dualboot da chameleon di Lion e Debian...la partizione di win non si avvia

per ripristinare il triplo boot ho avviato il terminale e digitato gptsync /dev/disk1 che é proprio il disco formattato guid con imiti tre sistemi operativi, ma non mi riconosce gptsync
allora ho fatto il boot di iatkos dalla chiavetta di installazione e avviato il terminale e digitato la stessa cosa con il seguente risultato:

gptsync illegal instruction: 4

ecco il mio problema: come posso ripristinare il triple boot??

spero di essermi spiegato e in caso contrario chiedete pure :)

vi ringrazio intanto!

#2
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 1,887 posts
  • Gender:Male
  • Location:Roma
vedi che a volte non parte perche avvia la partizione con i file di sistema di win
quindi avvia debian e con g parted vai su gestione flag nella partizione di win e flagga come boot su riservato per sistema

a me con ubuntu fa' cosi
ciao

ps: non credo sia la giusta sezione

#3
n1c0la

n1c0la

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
se non e' la coretta sezione mi scuso ma non sapevo dove postare altrimenti...in caso spostatela pure :)

comunque grazie per la risposta tempestiva, ma sinceramente non ho molto capito che devo fare, devo flaggare boot sulla partizione di win con gparted?
comunqe aggiungo che linux e mac partono senza problemi, solo win 8 quando lo faccio partire mi fa la sua schermata azzurrina dicendomi che il sistema deve essere riparato cn il disco originale (io ci ho provato ma non ripara un bel nulla).

ciao e grazie mille :)

#4
n1c0la

n1c0la

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
qualcuno può aiutarmi a far bootare win8?? plz

:help:

#5
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 1,887 posts
  • Gender:Male
  • Location:Roma
prova a fare come ti ho detto , hai provato?

con gparted seleziona il disco dove c'è win 8, li ci sono due partizioni, una riservata per il sistema, destro sopra, gestione flag e spunti boot, se è su file sistem toglila

comunque se boot e ti dice cosi ( che va riparato non credo sia un problema di boot) anche perche lo fa partire

comunque cosi non ti si puo aiutare

hardware in firma
almeno uno sa come aiutarti

#6
n1c0la

n1c0la

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
ciao, innanzitutto grazie per la risposta e la pazienza!
comunque, non posso fare come dici, tutti i miei s.o. sono sullo stesso HD partizionato GUID, quindi la flag di boot sta nella partizione iniziale che fa partire il bootloader chameleon, giusto? se flaggo il boot su win8 dopo non mi parte piu nulla temo...

come dicevo ho avuto il problema quando ho installato linux, prima funzionatano win8 e OSX in dualboot :blush:

#7
carlo_67

carlo_67

    InsanelyMac Deity

  • Local Moderators
  • 1,887 posts
  • Gender:Male
  • Location:Roma
hai provato?
devi provare

#8
n1c0la

n1c0la

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
ciao
ho provato stamattina, con gparted ho flaggato boot sulla partizione di win, e l'ho tolto alla partizione efi del botloader. Ho riavviato e dopo un po mi si è riaperto chameleon, stavolta però tra le scelte disponibili c'erano tutte tranne la partizione di win proprio!
stessa cosa flaggando boot sulla partizione di win e lasciando flaggata quella del bootloader.

comincio a credere non ci sia una soluzione al mio problema...

#9
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain

Guide to Installing Windows 7, Windows 8, Mac OS X Lion, and Ubuntu Multi-Boot « racerrehabman


#10
n1c0la

n1c0la

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
ciao, ti ringrazio per la guida! che seguirò in caso estremo
però prima di cancellare e rifare tutto preferirei risolvere se si può il problema sulla mia configurazione!
la guida che ho seguito è questa:
http://iatkos.me/for...hp?f=73&t=18840





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy