Jump to content

My Mountain Lion Success Story


  • Please log in to reply
3 replies to this topic

#1
MacNutty

MacNutty

    Mad for Mac

  • Members
  • PipPipPipPipPipPipPip
  • 648 posts
  • Gender:Male
  • Location:India
Yesterday I successfully installed Max OS X Mountain Lion on my PC. I got various problems while installing it. I am listing out the problems and solutions I found for it. May be it will help someone.

First I created bootable Mountain Lion disk by restoring BaseSystem.dmg and copying Packages from root folder to /System/Installation. This was the easiest way to create bootable install disk which worked perfectly for me.

Now here are the problems I faced while installation and solutions which worked for me.

Problem: Computer restarts at apple logo.
Solution: Install latest chameleon boot loader to the partition and try again.

Problem: Black screen and computer goes to sleep after some time.
Solution: Problem with your graphics card. Copy appropriate graphics kext to Extra folder, rebuild Extensions.mkext and try again.

Problem: "Cant install Mountain Lion on this computer" Error.
Solution: Build a proper SMBIOS.plist using latest models of Apple products and put it in Extra folder.

Finally I was succeeded in installing Mountain Lion.
  • PS2 keyboard and mouse: Works (ApplePS2Controller.kext).
  • Sound: Works (VoodooHDA.kext).
  • Graphics Card: Works (NvInject.kext).


#2
salado

salado

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
Hi MacNutty,

Could you share the configuration on your hack?

1. What's your NVidia card?
2. Where did you find the right version of NVinject?
3. Do you need to modify NVDXXXX.kexts to enable QE/CI?

My old 7900GS is not supported by the 10.8.2 stock GeForceXXXX.kexts anymore. Need to find a new card for both my 10.7.3 and 10.8.2.

Thanks!

#3
MacNutty

MacNutty

    Mad for Mac

  • Members
  • PipPipPipPipPipPipPip
  • 648 posts
  • Gender:Male
  • Location:India

Hi MacNutty,

Could you share the configuration on your hack?

1. What's your NVidia card?
2. Where did you find the right version of NVinject?
3. Do you need to modify NVDXXXX.kexts to enable QE/CI?

My old 7900GS is not supported by the 10.8.2 stock GeForceXXXX.kexts anymore. Need to find a new card for both my 10.7.3 and 10.8.2.

Thanks!


My hack config is given in my signature. I have Geforce 9400 GT which works with latest version of NvInject.kext. I did not modify any kext, it worked out of the box.

#4
salado

salado

    InsanelyMac Protégé

  • Members
  • PipPip
  • 55 posts
  • Gender:Male
Thanks and will find that card to try.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy