Jump to content

Debugging 10.7.3 hackbook pro [AMD]


  • Please log in to reply
1 reply to this topic

#1
opticos

opticos

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Hey there,

So I'm new here, but figured what a better place to start... I've been reading around, hearing that it's nigh impossible to get Lion running perfect on a laptop, and I aim to prove that wrong. I have been lurking on the forums these past days trying to piece together my knowledge, but finally hit a roadblock.

I would like to note, I'm using this as my ONLY operating system, no dual boots, whatsoever. I'm a trooper, not an idiot.

I am running 10.7.3 V2 (Niresh)

My specs are:

Lenovo Thinkpad Edge E535:

AMD A4-4300m CPU/GPU hybrid (APU)
4gb 1333 ram
(APU)> HD 7420g onboard graphics
WD500gb 7200rpm hdd
UEFI Bios



What I've solved so far:

Installation, check
Bootable, check
Audio, check
Access to ALL usb ports, check
WiFi & Internet access, check
Custom resolution, check
FN keys work for controlling volume, wifi, brightness, check


My remaining issues:

(1) Can't run 32-bit & 64-bit apps simultaneously, booting with -legacy will allow me to run 32-bit apps, booting without will let me run 64-bit apps. In legacy mode, Lion refuses to run 64 bit apps, period, with an error stating that it's not available on "this version of Mac". Without legacy mode, my 32-bit apps crash immediately upon launch. Using the maxmem=4096 flag has absolutely no effect, nor did the "amd_insn_patcher".

(2) GraphicsEnabled=yes refuses to boot, while giving me the infamous framebuffer error, my only solution so far is to avoid installing ANY video driver kexts, period. This isn't necessary, because I'm going to be using my Hackintosh primarily for Xcode, but if anyone has any solutions, I'd greatly appreciate it.

(3) I can't seem to get Chameleon to install to the bootsector properly, and I'm aware that it's the 4k over 1k bootsector size issue, though the Linux fix hasn't helped me with this one. It's a nuisance, but I do have a boot disk, so it's not *absolutely* necessary.

(4) This is pretty annoying, but it hasn't been a big issue (yet), but every time I unplug my mouse, OSX crashes and tells me to reboot. Irritating, but not a show-stopper.

(5) I haven't managed to enable trackpad scrolling yet, once I get that down, I'm gonna love the hell out of this OSx86 box.

(6) My laptop won't go into sleep/hibernate. This one isn't really something I *can't* figure out, but rather, I just haven't looked into it yet.



Other than those 6 issues I listed, only 2 of which are serious setbacks, everything else is working immaculately. This laptop seems almost like it was made to run OS X!

I will be writing a full noob tutorial, from making a bootable usb/dvd, all the way until the last patch. If you help me, you will be accredited with your specific assistance in the matter.

So, is there anyone willing to help me out here?

#2
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,775 posts
  • Gender:Male
  • Location:Bcn-Spain
here info for AMD[AMD] Working Builds! - OSx86 10.6 (Snow Leopard) - InsanelyMac Forum


FORUM AMD:http://www.osx86.net/amd-processors/ http://www.insanelymac.com/forum/index.php?showtopic=278181







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy