Jump to content

[AMD] Working Builds!


  • Please log in to reply
224 replies to this topic

#141
ZaDoR

ZaDoR

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male
  • Location:Germany / Greece / Russian Federation

Screen_Shot_2014_01_14_at_11_01_00.jpg

 

APU A8 3870k  

m/b ASUS F1A55 MLK 2.0 

8GB Ram

XFX HD6870 OC



#142
Krazy-Killa

Krazy-Killa

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Full working OS X 10.9.1, booting with "npci=0x2000" only.  Kernel and System Cache both functioning without K/P. No DSDT being used.

 

CPU: AMD FX-4170 QC @ 4.2GHz

Motherboard: ASUS M5A97 r1605

RAM: 16GB @ DDR3-1866

Hard Drives: 1x 120GB SSD (with Trim Enabled), full NTFS R/W functionality with fuse4x and xCode. External Drives read normally

Sound: Fully Working (Front, Rear, and SPDIF) using VoodooHDA

Video: OOB GeForce GTX 560 1GB (QE/CI, OpenGL 4.1, Dual Monitor, and GPU Power Management with Patched AppleGraphicsPowerManagement kext)

Network: Realtek 8111E Gigabit (OOB with AppleRealtek kext)

USB 3.0: Working

USB 2.0: Working

Sleep: Partial (Will Sleep, but will not Wake)

Power Management: Not Working (System runs at full speed)

 

System is not completely stable, as if I leave it running for extended periods unattended, screens will go blank, and won't wake (like system is asleep), and need to hard reboot.

 

Doing some research on DSDT patching for this board.



#143
puxxie

puxxie

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
  • Gender:Male
  • Location:LA

 

OS: Maveriks 10.9

CPU: AMD Phenom x3 8550 @ 2.2GHz
Motherboard: MCP61 MB
Chipset: NVIDIA GeForce 6150SE nForce 430 ( NForceATA )
RAM: 4GB 800MHz
HDD: 320GB WDC
USB : 2.0 All working
GPU: GTX650
LAN: Realtek RTL8201N ( NForceLAN )
Sound: Realtek ALC662 ( VoodooHDA )
Sleep: Working in Mavericks.

 

mini_757893Schermata20131130alle171602.p

 

Can I ask how you installed? i have the same chipset



#144
fishhelmet

fishhelmet

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

OS: Maveriks 10.9.1

CPU: AMD FX 8350
Motherboard: AsRock Xtreme4 970
RAM: 16GB 1600Mhz (system only sees it as 667Mhz though) (Fixed: edited SMC and now it displays correctly)
HDD: 500GB WD Blue
USB : 2.0 All working 3.0 All working
GPU: GTX660
LAN: Realtek RTL8111E

WLAN: Netgear WNA1000m (yeah I know it sucks, but it was cheap while i wait for the OS X 10.9 drivers for my RTL8112au card)
Sound: Working thanks to spakk
Sleep: Appears to be working.

KERNEL: Andy's R9 kernel

 

Used Niresh's distro, after swapping his kernel with andy's system boots great with only the "GraphicsEnabler=No" flag. Apparently that's just an issue with my card card in particular as opposed to the entire 6xx series. 



#145
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 2,029 posts
  • Gender:Male
  • Location:marocain
Sound working with voodooHDA 2.8.4 or take an external USB-Sound System

#146
racainch

racainch

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
Notebook Model: HP G6-2240nr

CPU:2.7GHz up to 3.2GHz AMD A6-4400M Accelerated Processor (APU)
RAM: 4 GB 800 MHz DDR3 (1x 4GB)
Hard Drive:750GB
Graphics: AMD Radeon 7520 no QE/CI
Network: Ralink 3290 802.11bgn wifi adapter
not working, Ethernet: Realtek PCIe FE family controller, works with Lnx2Mac's RealtekRTL81xx v0.090 kext
Audio:Working with voodoo sound kext
PS/2: Touch pad and built-in keyboard working
Optical drive: working
I/O Ports: All three USB ports working both 3.0 and 2.0 I got it working by using USB 3.0 - universal in ##### 5.5.5 Tested front headphone jack, now working.

I've got both Mavericks 10.9 and ML 10.8.5 to both run on my notebook with little to no problems, but had a lot of problems, like application crashes mouse jumping etc. So I decided to to Install a retail ML 10.8.5, because it had less problems between the two.

To get it working I used myHack to make the usb installer, then replaced the mach_kernel with Bronozovka's AMD 10.8.x kernel. Installed the retail image using the USB 2.0 port (installed didn't boot on the USB 3.0 port) with no bootflags, After the installation completed I replaced the mach_kernel again, then repaired the permission on the drive I installed the retail ML on. I then deleted the org.chameleon.Boot.plist that myHack created and just used bootflags: npci=0x2000, dart=0 and UseKernelCache=Yes.

I'm still working on getting vga, and the hdmi port.

#147
dreadkopp

dreadkopp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts

OSX 10.8.5 by niresh. works well, needs freezefix to prevent fermifreeze, gpu not fully supported!

 

OSX 10.9.1 runs very well, GPU fully supported (finally i can run photoshop CC), start with niresh 10.9 usb dmg, replaced kernel and updated to 10.9.1.

 

Still can challenge an i7 System :D :

 

http://browser.prima...baseline=417357

 

 

bildschirmfoto2014-026bdmd.png

 

 

OSX 10.8.5:

screenshot2014-02-06a3rb1d.png

 

http://browser.prima...ekbench3/392948

 

it's an

 

Asus M4A88T-M USB3 motherboard

 

Phenom II X4 945 Cpu @ 3 Ghz

 

10 Gb of DDR3 Ram

 

Nvidia GTX 460 SE 1 GB

 

How i did it:

 

1. at first i update my bios to 0704 version. sata ->ahci, sleep state s3 only, mikrocode on. boot afterwards from usb

 

2. boot with flag kernel=amd64 root=BaseSystem.dmg . also uncheck USB injection at PCI settings, othewise my keyboard didn't work (bluetooth logitehc thingy)

 

3. uncheck the audio kexts, they gave me kernel panic, then install... when installation is finished (with error), don't reboot, open terminal and umount the install-hdd (umount -f /Volumes/whereveryouinstalled)

 

4 open Disk Utility and repair disk and permissions

 

5. reboot. boot again from usb stick, this time bootflags are npci=0x2000 -v -x -s

 

6. when you reached the single-user bash do fsck -f again.

 

7. if it is finished exit to boot to graphical mode.

 

8. you should be granted with welcome screen

 

9.wait till nireshs post-install stuff finishes.

 

10. then install kext for audio: http://www.osx86.net...or-via-vt1708s/

 

10.5. replace mach_kernel in root-directory with this one... it worked for me to escape safe-mode

http://www.osx86.net...085-amd-kernel/

 

11. I don't know i GPU kext is needed, since systemino recognizes my GPU, networks works outofthebox

 

12. install chameleon or clover... i am not at this stage right now.

 

13, be happy with your amd hackintosh

 

 

 

 

greetings



#148
kordoz

kordoz

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

My perfectly working AMD Hackintosh:

 

Mobo: Asus M5a99x EVO

CPU: AMD Phenom II 965 BlackEd

RAM: 4 x 4GB Kingston DDR3 1333Mhz

HDD: Samsung SSD Pro 128GB

Graphics:  AMD Radeon 7850 2GB 

 

Installation media: Niresh Mavericks for Intel and AMD

 

http://niresh12495.c...-intel-and-amd/

 

 

1) set Your Bios:

 

sata disks and DVD-ROM to AHCI

 

USB legacy ON, otherwise USB keyboard is not working while at initial screen

 

 

2) Boot NireshDVD, with F8 pressed set kernel by type of Your CPU:

 

amd -v 

 

or 

 

amd64 -v

 

or

 

amdfx -v

 

 

Install OS X

 

 

 

3) after first reboot remove DVD media, set boot options by pressing f8:

 

 

GraphicsEnabler=no

 

 

 

4) if You can't see anything than black screen, plug your DVI cable to another port of graphics card

 

 

5) create account, etc

 

 

6)  set GraphicsEnabler has to be permanently off

 

 

just edit /Extra/org.chameleon.Boot.plist

 

and set it to  "n" :

 

        <key>GraphicsEnabler</key>

        <string>n</string>

 

 

 

7) do not download any kexts, all You need is from Niresh Mavericks install DVD on Your /System/Library/Extensions

 

delete all graphics kext instead of these:

 

 

 

AMD2400Controller.kext

AMD2600Controller.kext

AMD3800Controller.kext

AMD4600Controller.kext

AMD4800Controller.kext

AMD5000Controller.kext

AMD6000Controller.kext

AMD7000Controller.kext

 AMDFramebuffer.kext

AMDRadeonAccelerator.kext

AMDRadeonVADriver.bundle

AMDRadeonX3000.kext

AMDRadeonX3000GLDriver.bundle

 AMDRadeonX4000.kext

AMDRadeonX4000GLDriver.bundle

AMDSupport.kext

 

Delete 0x68181002  at Info.plist of  AMDRadeonX4000.kext and AMD7000Controller.kext, Add 0x68191002 at the front for both

 

8) reboot , sign to adobe and update to 10.9.1  and thats all

 

internal sound card and ethernet card is working right after install

 

About_AMDMac.jpg

 

 

AMD7850.jpg



#149
RobertX

RobertX

    Yosemite Sam

  • Members
  • PipPipPipPipPipPipPip
  • 572 posts
  • Gender:Not Telling

...hi, i'm not on amd but, i am using the amd kernel(Pentium D requires the ssse3 emu)...take a peek

 

Attached File  pentium d.png   752.79KB   15 downloads

 

Attached File  madshaders.png   1.06MB   12 downloads                       Attached File  airportextreme.png   67.11KB   13 downloads   :smoke:

 

 

...not too bad eh! booting with chameleon bootflags -v -f -npci=0x2000 GraphicsEnabler=Yes



#150
nukedeath

nukedeath

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts

OS: Niresh Mavericks 10.9

CPU: AMD FX 8320

GPU: GIGABYTE GEFORCE GTX 670 (Running Dual Monitor) (Works, subpar performance)

Motherboard: ASUS M5A78L-M/USB3

RAM: 8GB 1600MHz (667mhz wat?)

HDD: Intel 335 240GB

USB : 2.0 All working

LAN: Realtek RTL8111 (Works with RTL8111 driver)

Sound: O2+DAC (Standard USB Sound Device, works)

Sleep: Not Tested (Not Needed)

 

Geekbench was 9900 something, and Cinebench OpenGL was only 40 fps :(

 

God I love the AMD kernel hackers. To boot I use GraphicsEnabler=Yes PCIRootUID=1 or else I get Black display / screen after bootsplash. The Graphics performance is under Linux and Windows, can play Dota 2 and stuff but Minecraft.. oh god Minecraft is really {censored}.

 

  • When launching mission control the UI isn't so smooth.
  • Tried editing AGPM to my device and change everything to 100, nothing changed :(
  • Also tried changing to this kernel by andy with full SSE4 support link but alas no change, probably 5 percent faster.
  • I even did download the new nvidia driver for mavericks, got it from some guy somewhere, nothing changed so must be the kernel.

 

How does Minecraft run for you guys?, should I ask in the kernel testing thread? I am really an idiot when it comes to hackintoshing. Been running for over a day now and its really stable, so it's stable atleast with no memory leaks ;)

Attached Files



#151
ntzrmtthihu777

ntzrmtthihu777

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

CPU: AMD FX-6300 Hex Core @ 3.5Ghz

Motherboard: MSI 970A-G46 (MS-7693)

GPU: NVIDIA GK107 [GeForce GTX 650]

RAM: 6gb DDR3-1600

OS X: Mavericks 10.9.1 - fx patched Kernel - Clover UEFI

 

Most everything is working; I installed by writing a vanilla Mavericks installer dmg to usb stick from linux, booting with chameleon with a modded fx kernel; had to install a kext for my ethernet to get app store working, and still working on getting hdmi audio working.

 

All in all I must say I'm pleased with my first foray into hackintoshing.



#152
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 2,029 posts
  • Gender:Male
  • Location:marocain
HDMI is working with Voodoohda or with Applehda?

#153
ntzrmtthihu777

ntzrmtthihu777

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

HDMI Video worked out of box, Audio not at all yet; I'm going to attempt the AppleHDA.kext + DSDT patch method; I'm the sort of person to not go for a quick and ugly hack, I like to have stuff work exactly right :P

HDMI is working with Voodoohda or with Applehda?

 



#154
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Local Moderators
  • 2,029 posts
  • Gender:Male
  • Location:marocain
That is the reason why we are all here. <br />Best of luck! And keep us in the running:D

#155
Thunderbolt

Thunderbolt

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 244 posts

Perfectly working 10.9 :

 

 AMD FX 6300 

 8GB RAM

 HD 7750 2 GB 

 Ga 880-gm-usb 3 rev 3.1

 Acer 20" x 2 (DVI / VGA) 

 Voodoohda 2.8.4 

 

 Flags Used :    npci=0x2000 GraphicsEnabler=No 

 

 Using only for X plane 10 but performance is not up to par. else everything else is nice and fast.

 

Will try the other R9 Kernel and check performance.



#156
lightskreen

lightskreen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 99 posts
  • Gender:Male

 My build went surprisingly smoothly. The only things that don't work are little and can't be bothered with.

CPU: AMD FX-6300 3.5 GHz working without NCPUPM.kext. Shows up as "3.5 GHz unknown" in about this mac. Help with that is always appreciated.

RAM: 8 GB DDR3 @ 1600 mhz dual-channel. In about this mac it shows up as "8 GB ???". Any help would be appreciated.
 

GPU: MSI GTX 760. Shows up as an NVIDIA Geforce GTX 760 and runs smoothly out of the box. The web drivers for 10.9.1 SEEM to make it feel faster.

HDD's: Installed onto a 64 GB Sandisk SSD alongside windows 8.1 purely gpt/uefi as well as a 1 TB WD Blue for data. I would like to know how to set it so that OS X always is the default boot option for clover, even if I boot into windows. If I boot into windows in fast mode, it never lets me select OS X again and I would like to have it just default to OS X and have access to windows whenever I need it.

Motherboard: Asrock 990fx extreme3. all usb 2.0 work perfectly as well as 3.0 with a PXHCD.kext installed. Ethernet works perfectly after installing a modified IONetworkingFamily.kext.

Wifi: Atheros AR938x chipset. Great signal and works out of box.

Bootloader: Clover revision 2652. Installer boots with "npci=0x2000 -x", The working install boots with "npci=0x2000" only which I have set in the config.plist.

Kernel: My kernel is the one from this link. http://www.osx86.net...l-sse4-support/

If there's a better one, suggest it to me, but this is the best I could find for my build.

OS: All of this was completed on Mavericks 10.9.1 and some of the beginning stages were done on 10.9.0. I used Windows 8.1 Professional because some games just can't run on Mac OS. ;)

Attached Files



#157
tragediana150

tragediana150

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 296 posts
  • Gender:Male
  • Location:Poland
  • Interests:Music Production

Snow Leopard 10.6.8 / Mavericks 10.9.0 / Mavericks 10.9.1

Everything is Retail version of OSX

 

Motherboard: Gigabyte GA-M56S-S3 Rev. 1

Processor: AMD Athlon 64 X2 6000+ 3.00GHz

Memory: 6GB DDR2 800MHz (2x2GB + 2x1GB)

Chipset: nVidia nForce 560

Graphics: nVidia GeForce GT 640 2048MB DDR3

Graphics on 10.9.0.-10.9.1 works with Dual Displays in full HD resolution (2xHDMI or 1xHDMI and 1xDVI) (VGA ports do not work at all)

Graphics on 10.6.8 works with adding Natit.kext

Audio: Realtek ALC888

Audio 2: M-Audio Fast Track II

LAN Internet: Tenda Repeater working with LAN cable

Bootloader: The newest Chameleon

Kernel for 10.9.0-10.9.1: Sineteks v6_kernel or any kernel from Bronzovka or Andy (almost every kernel boot to the desktop) :)

Kernel for 10.6.8: Nawcom Legacy Kernel v1 or Legacy Kernel v2

Boot flags with 10.9.0: npci=0x2000

Boot flags with 10.9.1: npci=0x2000 -f

Boot flags with 10.6.8: arch=i386 arch=x86_64 PCIRootUID=1

 

Mavericks is more functional and less problematic than Snow Leopard. Almost everything works perfect.

I did not try the onboard Audio becuase I've got Audio Interface from M-Audio.

AppStore = working

iTunes = working

iMessage = seems to work

iCloud = I have no time to check this and I will report back later


Edited by tragediana150, 30 March 2014 - 06:23 PM.


#158
Mikeszf

Mikeszf

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
  • Gender:Male
  • Location:Venezuela

OS:

-Mavericks 10.9.0/10.9.1/10.9.2 (Replacing the respective kexts)/ 10.9.4 (With bronya's rc2 kernel) / 10.9.5 (with rc2_kernel and replacing IOHIDFamily with the 10.9.4 version)

 

Motherboard: 

-Gigabyte Ga-970a-UD3 Rev. 1.0 Bios F7

-Virtualisation on

-AHCI and hybrid bios/uefi enabled. Windows 8 also works on GUID, though chameleon doesn't recognise it.

-RAM Speed manual on 1600Mhz

 

Processor: Desktop

-AMD Phenom II X4 965 BE

 

RAM:

-Corsair Vengeance 2x4GB 1600mhz

 

HDD:

-1TB WD (MBR, windows, storage, time machine…) + 250GB WD (GUID, mac).

*The motherboard has no IDE support

 

Sound: 

-Realtek ALC 889

-With VodooHDA 2.7.3 + Settings loader. 

-Midi settings  192000.0 Hz 16bit for no crackling

-Works only the green port. haven’t tried getting full 5.1 as my sound system burned :’(. 

-Back and front panel working.

-Microphone also works with bit of tweaking from the VodooHDA settings panel, the front one works almost as windows with just a minor feedback if too loud on the mic.

-The midi settings resets for the active output if an app uses the it e.g. Skype. Not all the times though.

-Haven’t tried to get auto detection working.

-No HDMI audio thru the video card, haven’t tried to fix it.

 

Network: 

-Realtek 8111E 

-With Lnx2Mac RealtekRTL81xx.kext.

-Again no auto detection. Had to connect the cable and re add the adapter from the settings.

-Atheros AR9285 PCI-e 1x card 

-With AirPortAtheros40.kext on S/E/E

 

Graphics: 

-Sapphire Radeon HD 6870 (100314-3L)

-Works perfectly with full QE/CI, can even play portal 2 with max graphs.

-Tried with 2 monitors at the same time, hdmi and dvi and worked fine as well, no auto detection though; it may randomly detect, very rare.

*This motherboard has no integrated graphics

 

USB: 

Both 2.0 and 3.0 work

-Don’t know about the 3.0 port speed, I mostly use them to charge my kindle and it mounts just fine. 

-I use the Zenith432 GenericUSBXHCI.kext for the 3.0

 

Optical drive: 

-Works fine, can’t remember the model and don’t have it connected as I don't actually use it and the led flashes every now and then on mac. 

-Burned some DVD's perfectly.

 

PS/2: 

-Not tested.

 

Kernel:

-sinetek’s 10.9.0_v4. (Tested from 10.9 to 10.9.2)

-Can’t shut down. Only restart but I don’t care as I don’t use to shut it down. If I need to, power button on the bios post… 

-The computer doesn't wake up after sleep either but again I don't care.

-The display can go sleep perfectly 

-Bronya's 10.9.4 rc2 (Tested on 10.9.4 - 10.9.5)

-Reboot and Shutdown work

-Has some graphic glitches on Finder and launchpad; taking screenshots; imessage; the album arts of itunes in the notifications and images on pages (mostly with jpg).

 

Boot Flags:

<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>-v npci=0x2000</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
<key>UseKernelCache</key>
<string>Yes</string> 

-The spakk no npci=0Xxxx works fine but disables the PCI card, which I use…

 

Bootloader: 

-Chameleon v2.2svn r2286. 

-Chimera and clover work as well

 

Notes:

-I used myhack for the installation in a GUID partition. MBR works but the first boot has to be done on secure mode (-x) and install the 3rd party sata drivers from some animalistic post installation tool. I use the Install ESD found on the App Store .app

-Any kernel panic while booting afterward gets fixed by deleting the com.apple.kext.caches folder. Tend to happen if changing kexts or the pc didn’t shut down properly.

-Can’t Open photoshop CS6 (CS5 works just fine).

-I was able to play skyrim in a high setting with parallels, almost max but the mouse wasn't captured so the camera was constrained to the movement of the mouse on the screen borders; the same will probably happen with any other game. Have windows so didn’t tried to fix it…

-Have been using it for a few months. I want it to post this after everything was working fine as I started only with graphics and WiFi with the above kext.

-I don’t use a DSDT as for Murphy's law each time I try to, some horrible random non-related issue happens.

 

Screen_Shot_2014_09_19_at_10_49_36_PM.jp Screen_Shot_2014_04_01_at_10_56_52_AM.jp



#159
internal

internal

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

CPU: AMD A8-4500M

Ram: 6GB DDR3

Build: OSX Mavericks 10.9

Kernel: bronya_rc8 rccfix

Boot Flags: -v -x GraphicsEnabler=No

PC: Samsung NP355V5C

Working: Keyboard and part touchpad

Not working: USB Support for non HFS+ Drives, No Bluetooth, No wifi or wifi support via usb, doesnt sleep, touchpad gestures, APU-Graphics not working

amd_osx.jpg


Edited by internal, 07 April 2014 - 12:18 PM.


#160
tragediana150

tragediana150

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 296 posts
  • Gender:Male
  • Location:Poland
  • Interests:Music Production

Mavericks 10.9.0 - 10.9.4

Everything is Retail version of OSX

 

Motherboard: Asus M5A78L-M LX3 (760G PCI-E DDR3)

Chipset: 760G

CPU: AMD 6-Cores FX-6300 3.5 Ghz

Graphics: nVidia GeForce GT 640 2048 MB DDR3 (working with full HD resolution on dual display)

Memory: GoodRAM 8GB 1333 MHz DDR3 (2x4GB)

Internet: Qualcomm Atheros 8161/8171 LAN Ethernet

OSX: Mavericks 10.9.0-10.9.4

Kernel: every BSA_kernel (now I am using BSA_V9_kernel) or RC1_kernel / RC2_kernel from Bronya

Boot flags: -f npci=0x3000 (or npci=0x2000)

Bootloader: Newest Chameleon

 

This is very stable and powreful build. Thanks to @spakk for helping with my new build.

Cheers!! :thumbsup_anim: :thumbsup_anim: :thumbsup_anim:


Edited by tragediana150, 23 August 2014 - 08:22 AM.






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy