Jump to content

[AMD] Working Builds!


  • Please log in to reply
213 replies to this topic

#81
granik

granik

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male

- AMD Athlon 64 X2 3800+ Manchester
- DFI LANParty UT NF4 SLI-DR Expert / No AHCI
- Dual ch OCZ EL PC3200 Platinum Rev2 1024
- HIS ATI X1300 IceQ Turbo 256MB DDR2 PCIe
- ALC850 / AC97 Internal sound

SNOW LEOPARD - Screen + bench

Install ; Hazard 10.6.6i -> 10.6.8
Kernel ; Nawcom 10.8 v2, flags ; arch=i386 -force64
Graphic ; Natit + RadeonHD Framebuffer (QE/CI)
Sound ; AppleAC97Audio

LION - Screen + bench

Install ; Retail 10.7.4. Tested ; Retail 10.7.2 + iAtkos L2, Niresh 10.7.3, 10.7.5 Virgin install image
Kernel ; RAW:86/Sinetek/Connactic (x86), flags ; arch=i386 -legacy. IiTz ShAnE build (x64), flags ; -nossse3bit
* bronzovka latest kernel failed, instant reboot.. too bad
Graphic ; DSDT (QE/CI)
Sound ; AppleAC97Audio (x86)

MOUNTAIN LION - Screen + bench

Install ; iAtkos ML2
Kernel ; Andy Vandijck (md5: 8F8E8B639E2CFB37293EDE5A34458B49), no-flags
Graphic ; DSDT + 10.7.5 ATI kexts (No - QE/CI) :P
Sound ; AppleAC97Audio (x86)

* All need "VoodooTSCSyncAMD" to reduce lag + hang


Thanks to all developers who made this happen

can you provide a link to 

 

 

Kernel ; Andy Vandijck (md5: 8F8E8B639E2CFB37293EDE5A34458B49), no-flags

?



#82
rrtn

rrtn

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:nyc

can you provide a link to 

?

 

http://www.insanelym...testing-on-amd/

amd_kernel.zip



#83
bibi

bibi

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

OSX 10.8.5

CPU     - AMD fx-8320 8 core 3.5 ghz

MOBO - ASUS Sabertooth 990FX REV 1.0

RAM - Corsair 1600 2x4GB

GPU    -AMD Radeon HD 7850 2GB (ASUS DIRECT CU II ) - working with screen rotation trick.

USB     -keyboard and mouse

BOOTLOADER     - CLOVER 2184

KERNEL - Sinetek's  fx kernel

some glitches FULL QE/CI

2 systems on 1 sata hdd with EFI CLOVER (WIn 8 + OSX)

 

Now

OSX 10.9

BOOTLOADER     - CLOVER 2236

Kernel Sinetek



#84
LightInDark

LightInDark

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts

Here are my working Builds.

CPU: AMD FX 8350 @ 4.0Ghz
Motherboard: Asus CrossHair V Formula-Z
SB/NB: SB:950 & NB:990FX
RAM: 16GB DDR3 1600Mhz
SATA: Tested with 6 HDDs, 60Gb SSD windows 7, 200GB SL, Lion & ML , & others . Blu-Ray drive worked too.
IDE: No.
USB 2.0: All ports work.
USB 3.0: Unknown.
Firewire: Disabled always
GPU: AMD Radeon HD 5970, works after editing 2 kexts, GraphicsEnabler. QE/CI
LAN: Intel 82583V Gigabit
Sound: ALC899 -> no support, but latest VoodooHDA 2.8.0 works on all SL, Lion & ML.
PS2: Not used.

Bootloader: Chameleon 2.1 R2069

Snow Leopard: Installed 10.6 from Nawcom Modcd and then updated to 10.6.8 through software update. After install everything worked correctly with appropriate kexts. Using AnV legacy 10.6.8 V8 R2 kernel in 64-bit UserLand.

Lion: Works in 32-bit with theconnactics 10.7.5 kernel, some fixes were needed (IOPCIFamily.kext etc.) basic stuff. Dodgy Graphics will sometimes not work.

Mountain Lion: Booted Installer, manually created install image and replaced AppleACPIPlatform.kext, IOPCIFamily.kext & IOUSBFamily.kext from acpirollback package by andy. No graphics QE/CI, still working on it. Sinetek "AMD Test Kernel 1" will let me install Mountain Lion and create user. But on next boot only shows a light grey screen that is slowly flashing dim then bright.

I have the same CPU but I get no luck doing what you've said :( my chipset is the AMD 970 if that helps.



#85
jonp1977

jonp1977

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

OS 10.6.8 Snow Leopard AMD Working build on Dell Studio XPS 7100

Processor:
AMD Phenom II x6 1075t 3.0 Ghz;

Motherboard:
Dell Studio XPS 7100 Motherboard:
 -On Board Audio ALC887/888b does not work, had to buy a USB Audio Adapter for $9 to get 2channel sound.  On Board microphone works with VoodooHDA.kext installed.  (I now have two audio devices.)
 -On-board LAN does not work
 -All USB Ports work without issue

Graphics:
ATI Radeon HD 5450 working when updated to 10.6.8 and then editing the ATI5000.kext plist to include 68f91002 hardware id.

Wifi Card: (PCI-e) works out of box (I think its a broadlcom wifi card,

12GB Ram

1TB Sata Hard drive

Install Method:
Used nawcom boot CD which gave me a compatible kernel (legacy_kernel) and chameleon bootloader necessary to get to the installation screen on my AMD system.  Installed with bootflags -v and -force64 as required by my processor.  After installation, updated to 10.6.8 and applied the ATI5000.Kext.plist edit mentioned above to get working graphics card.  Note:  Currently using arch=i386 maxmem=4096 busratio=19 and -force64 as bootflags.


P.S.  Thanks to Duran Keeley and Spaak and the insanelymac community for the good input and putting up with my dumba#@.  You guys rule.

 

*Mavericks 10.9 working build nearly complete!  New kernel in downloads section works great!  Thanks and congrats to all involved.  Awesome work.


Edited by jonp1977, 21 June 2014 - 08:46 AM.


#86
granik

granik

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male
post_offline.png rrtn

 

try http://www.insanelym...ttach_id=127906



#87
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,860 posts
  • Gender:Male
  • Location:português

OS 10.6.8 Snow Leopard AMD Working build on Dell Studio XPS 7100

Processor:
AMD Phenom II x6 1075t 3.0 Ghz;

Motherboard:
Dell Studio XPS 7100 Motherboard:
 -On Board Audio ALC887/888b does not work, had to buy a USB Audio Adapter for $9 to get 2channel sound.  No biggie.
 -On-board LAN does not work
 -All USB Ports work without issue

Graphics:
ATI Radeon HD 5450 working when updated to 10.6.8 and then editing the ATI5000.kext plist to include 68f91002 hardware id among list of other id's.

Wifi Card: (PCI-e) works out of box (I think its a broadlcom wifi card,

12GB Ram

1TB Sata Hard drive

Install Method:
Used nawcom boot CD which gave me a compatible kernel (legacy_kernel) and chameleon bootloader necessary to get to the installation screen on my AMD system.  Installed with bootlegs -v and -force64 as required by my processor.  After installation, updated to 10.6.8 and applied the ATI5000.Kext.plist edit mentioned above to get working graphics card.  Note:  Currently using arch=i386 maxmem=4096 busratio=19 and -force64 as bootflags.

Currently working on getting 64 bit snow leopard up and running so I have access to all 12 GB of RAM on my system.  Any help would be much appreciated.

P.S.  Thanks to Duran Keeley and Spaak and the insanelymac community for the good input and putting up with my dumba#@.  You guys rule.

Install the SystemInfo tool see here---> http://www.insanelym...nd-kexts-info/  and the current java version. then  run the tool, create an imaging your installed hardware with the systemInfo tool and upload it up here as an image, then we can adapt your Ethernet driver.


or read the information and look the video, then you will certainly modify the Ethernet driver in a few minutes, good luck


#88
jonp1977

jonp1977

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts
Here ya go Spaak
 
Attached File  SysInfo.tiff   345.45KB   14 downloads

 

Attached Files



#89
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,860 posts
  • Gender:Male
  • Location:português

take this http://www.osx86.net.../1136-bcm57788/


This driver contains your device ID (14e4) and vendor ID (1691) install this driver with kext wizard


more information to BCM 57788, see here ---> http://www.insanelym...river-3264-bit/


Edited by spakk, 18 October 2013 - 09:49 PM.


#90
jonp1977

jonp1977

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Cool tool.  Worked like a charm,

but, Hey, While I got you, has anyone been able to fix the graphics artifacts glitch in Mountain Lion on AMD? 

 

*Graphics working properly on 10.9 Mavericks!


Edited by jonp1977, 21 June 2014 - 08:46 AM.


#91
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,860 posts
  • Gender:Male
  • Location:português

my graphics card is working normally. I do not understand why so many user have so many problems with ati or nvidia graphics card.



#92
Chris Etheridge

Chris Etheridge

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:South Africa
  • Interests:Web development
    Web design
    Good music

This is my second 'Working Build' post, as my previous one didn't seem to work for me.

This was because I installed Mac, then got rid of it, installed Ubuntu, then got rid of it, then wanted to install Mac. This created trouble with Chameleon (so I think), maybe Grub had something to do with the trouble I was getting. My Mac would install fine, but when booting it would instantly restart at 'Starting Darwin x86', no matter the flags nor kernel. 

I basically bombed my boot record (Windows 8 on a separate hard disk thankfully). Fully erased it, wrote over it, destroyed it. Then rebuilt it using Windows 8 and bam Mac worked like a beauty. Here is my build:

 

CPU: AMD Athlon X2 @ 3.3Ghz

Motherboard: Biostar A780L (probably the most unsupported motherboard ever)
RAM: 4GB DDR2 1333Mhz
SATA: 2 X 160GB 
GPU: ATI Radeon HD5770 (full QE/CI)

LAN: Realtek 8102EL with RTG Mac
WiFi: TRENDnet TEW 684-UB with the drivers that came with the disk

Sound: ALC889 with VoodooHDA 2.8.4

 

Bootloader: Chameleon 2.2 
Kernel:  Bronzovka v4

Flags: USBLegacyOff=Yes npci=0x2000 (arch=i386 sometimes, but both 32 and 64bit work)

I installed using iAtkos. It took me about 2 days worth of time to finally get a bootable media device working. Expanding the DMG to my USB didn't work, and all the other methods didn't, and I didn't have a Mac machine available to use. I also have the worst internet in the world (70kb/s downstream), so I could not stand to wait to download Hazard's Snow Leopard for a virtual machine.

I finally wrote it to a DVD by expanding the image, packing in some of my own things (kernel and such), compressing it, and then using PowerISO to burn it to a disk. I used TransMac to do the DMG work. Everything booted up perfectly.

Feel free to ask my for any help, if need be (I have had run in with so many errors its ridiculous). Thank to everyone who helped me! :D

 



#93
Diazz72

Diazz72

    ExAMD Terminator

  • Members
  • PipPipPip
  • 171 posts
  • Gender:Male
  • Location:CROATIA

Any fix for this graphic glitches???



#94
rrtn

rrtn

    InsanelyMac Protégé

  • Members
  • Pip
  • 30 posts
  • Gender:Male
  • Location:nyc

I get reboot when loading, I believe that kernel is for FX

 

apple released sources for 10.9 & 10.8.5...new amd test kernels from Andy Vandjick, Bronzovka and Sinetek :)

http://www.insanelym...on-amd/page-167



#95
aplIIc

aplIIc

    InsanelyMac Protégé

  • Members
  • PipPip
  • 98 posts
  • Gender:Male
  • Interests:Blender, Mac on AMD, Coffee, F1, hakie sack, BEAMbots, beer, surf, MotoGP, ax throwing, son et l...

Here's my rig, GFX is a Genuine AMD ATI Radeon HD 5770

-Motherboard: ASRock 870 Extreme3 R2.0
-CPU: AMD Phenom II x4 B50 3.62Ghz (w/CoreUnlocker) Athlon II x3 450 3.2Ghz (wo/CoreUnlocker)
-RAM: A-Data DDR3 1333 Mhz
-GPU: OEM ATI Radeon HD 5770 1024 Mb Full QE/CI
-Audio: ALC892 - Voodoo HDA 2.8.4
-HDs: Seagate 1.5Tb, Hitachi 160Gb, WDC 320.0 Gb
Attached File  smtsixamd.png   4.41KB   13 downloads
-SnowLeo Retail + 10.6.8 Combo Update+ Legacy Kernel 10.8.0v2

-kexts: AtherosL1cEther, AppleRTC, ATAPortInjector, AHCIPortInjector, EvilAppleACPIPlatform, EvilIOPCIFamily, FakeSMC 3 r493, NullCPUPowerManagement, VoodooHDA, PXHCD -BootLDR Flags: legacy_kernel, -force64 arch=i386 maxmem=4096 busratio=16

amd_insn patch: dyld - libSystem.B - libSystem.B.profile - CarbonCore - QTComponents - QTh264scalar

Pretty darned stable!
Attached File  smamdmav.png   5.42KB   8 downloads

10.9 Mavericks!! kernel_beta_rc4

 

R.I.P (2004-2013)

eMachines T6542 (ECS C51-PVGM) - AMD Athlon64 3500+ @ 2.21 Ghz - 1.5 Gb DDR2 -PCIe 2.0 16x Nvidia GeForce 9400 GT 512 MB @ 400Mhz (Full Support)

iPC 10.5.6 Universal Final - 9.5.0 voodoo Kernel - Full Hardware Accel. 9f23installer.pkg GeForce 9400 GT - AppleNForce MeDevil - ALCInject & AppleHDA

 

New addition: aluminum fruit

Attached File  instapple.jpg   84.37KB   6 downloadsAttached File  alumapple.jpg   102.03KB   7 downloads

Attached File  banner.png   56.51KB   7 downloads

 

And now to load up my favorite game:

Attached File  IIc1.jpg   8.71KB   5 downloadsAttached File  IIc2.jpg   22.08KB   5 downloads

Attached File  IIc3.jpg   61.03KB   4 downloadsAttached File  IIc4.jpg   28.56KB   5 downloads



#96
JBExtrem

JBExtrem

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts

AMD Phenom II x4 965 @4x4,08Ghz

Asus Sabertooth 990FX r2.0

Sapphire HD 7970 3GB

8GB 1333Mhz RAM

 

Screen

57N07.png



#97
ADHDMedia

ADHDMedia

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 620 posts
  • Gender:Male
  • Location:Modesto, CA, USA

CPU: AMD Phenom II x6 1075T @ 3.675GHz OC
Motherboard: ASUS M4A78LT-M
RAM: 12GB 1066MHz DDR3
SATA: 250GB & 320GB Internal HDD
IDE: 300GB Internal HDD, 80GB External HDD (Enabled via AppleATIATA.kext)
USB: All 6 rear & both front ports 
GPU: XFX ATI Radeon HD 5750 1024MB (Enabled via attached kexts below)

LAN: Realtek RTL8168 (Enabled via Lnx2Mac's RTL8XXX driver)
Audio: M-Audio FastTrack USB Interface / HDMI (Enabled via attached DSDT.aml) / Onboard VIA VT1708S (All outputs enabled via attached VoodooHDA.kext)

Sleep: Enabled via patched USB kexts from 10.6 attached below

PS2: N/A

 

Bootloader: Chameleon 2.2svn r2181
Kernel: Sinetek's v4 Kernel (flags: darkwake=0 npci=0x2000 busratio=15 fsb=245)
OSX: 10.9 via MyHack USB Install Method (Updated safely to 10.9.1 via AppStore) 

 

DSDT: https://db.tt/JizltgVE

Graphics Kexts: https://db.tt/gsVv1DGL

VoodooHDA for Onboard Audio: https://db.tt/qQtbabtN

Patched USB Kexts: https://db.tt/j9yOVuDe

AppleATIATA.kext (IDE) : http://puu.sh/7JG0Y.zip

 

 

5QvOr.png

 

Notes:  

 

No more graphics corruption thanks to the system.kext patches by Sinetek!!!  The only remaining issues I have are some pink icons in Launchpad, and some corruption around icon labels on the desktop.  Nothing major, perfectly tolerable for me. 

 

One thing I did have to do as kind of a workaround after installing the older patched USB kexts from 10.6, was install official kexts for my M-Audio FastTrack from the website.  It was previously detected OOB with Mavericks, but it stopped working when I installed the old USB kexts, so installing the official kexts from M-Audio fixed that issue for me.  Im assuming this might be an issue for other USB audio interfaces as well.  Just a heads up if you use these kexts.  

 

Also, I have working iCloud services with sync enabled (no iMessage or FaceTime though) via a fix by theconnatic involving merging an iCloud enabled account from an Intel Hackintosh (or real Mac) to the AMD machine using Migration Assistant.  Many, many thanks to everyone involved with getting my Mavericks installation up and running!   

 

***

 

EDIT:  I've been getting a lot of private messages asking me how I got iCloud working, so I figured I'd link theconnatic's original post about it: 

 

http://www.insanelym...ound/?p=1852906

 

***

 

5QeqU.png

 

 

5nymF.png   



#98
granik

granik

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
  • Gender:Male
Снимок экрана 2013-11-10 в 1.19.27.png

 



#99
Chris Etheridge

Chris Etheridge

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
  • Gender:Male
  • Location:South Africa
  • Interests:Web development
    Web design
    Good music

CPU - AMD Athlon X2
Motherboard - Biostar A780L
GPU - ATI HD5770 1GB
Kernel - Andy's RC6 Kernel
RAM - 4Gb DDR2
Hard Drive - 2 X 160GB SATA
USB Ports - 4 at the back and 2 in front (all work)
LAN  - Realtek RTL8168 using RTGMac 

Wifi - Trendnet TEW 648-UB (works using Snow Leopard drivers from the disc)
Audio - Realtek ALC662 - used Voodoo HDA 2.8.4
Sleep - working OOB
 

Lion works flawlessly, used Bronzvokas Lion 10.7.5 kernel and iAtkos L2 to install.

Mavericks also works amazingly.

 

Created a USB installer using Insanelymac's Pandoras Box (thank you!). Booted using Andy's kernel, with the flags "USBLegacyOff=yes npci=0x2000 -v". Installed fine and then booted fine too. First boot was EXTREMELY slow, left my machine on over night to allow Spotlight to index everything. Then replaced the System.kext with Andy's one, and everything worked fine. Graphics works 100%, and everything is very smooth.

 

Bootloader is Chameleon, using the flags "-v USBLegacyOff=Yes npci=0x2000"

 

iCloud / AppStore etc. does not work unfortunately. (no biggy though).

 

Screenshot_2013_11_10_12_53_35.png



#100
ADES21

ADES21

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
  • Gender:Male
  • Location:Spain

Mavericks on AMD FX with nVidia Full working  :D

Attached Files







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy