Jump to content

[AMD] Working Builds!


  • Please log in to reply
192 replies to this topic

#181
EsLam Easa

EsLam Easa

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

anyone have Turion  ii p520 ...


anyone have Turion  ii p520 ...



#182
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,824 posts
  • Gender:Male
  • Location:português
Create a dsdt either OS X or Windows or Linux with the dsdt-editor Tool and upload it here.
http://www.insanelym.../297774-amd-dmg development/

Then you can create with myhack.app vers. 3.3.1 a Mavericks USB installer and use the DSDT.aml or ssdt.aml then your Laptop will run with os x . Make yourself not severe.

#183
gils83

gils83

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,620 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique

:)

 

Danube PGA CPU 638 is equivalent to a Atlhon II, so it must be running OS X with a patched kernel AMD.

Now you have a dual GPU system somewhat equivalent to an Intel optimus except that the video drivers for the HD 4250 (880 G) does not exist in OS X.

Then your HD 5470m runs under OS X (I already tested on Intel).

advice I can give you is to start with the distro iATKOS S3 V2 (10.6.3) ensure that the bios has AHCI and boot with flag: busratio=9 -v -f -x arch=i386 UseKernelCache=No

if you do not have AHCI, you can try by hazard 10.6.2

 
 
 
 
 
 
 


#184
EsLam Easa

EsLam Easa

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

 

:)

 

Danube PGA CPU 638 is equivalent to a Atlhon II, so it must be running OS X with a patched kernel AMD.

Now you have a dual GPU system somewhat equivalent to an Intel optimus except that the video drivers for the HD 4250 (880 G) does not exist in OS X.

Then your HD 5470m runs under OS X (I already tested on Intel).

advice I can give you is to start with the distro iATKOS S3 V2 (10.6.3) ensure that the bios has AHCI and boot with flag: busratio=9 -v -f -x arch=i386 UseKernelCache=No

if you do not have AHCI, you can try by hazard 10.6.2

 
 
 
 
 
 
 

 

i think all problem is related to GPU and it's the first card which is (880) 

i found someone on youtube have the same pc and get it worked ... 

i will try niresh maveric ... maybe it will help ...

 

but i don't know how to get this card worked (880)

 

if i put the correct kext and boot flags for both card it should work !! or it won't !! 

 

bro bro i don't have ahcl in my bios setup 

 

in hp laptop you don't have all of this option ..

 

i think it's AHCL by default  :) 



#185
gils83

gils83

    InsanelyMac Deity

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,620 posts
  • Gender:Male
  • Location:France
  • Interests:le soleil du var et l'informatique

and boot flag = busratio=9 fsb=200 Mhz PCIRootIUID=1 GraphicsEnabler=No -v -f -x with chameleon 



#186
EsLam Easa

EsLam Easa

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts

i have note that it not related to boot flag (maxmem_ or any thing it just usb flash ... that makeing this 

 

i have to pulg and replug the usb flash serveral time in order to boot .. and when it booted touch pad and keybord doesn't work 



#187
Hervé

Hervé

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 543 posts
  • Gender:Male
  • Location:Rennes, BZH of course!

EsLam Easa, no offence meant, but you're now effectively polluting a thread about working builds with your own, so far unsuccessful, research. Please open up a dedicated thread for this and once you have it working you can return here with your detailed foundings & settings. Thanks.



#188
Savva_Mitrofanov

Savva_Mitrofanov

    InsanelyMac Protégé

  • Members
  • Pip
  • 32 posts

ASUS M3N78-EH:

South Bridge: MCP78S similar  to MCP79 which used in MacMini 3,1 so i set smbios to Mac mini 3,1 and many devices work oob after editing dsdt

Audio : ALC883 - using patched by my hand AppleHDA

LPC : dsdt patched

smbus : dsdt patched

rtc,,ipic,hpet : dsdt patched and renamed

usb : dsdt patched , using vanilla kext, i spend a lot of time to solve sleep issues on this stuff , chines leaked data sheets help me in this 

Sleep : working perfectly

Wake-On-Lan : working perfectly

all monitor and other garbage like ps/2 cleaned from dsdt

CPU AMD Athlon 64 X2 5000+ - VoodooTSCSyncAMD to solve lags

cool & quite : working via editing p-states in ssdt and using p-state changer, however i don't use them

Video: NVIDIA Geforce 9800 gt working oob , just edited dsdt

Sata: patched as intel ich6 in dsdt, mcp 79 don't work cause it completely different ahci chip from 78s

Bootloader : Clover

Ethernet : Nvidia nforce lan - works well with nforcelan kext , but no wol , so i  disabled onboard lan and bought new nic

RTL8169(SC) - slice's kext works fine

Kernel and OS version: not matter , i'm sitting on current working system from snow leopard , just changing kernel's and updating os, now i'm on 10.9.5

and using bronya's rc2 kernel based on 10.9.4 sources

So in conclusion , i just use 3 non-apple kext's : voodootscsyncamd , applertl8169ethernet, fakesmc



#189
Hacker Pro

Hacker Pro

    InsanelyMac Protégé

  • Members
  • Pip
  • 38 posts
  • Gender:Not Telling
  • Interests:Hackintoshing, Playing around with virtual machines, and Gaming.

Do virtual machines count?


Do virtual machines count?



#190
Hervé

Hervé

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 543 posts
  • Gender:Male
  • Location:Rennes, BZH of course!

No.



#191
dodo

dodo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 130 posts

I'm running 10.8.5

 

CPU: AMD FX-8120
Motherboard: Gigabyte 990FXA-UD3 rev1.1 
RAM: 2x 8GB
SATA: 128GB SDD + 1.5TB HDD + 165GB HDD
GPU: Gigabyte GT610
LAN: onboard Realtek RTL8111e (using this driver)
Audio: onboard Realtek ALC889 (using this driver)
 

The only other kext files I needed are FakeSMB and NullCPUPowerManagement.

 

using MacPro 5.1 template for smbios.plist (using Chamelion Wizard)

 

using GraphicsEnabler=yes npci=0200 for kernel flags

 

 

What kernel do you have?



#192
dodo

dodo

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 130 posts

 

OSX 10.8.5

CPU     - AMD fx-8320 8 core 3.5 ghz

MOBO - ASUS Sabertooth 990FX REV 1.0

RAM - Corsair 1600 2x4GB

GPU    -AMD Radeon HD 7850 2GB (ASUS DIRECT CU II ) - working with screen rotation trick.

USB     -keyboard and mouse

BOOTLOADER     - CLOVER 2184

KERNEL - Sinetek's  fx kernel

some glitches FULL QE/CI

2 systems on 1 sata hdd with EFI CLOVER (WIn 8 + OSX)

 

Now

OSX 10.9

BOOTLOADER     - CLOVER 2236

Kernel Sinetek

 

hi can you provide me your steps to get 10.8.5 install

 

i got it install now evertime i boot i get kernel panick

 

using this kernel
http://www.hackintos...md-108x-kernel/

with kernel flag npci=0x2000

 

i have similer config

Asus M5A99FX

AMD FX 8350

16GB DDR 3 1600MHz

Nvidia 760 4GB

SSD 240GB



#193
spakk

spakk

    If you try to please everyone, then you have certainly forgotten

  • Members
  • PipPipPipPipPipPipPipPipPipPip
  • 1,824 posts
  • Gender:Male
  • Location:português
@dodo

here you find a instructions and various tools to install Mavericks OS X on your AMD Computer

http://rampagedev.wo...m/amd-dmg/asus/

Downloade the Amd.dmg file therein are various tools, SSDT.aml for your Hardware that can you use for your project to install Mavericks.





2 user(s) are reading this topic

0 members, 2 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy