Jump to content

Asus EAH6850 modified ATI6000Controller.kext


  • Please log in to reply
9 replies to this topic

#1
scrawld

scrawld

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
I've modified the ATI6000Controller.kext to get the HDMI and second DVI ports working. I've only tried two combinations (HDMI & DVI-I; DVI-I & DVI-D). The DVI-I (upper port) works with DVI and a DVI-VGA adapter. I have not tested the DP. My computer couldn't boot with the other modified kexts for the EAH6850 that have been posted on the forums.

This is the first time that I've done something like this, so if I've mucked up something, let me know so that I can fix it.

My system is a ######/###### non-DSDT installation on a GA-Z77X-UD5H. I have ATIConfig=Duckweed and ATIPorts=4 in my plist.

The modified Duckweed personality info:

00 04 00 00 04 03 00 00 00 01 00 00 12 04 04 01
00 08 00 00 04 02 00 00 00 01 00 00 22 05 03 04
04 00 00 00 14 02 00 00 00 01 00 00 01 02 05 06
00 02 00 00 14 02 00 00 00 01 00 00 00 00 06 05

Hardware Info:


AMD Radeon HD 6850:

Chipset Model: AMD Radeon HD 6850
Type: GPU
Bus: PCIe
PCIe Lane Width: x16
VRAM (Total): 1024 MB
Vendor: ATI (0x1002)
Device ID: 0x6739
Revision ID: 0x0000


Many thanks to Fishcow and Martinez (his guide: http://www.insanelym...ectors-to-work/)

Attached Files



#2
shiecldk

shiecldk

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts
  • Gender:Male
  • Location:Taiwan
Can the personality pass the 10.8 installation white screen?

My patched ATI6000Controller.kext can't pass the white screen in the 10.8 installation. I have to delete it before the installation.

#3
scrawld

scrawld

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
I'm not sure I understand you. Do you mean using the personality in order to be able to install ML with a 6000 series card? I doubt it. I haven't used the card or the personality for an installation of ML. I never had any trouble installing Lion with it, but this modified kext will only work with ML.

#4
shiecldk

shiecldk

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts
  • Gender:Male
  • Location:Taiwan
I'm curious how real mac's HD 6xxx pass the 10.8 installation. I haven't see anyone with 6xxx card pass the installation without removing the driver.

#5
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,076 posts
  • Gender:Male
  • Interests:AKern@RampageDev.com

I'm curious how real mac's HD 6xxx pass the 10.8 installation. I haven't see anyone with 6xxx card pass the installation without removing the driver.


Its called EFI....

#6
shiecldk

shiecldk

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 233 posts
  • Gender:Male
  • Location:Taiwan

Its called EFI....

So if I use an EFI VBios for HD 6xxx cards, then I can pass the white screen?

Have you seen this?
http://forum.netkas....opic,692.0.html

Although it said only works on real macs, I think maybe UEFI+Clover can get it work too.

#7
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 2,076 posts
  • Gender:Male
  • Interests:AKern@RampageDev.com

So if I use an EFI VBios for HD 6xxx cards, then I can pass the white screen?

Have you seen this?
http://forum.netkas....opic,692.0.html

Although it said only works on real macs, I think maybe UEFI+Clover can get it work too.


No, EFI has nothing to do with Hackintosh's but it has to do with a real Mac. Your are just over think it. DSDT injection and then placing the DSDT in your extra folder on the install USB will get you around the white screen without removing drivers. But really why is this a issue when you only install once or twice and then you are up and running 100%...

Also clover has nothing to do with this either. You are not understanding what each app and item is doing...

#8
markfultonncl

markfultonncl

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
scrawld,

A huge thanks for this - My EAH6850 now all working perfectly with ML 10.8.2 and

ATIConfig=Duckweed and ATIPorts=4 :)



#9
scrawld

scrawld

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
glad to hear that it worked for you, mark

#10
TH3L4UGH1NGM4N

TH3L4UGH1NGM4N

    (~_~)

  • Retired
  • 1,159 posts
  • Gender:Male
  • Location:Wonderland
  • Interests:(~_^)
Might be a bit late but I own a 6870 and to get pass the white screen installer I just simply put my system to sleep and then wake it and then I'm presented with the normal installer screen. I was contemplating on flashing the vbios but said meh I'd just leave the card alone.

But yeah, you could try the sleep and wake and see how it works out. Found the topic a bit late though.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy