Jump to content

Toshiba Portege M400, Native success


  • Please log in to reply
109 replies to this topic

#61
Siegfried

Siegfried

    InsanelyMac Protégé

  • Members
  • Pip
  • 44 posts

I'll let you know if I have any luck. I'll try it when it arrives and fingers crossed it might work

I tried a PCMCIA card, but I couldn't get the cardbus controller to work in 10.4.10, even after I recompiled the driver with support for this model. If you have any luck let me know. I have yet to try it in 10.5.

#62
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

I tried a PCMCIA card, but I couldn't get the cardbus controller to work in 10.4.10, even after I recompiled the driver with support for this model. If you have any luck let me know. I have yet to try it in 10.5.


Thanks for your reply. i don't have a clue how to recompile the driver if it doesn't work. I'm still very much a new newbie. i may ask be asking for some assistance if that's ok?

Spadge

#63
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
PCMCIA card arrived today but it doesn't work. The card isn't recognised by OSX. Anyone have any ideas as to what I can do next?

Thanks

Spadge

#64
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

PCMCIA card arrived today but it doesn't work. The card isn't recognised by OSX. Anyone have any ideas as to what I can do next?

Thanks

Spadge


Carpao,

What USB Wifi Card do you use?

#65
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

Carpao,

What USB Wifi Card do you use?


I used in Tiger the ASUS WL 167G but I didn't installed it in leopard till now

#66
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

I used in Tiger the ASUS WL 167G but I didn't installed it in leopard till now


Does Leopard recognise the card natively or require drivers?

#67
Alex_Br

Alex_Br

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi ! I am M400 owner too.
I use Kaliway Leopard.
How to configure MagicTablet to work with M400?
I installed the last version, but it can't find my tablet...

Alex from Moscow, Russia.

#68
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

Hi ! I am M400 owner too.
I use Kaliway Leopard.
How to configure MagicTablet to work with M400?
I installed the last version, but it can't find my tablet...

Alex from Moscow, Russia.


I haven't played around with the tablet functionality yet so I'm afraid I can't help!

sorry....

#69
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

Hi ! I am M400 owner too.
I use Kaliway Leopard.
How to configure MagicTablet to work with M400?
I installed the last version, but it can't find my tablet...

Alex from Moscow, Russia.


I assume that you already changed the serial configuration byinserting WAC004 like for tiger
after that I had probably your same problem: no serial detected...
what I did is:

I booted one time with the tohkernel instead of vanilla and the serial ... was there
after that i booted again with the vanilla kernel... and it was still there :-D


I received a confirmation by another user that it worked for him too... so try it and let us know

#70
Alex_Br

Alex_Br

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 2 posts
Hi, Carpao!

I assume that you already changed the serial configuration byinserting WAC004 like for tiger
after that I had probably your same problem: no serial detected...
what I did is:

I didn't use Tiger and nothing changed in Leopard' serial configuration...

I booted one time with the tohkernel instead of vanilla and the serial ... was there
after that i booted again with the vanilla kernel... and it was still there :-D

Sorry, how can I run "tohkernel" when I am using Kaliway Leopard install (EFI_8 MBR + Vanilla) ?

What sofware do u use for handwriting ?
Is there something like Ms Onenote for Mac ?

#71
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

Hi, Carpao!

I didn't use Tiger and nothing changed in Leopard' serial configuration...

Sorry, how can I run "tohkernel" when I am using Kaliway Leopard install (EFI_8 MBR + Vanilla) ?

What sofware do u use for handwriting ?
Is there something like Ms Onenote for Mac ?


1) to expose the serial
Edit info.plist:
/system/library/extensions/Apple16X50Serial.kext/Contents/PlugIns/Apple16X50ACPI.kext/Contents/Info.plist
change IONameMatch string:
PNP0501 to WAC004


2) to boot with tohkernel itis enough to write
tohkernel at the boot


3) there exists inkwell but the handwriting recognition is very primitive...
it is possible to enable it bye tabletmagic

however the pen support is good (pression, precuision etc) so the problem is the lack of software
perhaps there is something to port from the linux world...

#72
xtiank

xtiank

    InsanelyMac Protégé

  • Just Joined
  • Pip
  • 4 posts
Hi there, has anyone had any luck getting the pcmcia slot to work - im nearly at the end of the road for this machine as i just wanna get a wireless going so i can work on it... tried swapping out the minipci - no work 'cause of hardware lockout - and just recieved a cardbus one with a native driver, but no slot working, booo

ive copied the nice kexts from http://forum.insanel...amp;mode=linear

but they dont seem to make it work - think its the vendor / dev id thing - which for the kext in question IOPCCardFamily.kext seems to be a little complex to edit

is there anyone out there that can give me a clue on this one before I go and buy a macbook and have done with the idea of a mac tablet....

cheers

christian

#73
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

Hi there, has anyone had any luck getting the pcmcia slot to work - im nearly at the end of the road for this machine as i just wanna get a wireless going so i can work on it... tried swapping out the minipci - no work 'cause of hardware lockout - and just recieved a cardbus one with a native driver, but no slot working, booo

ive copied the nice kexts from http://forum.insanel...amp;mode=linear

but they dont seem to make it work - think its the vendor / dev id thing - which for the kext in question IOPCCardFamily.kext seems to be a little complex to edit

is there anyone out there that can give me a clue on this one before I go and buy a macbook and have done with the idea of a mac tablet....

cheers

christian


Have you had any luck with this?

I too am trying to get a PCMCIA card to work, I have kalyway 10.5.1 (soon to be 10.5.2) what are you running

#74
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

(soon to be 10.5.2) what are you running


remember to report the procedure and hints that you used and possibly opinions on the difference for our computer

#75
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

Does Leopard recognise the card natively or require drivers?


update: I used the same dirver that i used under Tiger and they works in leopard too (I'm using the wireless connection now)

#76
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts

remember to report the procedure and hints that you used and possibly opinions on the difference for our computer


Success my M400 is now running 10.5.2 with the 9.2.0 vanilla kernel. I followed the foodie monsters instructions on page 104 on the kalyway 10.5.1 thread (http://forum.insanel...c=77069&st=2060).

So far everything looks ok albeit only had 15 mins worth of use.

I have just run the software update utility and installed the Leopard graphics update and now I just get a blue screen on reboot. If I attach an external monitor I can get into the GUI but not with the builtin laptop screen. Any ideas how to rollback this update?

Ended up doing a reinstall of everything. Do not install the Graphics Update if you run a intel GMA 950 graphics card.

Here is the PCMCIA info which is displayed in About This Mac

Type: Cardbus Bridge
Driver Installed: No
Bus: PCI
Slot: PCI Slot 0
Vendor ID: 0x104c
Device ID: 0x8039
Revision ID: 0x000

Do other M400 report the same properties. I haven't tried to install the kext yet as I think they will need editing which I do not know how to do yet.

#77
spadge

spadge

    InsanelyMac Protégé

  • Members
  • Pip
  • 41 posts
I now have the PCMCIA slot working on the M400.

I used Chun-Nan's IOPCIFamily.10.5.2.beta.zip. Read the info on the thread from Page 21 onwards. Most important point is to repair permissions before boot. To get both firewire and pcmcia working I had to seperate the kext and load them seperately (see page 23) http://forum.insanel...&...st&p=630767
Spadge

#78
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

I now have the PCMCIA slot working on the M400.

I used Chun-Nan's IOPCIFamily.10.5.2.beta.zip. Read the info on the thread from Page 21 onwards. Most important point is to repair permissions before boot. To get both firewire and pcmcia working I had to seperate the kext and load them seperately (see page 23) http://forum.insanel...&...st&p=630767
Spadge



I'll check it too... thx

#79
Cypherion

Cypherion

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
After 8 reinstalls. I had MAC OSX86 working. I used Kaliway 10.5.1. I tried patching it with 10.5.2, it resulted in kernel panic even if I fixed the permissions.

Here's the status of my install...

Toshiba Portege M400
- Video OK (with acceleration out of the box)
- Audio OK (though HDAPatcher)
- LAN OK
- Wireless USB LAN OK (internal LAN not working; am using Realtek USB WIFI)
- Sleep OK
- USB Devices OK (Mouse and USB Sticks)

NOT WORKING
- Bluetooth (Kext update did not work for me)


Next project, to get my Nokia Phone to be used as a 3G modem.

#80
carpao

carpao

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 108 posts

After 8 reinstalls. I had MAC OSX86 working. I used Kaliway 10.5.1. I tried patching it with 10.5.2,

the automatic apple update does not work , but there is a post that explain how to do it (i didn't try it yet however)

- Bluetooth (Kext update did not work for me)
Next project, to get my Nokia Phone to be used as a 3G modem.

did you try what suggested in http://forum.insanel...&...st&p=569544

I use internal bluetooth without problem (or better I have to reload the extension after the sleep)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy