Jump to content

Will this card work with ML OOB?


  • Please log in to reply
13 replies to this topic

#1
wws12

wws12

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
Hi.

I am looking to purchase this card to add wifi functionality to my ML system. Rampage Dev commented on another post that the device id cannot be xx27 or 27xx or xx23 or 23xx. I'm not sure how to tell if this is a OK card to use or not, could someone help me? Or should I purchase a Airport Extreme card off of ebay?

http://www.ebay.com/...=item51a2672914

#2
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
yes it works great, i use it.

OOB no mods.. its device id 2A from atheros.

rampage dev means the broadcom device 4713 will never work.

#3
wws12

wws12

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts

yes it works great, i use it.

OOB no mods.. its device id 2A from atheros.

rampage dev means the broadcom device 4713 will never work.



What does device ID mean? Will I have to enter it somewhere?

#4
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida

What does device ID mean? Will I have to enter it somewhere?


this one works without any mods.

atheros vendor id 106C device id 2A is in the kext since 10.6.3

broadcom device id 4713 is not.

#5
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

What does device ID mean? Will I have to enter it somewhere?

What are vendor and device IDs and how do I use them?

#6
wws12

wws12

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts

this one works without any mods.

atheros vendor id 106C device id 2A is in the kext since 10.6.3

broadcom device id 4713 is not.


Could you recommend a good quality mini PCI to pci-e adapter? I looked around on eBay and amazon but all the ones I found had mixed reviews. Thanks for your help!

#7
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
all are about the same. no actual chip on the adapter.. just wired.
http://www.ebay.com/...i-/310424537655
the metal is just a cover.. wifi card goes under it.

#8
wws12

wws12

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts

all are about the same. no actual chip on the adapter.. just wired.
http://www.ebay.com/...i-/310424537655
the metal is just a cover.. wifi card goes under it.


Thank you very much!

#9
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
u do understand u have to buy laptop wifi AR5B91 X card separate and add it to the mini to pci-x adapter i posted above?

#10
wws12

wws12

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts

u do understand u have to buy laptop wifi AR5B91 X card separate and add it to the mini to pci-x adapter i posted above?


Yup, I'm going to buy the one in the OP

#11
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
As Latin suggested and I'll 2nd, there's really no such thing as a "good quality" mini-pcie to pcie adapter, they're pretty much all borderline rubbish; but they're cheap, get the job done and because they're cheap, if it doesn't work or breaks you can buy another one. :) As example, which seems to be a common "flaw", on mine the pci backplate needed a bit of adjustment to fit right, it was completely straight and didn't have the little bit of angle needed where the tab part slides behind the edge or your mobo, just compare it to your slot cover you remove to put it in and adjust as needed.

#12
wws12

wws12

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts
@LatinMcG

I successfuly installed the card and adapter and it works fine...under Windows 7! When I boot OS X 10.6.8, I get Failed to load kext: com.apple.driver.AirPort.Atheros21. I also get a Failed to load IO80211family error. How can I fix this? I used ##### if that makes a difference.Thanks!

#13
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,509 posts
  • Gender:Male
  • Location:Tampa, Florida
its your install source likely... iatkos ?
or all the modifications u did before switching card to this one.
i never had that problem with AR5B91

#14
wws12

wws12

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 105 posts

its your install source likely... iatkos ?
or all the modifications u did before switching card to this one.
i never had that problem with AR5B91


I fixed it. I was booting with the legacy kernel instead of the mach kernel. Thanks!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy