Jump to content

Clover General discussion

Bootloader EFI Clover

  • Please log in to reply
4247 replies to this topic

#1561
okmacok

okmacok

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I need advices about kext injections.
http://www.insanelym...s/#entry1853406

Should I use clover kext injections or should I install kexts with a tool like this one :
http://www.osx86.net....8_edition.html

Clover kext injection seems more slow...
What are the add and cons ?

I imagine that clover kext injection can be fine for testing for example ? But "normal" kexts installation are fine for definitive use ?
Or Clover kext injection are the best anyway in the point of view of simplicity and clarity ? (or maybe usefull only in case of multiple Os ?)

#1562
antoniodapc

antoniodapc

    InsanelyMac Legend

  • Donators
  • 546 posts
  • Gender:Male

I would like to start by
EFI with the new release of Clover EFI from Usb Stick



I tried to install Clover EFI package EFI only USB ( Fat32)
but nothing when I tell him to select EFI USB stick
I have only the black screen in the emergency command with the cursor flashing.

Can you give me a hand please?

Did you try BootDiskUtility.exe ?

here is a too long help about this tool, but there good informations here :
http://www.osx86.net...enovo-g570.html


I have read your guide, but my problem is not that the key is not boottabile is the next step, because the motherboard find the presence of EFI file in the Key

#1563
xpamamadeus

xpamamadeus

    InsanelyMac Sage

  • Donators
  • 489 posts
  • Gender:Male
  • Location:Croatia

I need advices about kext injections.
http://www.insanelym...s/#entry1853406

Should I use clover kext injections or should I install kexts with a tool like this one :
http://www.osx86.net....8_edition.html

Clover kext injection seems more slow...
What are the add and cons ?

I imagine that clover kext injection can be fine for testing for example ? But "normal" kexts installation are fine for definitive use ?
Or Clover kext injection are the best anyway in the point of view of simplicity and clarity ? (or maybe usefull only in case of multiple Os ?)

Use clover only when installing OSX or having problems with installed one in S/L/E,otherwise install kext in S/L/E

#1564
okmacok

okmacok

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

Use clover only when installing OSX or having problems with installed one in S/L/E,otherwise install kext in S/L/E

Thank you !

Is it a good idea to use clover for testing ?

I have read your guide, but my problem is not that the key is not boottabile is the next step, because the motherboard find the presence of EFI file in the Key

My suggestion is to use the BootDiskUtility
Here is a more simple explanation :
http://www.insanelym...h-macosx-distr/

BootDiskUtility is great. With it I made a USB key with 2 partitions : One with clover and the second with MacOS Install

Did you make this first step ? About the problem you have ("the key is not boottabile is the next step, because the motherboard find the presence of EFI file in the Key")
do you have you this problem with the USB Key created with BootDiskUtility ?

#1565
Vlad

Vlad

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Romania
hello all,

i try to boot OSX in verbose mode (-v) but when OSX starts booting no text is displayed on screen until the system is fully loaded and the desktop appears
What do i have to do to se the booting procedure?

Also if I'm trying to boot without -v option no booting logo is displayed, same as described before a black screen appears and afterwards the desktop.

#1566
alexanderq

alexanderq

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 155 posts
  • Gender:Male
How did you try booting in verbose mode?
Using space bar?
Writing -v in

<key>SystemParameters</key>
<dict>
<key>boot-args</key>
<string>-v</string>

#1567
Vlad

Vlad

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Romania
yes, and the behaviour is one displayed earlier :(

#1568
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,530 posts
  • Gender:Male
  • Location:Moscow

hello all,

i try to boot OSX in verbose mode (-v) but when OSX starts booting no text is displayed on screen until the system is fully loaded and the desktop appears
What do i have to do to se the booting procedure?

Also if I'm trying to boot without -v option no booting logo is displayed, same as described before a black screen appears and afterwards the desktop.

It seems you have such hardware. :wallbash:

#1569
xpamamadeus

xpamamadeus

    InsanelyMac Sage

  • Donators
  • 489 posts
  • Gender:Male
  • Location:Croatia

yes, and the behaviour is one displayed earlier :(

try F1 like in all other software when u need help.

#1570
jlfilms

jlfilms

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 201 posts
  • Gender:Male
  • Location:Cali
  • Interests:Hackintoshs
Hey guys , tried making over clocked ssdt last nite for my rig, added few lines to config list an dropped ssdt into patched folder an now I can't boot can someone plz help ? When I boot in -v I see it says fakesmc problem , thanks for any advice, btw I already deletd the ssdt from clover shell an booted with no Kexts no luck


#1571
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,530 posts
  • Gender:Male
  • Location:Moscow

Hey guys , tried making over clocked ssdt last nite for my rig, added few lines to config list an dropped ssdt into patched folder an now I can't boot can someone plz help ? When I boot in -v I see it says fakesmc problem , thanks for any advice, btw I already deletd the ssdt from clover shell an booted with no Kexts no luck

What is the question if it is fakesmc problem?

#1572
antoniodapc

antoniodapc

    InsanelyMac Legend

  • Donators
  • 546 posts
  • Gender:Male
Please I need Help

where can I download the EFI folder to be inserted in USB formatted Fat32 ?

#1573
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,530 posts
  • Gender:Male
  • Location:Moscow

Please I need Help

where can I download the EFI folder to be inserted in USB formatted Fat32 ?

Official download page -> Installer
Attached File  Screen Shot 2013-05-13 at 21.26.10.png   180.19KB   26 downloads

#1574
tdtran1025

tdtran1025

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 343 posts
I have 2 machines with identical motherboards (Asus P5Q-Pro), except for the NVidia cards-1 is 8800GTX, the other 250GTS. Clover1635 on USB stick boots the 8800GTX to GUI screen, but on 250GTS, a menu context screen appears that go no further than a loop back. All I can think of is the video card makes all the difference.
What can I do to make clover boot to GUI the machine with NVIdia 250GTS?
Thank you anyone.

#1575
PJALM

PJALM

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
  • Gender:Male
I see since build 1637 that the refit.conf and settings.conf have been removed and moved to the config.plist and new theme.plist. I can't find any documentation on what settings have been moved to where. I managed to create the theme.plist for the theme I am using but a lot of the settings from the old settings.conf are not in the themes.plist included in latest build.

Is there somewhere we can see what has been moved to where and what one no longer exsist etc?

Thanks

#1576
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 2,530 posts
  • Gender:Male
  • Location:Moscow

I have 2 machines with identical motherboards (Asus P5Q-Pro), except for the NVidia cards-1 is 8800GTX, the other 250GTS. Clover1635 on USB stick boots the 8800GTX to GUI screen, but on 250GTS, a menu context screen appears that go no further than a loop back. All I can think of is the video card makes all the difference.
What can I do to make clover boot to GUI the machine with NVIdia 250GTS?
Thank you anyone.

Exchange video cards to check.

I see since build 1637 that the refit.conf and settings.conf have been removed and moved to the config.plist and new theme.plist. I can't find any documentation on what settings have been moved to where. I managed to create the theme.plist for the theme I am using but a lot of the settings from the old settings.conf are not in the themes.plist included in latest build.

Is there somewhere we can see what has been moved to where and what one no longer exsist etc?

Thanks

Sorry, don't discuss revisions above 1635 until special instructions.

#1577
antoniodapc

antoniodapc

    InsanelyMac Legend

  • Donators
  • 546 posts
  • Gender:Male

Official download page -> Installer
Attached File  Screen Shot 2013-05-13 at 21.26.10.png   180.19KB   26 downloads


thank you very much for your recommendation now I try

#1578
Vlad

Vlad

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Romania
is there an embedded method to enable HD4000 using clover similar to http://www.insanelym...ig-platform-id/ ?

#1579
alexanderq

alexanderq

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 155 posts
  • Gender:Male
There are a lot of things about clover my friend.

<key>Graphics</key>
<dict>
<key>GraphicsInjector</key>
<string>Yes</string>
<key>ig-platform-id</key>
<string>0x01620005</string>
</dict>

#1580
Vlad

Vlad

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
  • Gender:Male
  • Location:Romania

There are a lot of things about clover my friend.

<key>Graphics</key>
<dict>
<key>GraphicsInjector</key>
<string>Yes</string>
<key>ig-platform-id</key>
<string>0x01620005</string>
</dict>


thanks for the quick reply, i will try it later this day. I expected to by as you say, it would be more usefull if those informations are available inside a separate thread because here is way to much information to dig into





Also tagged with one or more of these keywords: Bootloader, EFI, Clover


2 user(s) are reading this topic

1 members, 1 guests, 0 anonymous users


© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy