Jump to content

Clover General discussion

Bootloader EFI Clover

  • Please log in to reply
7311 replies to this topic

#1541
Andy Vandijck

Andy Vandijck

    InsanelyMac Deity

  • Coders
  • 1,857 posts
  • Gender:Male
  • Location:Tienen
  • Interests:Programming stuff for Mac OS X...
    Hacking...
    Hard rock (also really big Metallica...

MacBookPro10,1 has HD4000, no?

Oops... you're right.
Had them confused.
It's an earlier model I mean...

#1542
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,729 posts
  • Gender:Male
  • Location:Moscow

Oops... you're right.
Had them confused.
It's an earlier model I mean...

I took ioreg from MacBookPro8,2 with HD3000 and there is no ig-platform-id. It is for 4000 only.

#1543
tluck

tluck

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 864 posts
  • Gender:Male
  • Location:NC, USA
@Andy Vandijck -

i have a laptop with HD3000 (only) gfx. MacBookPro8,1 is a good match. happy to help you get it running if i can. however, i use dsdt.aml.

Note: i could be wrong, but i think HD 3000 gfx is only with 2nd gen core i3/i5/i7. Pentium procs have HD Graphics, no? it maybe "sandy bridge" but ...

"The Pentium B980 integrates a graphics card called Intel HD Graphics that is based on the desktopHD Graphics 2000 clocked at 650 / 1150 (with Turbo Boost)."

#1544
xpamamadeus

xpamamadeus

    InsanelyMac Legend

  • Donators
  • 588 posts
  • Gender:Male
  • Location:Croatia

@Andy Vandijck -

i have a laptop with HD3000 (only) gfx. MacBookPro8,1 is a good match. happy to help you get it running if i can. however, i use dsdt.aml.

Note: i could be wrong, but i think HD 3000 gfx is only with 2nd gen core i3/i5/i7. Pentium procs have HD Graphics, no? it maybe "sandy bridge" but ...

"The Pentium B980 integrates a graphics card called Intel HD Graphics that is based on the desktopHD Graphics 2000 clocked at 650 / 1150 (with Turbo Boost)."

As i allready say it.
U are right pentiums dont even have hd 2000/3000 its only intel hd graphics.
http://www.cpu-world...hics_units.html

#1545
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,729 posts
  • Gender:Male
  • Location:Moscow
What is the sense to name it "HD Graphics" or "HD 3000" if I see deviceID=0x106 that corresponds to Apple's driver HD3000?

#1546
Deridjian

Deridjian

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Zacatlán, Puebla
Hi everyone,

I'm desperetaly trying to get Clover to work on USB to try it out with my existing Installations. Already read a bunch of discussions, guides and threads about it, but I just couldn't nail it. The resulting stick never gets recognized after UEFI load (I did of course change boot orders). It goes directly into my existing Installation on most occasions. I did have two cases where the screen just went black and one where I had a Slash stuck in the corner. I tried different versions of Clover, different partition formats, different install methods. The most recent installer (v2_r1526) looks totally different to almost every documentation I can find online. In the SourceForge repository there's even a "bootable ISO" to download. Which I downloaded, mirrored to my stick and … nothing. I don't have to install an OS to the stick do I? I don't have to change anything in the UEFI more than the boot device, do I?
I cannot imagine to be the only fool who can edit VBIOS ROMs and Framebuffer but not install Clover to a pendrive…I'm crying, seriously.
My board is a GA-H77-D3H with a Xeon E3-1230v2 CPU. It's not like I haven't booted USB before on my board either…
I know this question is completely anti-1337 but as I say, I feel like there are more ppl like me out there who would really like to test clover but just can not get it to work for such simple things. Any ideas are incredibly welcome, sorry for my noobishness.
Greetings

Deri~

#1547
Kogen Mantis

Kogen Mantis

    InsanelyMac Protégé

  • Donators
  • 98 posts
  • Gender:Male
@Deridjian - try my custom Clover r1229 package to make a bootable USB pen-drive. Just point the installer on the FAT32 USB media (you don't have to change any settings) and try booting OS X from it.

Attached File  Clover_v2_r1229k0.zip   5.74MB   90 downloads

#1548
xpamamadeus

xpamamadeus

    InsanelyMac Legend

  • Donators
  • 588 posts
  • Gender:Male
  • Location:Croatia

Hi everyone,
I don't have to change anything in the UEFI more than the boot device, do I?


Hi.
Posted Image
Use UEFI and u are good to go.
Here u can find really nice and detail guide about UEFI booting with clover by dmazar
http://www.projectos...682

#1549
Deridjian

Deridjian

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Zacatlán, Puebla
Thank you very much for not cutting my head off and throw it off the bridge. I will try to look into your suggestions asap as I'm currently occupied and will get back to it if I can get any success or something similar.

#1550
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,729 posts
  • Gender:Male
  • Location:Moscow
About BootableISO. It is intended to be burned on DVD because using specific CD drivers.

Or you can drag all files from the ISO to ESP partition of USB drive formatted to GPT.

#1551
Fab1Man

Fab1Man

    InsanelyMac Protégé

  • Members
  • PipPip
  • 74 posts
I'm trying to get Clover to work as well, but on boot I only get to see this. It's in the correct resolution though. Anyone seen this before?

Attached Files



#1552
Maniac10

Maniac10

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPipPipPip
  • 1,473 posts
  • Gender:Not Telling
Those are placeholders for missing images. Most likely you're victim of the recent change in the location of the theme definition. Before it was in refit.conf and was moved recently to the nvram. You can:
- compile the latest version that fixed this (rev1566: use refit.conf theme if NVRAM absent)
- type in a terminal: sudo nvram Clover.Theme=THEME_NAME and use the nvram instead of refit.conf from now on

#1553
Slice

Slice

    InsanelyMacaholic

  • Local Moderators
  • 3,729 posts
  • Gender:Male
  • Location:Moscow

I'm trying to get Clover to work as well, but on boot I only get to see this. It's in the correct resolution though. Anyone seen this before?

Sorry, update Clover. The bug is corrected in 1570+

#1554
Deridjian

Deridjian

    InsanelyMac Protégé

  • Members
  • Pip
  • 17 posts
  • Gender:Male
  • Location:Zacatlán, Puebla
Hello again everybody,

I'm slowly getting desperate over this. I tried so many methods and files and settings I'm getting out of ideads what to really tell I'm doing wrong…
I format my USB to FAT/MBR and do a Standard! Installation via Clover Installer r1570.

When I reboot my system with the Stick attached, I change the boot order in my EFI/UEFI/BIOS whatever...to the USB Device and reboot. The next thing that happens is just a usual boot from chameleon. The device won't be detected. I then reboot and in EFI/UEFI/BIOS change bootable devices to UEFI only. I reboot and this time the stick gets detected but I get the same screen with placeholders like Fab1Man (With r1570!)

Posted Image

I then tell myself: What gives, it's only images. My drives are there. So I boot my 3rd partition, which is my daily-use OSX. (The first two are system backups with the same config as #3 to mess around with updates etc.)
What happens next is this:

Posted Image

This happens exactly the same way when I
- add custom drivers and files on the installed stick as in here
- format the stick to GPT and install for UEFI only with the clover installer (this installation fails when formatted to FAT)
- try different setups with the installer

Some things I am confused about apart from the installer:
- Gigabyte states about the GA-H77-D3H on the official website that the BIOS is/has:
a] GIGABYTE 3D BIOS (Dual UEFI)
b] Use of licensed AMI EFI BIOS
c] Support for DualBIOS™

So what the hell is my BIOS/EFI/UEFI anyways? Is it hybrid? Is it EFI? Is it UEFI? I can't tell...It definetly has capabilities to support UEFI, but is it UEFI for that reason? I don't get it...

#1555
toleda

toleda

    InsanelyMac Deity

  • Gurus
  • 1,530 posts
  • Gender:Male

What is the sense to name it "HD Graphics" or "HD 3000" if I see deviceID=0x106 that corresponds to Apple's driver HD3000?

For Sandy Bridge, the framebuffer is AppleIntelSNBFramebuffer.kext. The property is AAPL,snb-platform-id. To ensure the HD3000 framebuffer loads, inject device-id 0126. Required IGPU/GFX0 dsdt injection:

For macbookpro8,1 (LVDS, DPx3)
"device-id",
						 Buffer (0x04)
						 {
							 0x26, 0x01, 0x00, 0x00
						 },
						 "AAPL,snb-platform-id",
						 Buffer (0x04)
						 {
							 0x00, 0x00, 0x01, 0x00
						 },


For macmini5,1 (DPx2, HDMI)
						 "device-id",
						 Buffer (0x04)
						 {
							 0x26, 0x01, 0x00, 0x00
						 },
						 "AAPL,snb-platform-id",
						 Buffer (0x04)
						 {
							 0x10, 0x00, 0x03, 0x00
						 },
Credit: RevoGirl

#1556
ZenGiga

ZenGiga

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 134 posts

With the options 'install Clover in ESP' and 'BIOS MBR boot0', clover installer did what you said.
But after reboot, i'm stuck in duet screen with no device detection : so no boot.

I saw that too. Try boot0hfs instead of boot0 (not sure if I have the names right - also the names have changed in the most recent Clover builds, ymmv).

#1557
antoniodapc

antoniodapc

    InsanelyMac Legend

  • Donators
  • 546 posts
  • Gender:Male
I would like to start by
EFI with the new release of Clover EFI from Usb Stick



I tried to install Clover EFI package EFI only USB ( Fat32)
but nothing when I tell him to select EFI USB stick
I have only the black screen in the emergency command with the cursor flashing.

Can you give me a hand please?

#1558
okmacok

okmacok

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts

I would like to start by
EFI with the new release of Clover EFI from Usb Stick

...
Can you give me a hand please?

Did you try BootDiskUtility.exe ?

here is a too long help about this tool, but there good informations here :
http://www.osx86.net...enovo-g570.html

#1559
antoniodapc

antoniodapc

    InsanelyMac Legend

  • Donators
  • 546 posts
  • Gender:Male

Did you try BootDiskUtility.exe ?

here is a too long help about this tool, but there good informations here :
http://www.osx86.net...enovo-g570.html

Did you try BootDiskUtility.exe ?

here is a too long help about this tool, but there good informations here :
http://www.osx86.net...enovo-g570.html

Thankyou very much , I' LL try

#1560
okmacok

okmacok

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
I need advices about kext injections.
http://www.insanelym...s/#entry1853406

Should I use clover kext injections or should I install kexts with a tool like this one :
http://www.osx86.net....8_edition.html

Clover kext injection seems more slow...
What are the add and cons ?

I imagine that clover kext injection can be fine for testing for example ? But "normal" kexts installation are fine for definitive use ?
Or Clover kext injection are the best anyway in the point of view of simplicity and clarity ? (or maybe usefull only in case of multiple Os ?)






6 user(s) are reading this topic

1 members, 5 guests, 0 anonymous users


© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy