Jump to content

Problemino:non posso riavviare il sistema....


  • Please log in to reply
13 replies to this topic

#1
gero206

gero206

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Buonasera a tutti,parto subito a rompere con un po di problemi che affliggono il mio appena nato hackintosh.Premetto che con la ricerca non ho trovato niente che corrisponda al mio caso,perciò vi prego di essere clementi se sono o.t. oppure creo un Topic doppio...
Allora,con l'hardware in firma ho installato su un hard disk di prova Lion 10.7.2 con l'immagine di iAtkos L2 da dvd.Tutto perfetto,funziona tutto alla grande a parte 2 cose:Non mi si riprende dallo stand-by,nel senso che resta lo schermo nero,senza segnale e devo spegnere tenendo premuto il tasto di accensione,e cosa molto più fastidiosa,come da titolo,non posso riavviare il sistema!Se chiudo il pc con "Spegni..." si spegne,e poi lo riaccendo e tutto fila liscio,ma se faccio "riavvia..." al riavvio mi spara un KP non meglio identificato (e se magari qualcuno mi dice come si identificano i KP) subito dopo la schermata di caricamento,quella bianca con la mela.Ho provato ad aggiornare a Lion 10.7.5 ma al riavvio si blocca.

Se servono info in più chiedete e vi sarà dato con piacere!

E grazie in anticipo a tutti quelli che mi daranno una mano!

#2
Giorgio_multi

Giorgio_multi

    InsanelyMac V.I.P.

  • Gurus
  • 9,514 posts
  • Gender:Male
  • Location:Ferrara, Italy
  • Interests:Elettronica in genere, informatica e Sistemi Operativi in particolare. Cani da slitta e Sleddog....
Per il riavvio hai provato EvoReboot.kext?

Per identificare il KP devi fare una foto dello schermo.

Per lo sleep, se hai installato sleepenabler.kext, è un problema comune di non facile soluzione.

#3
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,615 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana

Per identificare il KP devi fare una foto dello schermo.

Digitando -v al boot

#4
gero206

gero206

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Ok,poi provo,nel frattempo chiedo puo essere che ho sbagliato qualche settaggio nel bios?ora la modalità sleep è su s3...

#5
gero206

gero206

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Installato EvoReboot,si riavvia tutto che è un piacere!E una risolta,grazie Giorgio_multi!Non lo avevo installato prima perchè non ho trovato nessuno col mio problema,nel-nei forum la maggior parte dei kp risolti con evoreboot riguarda il mancato spegnimento,o avvio...
Ora resta il problemino,peraltro secondario,dello sleep che non va.
Come verifico se ho installato sleepenabler.kext?
Se per far andare lo sleep devo fare lavori che rischiano di rovinare tutto il lavoro fatto fin qua direi che posso evitare di sospendere il sistema...l'ottimo sarebbe avere un hackintosh funzionante al 100% ma non è proprio una funzione per me fondamentale...
Ah,dite che posso aggiornare il sistema col tool ufficiale apple? Per intenderci mela/aggiornamento software...

#6
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,615 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Ciao, i kext vengono installati in /Sistema/Libreria/Extensions oppure in /Extra/Extensions (se la cartella è stata creata da chameleon); fai una ricerca per sleepenabler su questo forum o sul web, ne troverai diversi da provare, ricorda di installarli con kext wizard in /S/L/E e riavviare con -v; in caso di kernel panic in mezzo a tutte le scritte ci sono anche le istruzioni per riavviare normalmente il sistema (solitamente bisogna digitare pmVersion=0).
Aggiornamento software... meglio scaricare la dmg dal sito apple, se hai voodooHDA rimuovilo e lancia l'aggiornamento.

#7
gero206

gero206

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Trovati i kexst,sono tutti in s/l/e,la mia versione di chameleon (2.1svn r1650) non usa più la cartella e/e.Niente sleepenabler ne ho provati un paio ma sempre kp,addirittura uno (era scritto specifico per 10.7.2) mi va in sleep correttamente,ma poi si spegne-riavvia di continuo senza mai farmi vedere lo schermo...spento togliendo la corrente al riavvio mi da un errore di POST e mi setta il BIOS su una modalità safe,cioè lascia tutto invariato tranne la frequenza della memoria,portata a 1333Mhz invece di 1600.Ho dovuto settare a mano il moltiplicatore su "16" per fargli riconoscere di nuovo la frequenza giusta,altrimenti su "auto" mi indicava sì la frequenza di 1600,ma all'avvio,nel POST mi rilevava 1333....questa non l'ho capita.
Come power management ho trovato appleCPUPowerManagement,AppleCPUPowerManagementClient e NullCPUPowerManagement,non è che si infastidiscono l'un l'altro?

Ah,ho avuto ancora un paio di KP dopo l'installazione di evorebboot al riavvio,ma ho risolto settando in chameleon per la grafica "usa ati rom" invece di "grafic enabler",anche se prima la scheda video funzionava perfettamente,ora non ho più kp....

Altra cosa,dopo aver rimosso i voodoohda posso far partire l'installazione dell'update direttamente da lion o devo masterizzarlo e farlo partire con chameleon?Ho trovato molte teorie in rete ma pare che funzionino tutte e nessuna,purtroppo non ho trovato casi uguali al mio...

#8
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,615 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Per i kext power management vanno bene così, per l'aggiornamento lancia la dmg da Lion, al riavvio non funzionerà l'audio, trova disabler.kext ed installalo assieme a voodooHDA.kext (disabler serve per non dover eliminare AppleHDA ogni volta che si aggiorna il sistema).
Ciao

#9
gero206

gero206

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts

Per i kext power management vanno bene così, per l'aggiornamento lancia la dmg da Lion, al riavvio non funzionerà l'audio, trova disabler.kext ed installalo assieme a voodooHDA.kext (disabler serve per non dover eliminare AppleHDA ogni volta che si aggiorna il sistema).
Ciao


Aggiornato a 10.7.5 con la combo update,tutto ok.Installato appleHDAdisabler e voodooHDA.L audio non va.Allora ho eliminato a mano applehda e anche il disabler niente.eliminato anche voodoo e reinstallato,ma niente,neanche con la versione estrapolata da un backup di time machine.ovviamente dopo ogni azione ho riparato i permessi e fatto ricreare la cache da kextutility.ora non ho piu kp ma non ho l audio.mi tengo volentieri il mac con l insonnia,ma l audio devo farlo funzionare.qualche idea?

#10
gero206

gero206

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Mi rispondo da solo,e se può tornare utile a qualcuno ho risolto così:<br /><br />- Eliminato di nuovo voodooHDA.kext da sistema/libreria/extensions;<br />- Trovato ed eliminato i files .prefpane da sistema/libreria/PreferencePanes relativi a voodooHDA,appleHDA e appleHDAdisabler,<br />- Riparato permessi,riparato cache e riavviato,non si sa mai.<br />- Scaricato il pacchetto zippato di voodoHDA 2.7.4,unzippato,installato voodooHDA.kext con kextutility;<br />- Piazzato manualmente il file voodooHDA.prefpane (compreso nel pacchetto) in sistema/libreria/PreferencePane;<br />- Installato il voodoo control panel presente nel pacchetto<br />- riparato permessi e cache,riavviato e bam&#33; FUNZIONA&#33;<br /><br />Ho così ottenuto l&#39;audio,e un bel control panel nelle preferenze di sistema con tanti bei controlli aggiuntivi&#33;<br /><br />Resto sempre in ascolto se qualcuno ha una soluzione per il problema sleep,ma per ora intanto grazie a tutti&#33;<br /><br />Edit: mi sono accorto di aver perso con l aggiornamento le porte usb 3.0,risolto spuntando usb bus fix in chameleon.

#11
gero206

gero206

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Scusate ho fatto un casino editando il post dal cellulare

#12
gero206

gero206

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Ehm rieccomi qua,si ripresenta il problema audio.Dunque,ho provato vari voodooHDA.kext,fino alla versione 2.7.3,non danno nessun kp,l audio funziona ma il volume e ridicolmente basso.la versione 2.7.4 funziona bene ma ogni tanto all avvio mi da dei kp.

#13
carbo178

carbo178

    InsanelyMac V.I.P.

  • Local Moderators
  • 5,615 posts
  • Gender:Male
  • Location:Dalle paludi della Pianura Padana
Metti questi, togli applehda, disabler e voodoohda, elimina il voodoohdaprefpanel

Attached Files



#14
gero206

gero206

    InsanelyMac Protégé

  • Members
  • Pip
  • 24 posts
Non vorrei cantare vittoria troppo presto,ma sembra che funzioni!
Ancora grazie carbo178!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy