Jump to content

D620 built in display is turned off

D620 Intel GMA950 display

  • Please log in to reply
2 replies to this topic

#1
Har1

Har1

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Hi

I am experiencing an annoying issue on my Dell D620 Latitude (Intel GMA950 graphics, Intel PRO/Wireless 3945ABG) running SL version 10.6.8.

Originally it was made using the D620SLV1 image (only way I got close in having success) created by leppy700m and a 10.6.3 Snow Leopard Retail DVD. The built-in LCD display has never worked all that good, meaning that viewing images (in eg. Preview) or viewing video (e.g. in You Tube (Safari) (The flash process took most of CPU clock cycles) , VLC or QuickTime) was an absolute no go. The pictures was all white and the video all black. Strange enough, when attaching an external monitor, the pictures and video was all perfect.

Eventually I decided to upgrade to SL 10.6.8, and a new problem turned up:
The built-in LCD screen is only available when booting and the spinning wheel. When the boot process is complete the built-in screen is switched off, and only the external monitor is ok (full resolution 1280x1024x32@75).

Do you have any idea how to get the display working? Any ideas or hints are most welcome…

Thanks in advance for any help.

All the best
Har1

More technical information below:

The BIOS settings are as suggested in OSX Latitude (http://forum.osxlati...-settings-d620/).


After the upgraded to 10.6.8, I
1. Copied the Apple kexts in use (in bold below) from /System/Library/Extensions to /Extra/Extensions
2. Updated VoodooHDA.kext (in italics below) to version 2.73 (to get the mic working).
3. Changed the access rights
sudo -R chmod 755 /Extra/Extensions
4. Change user and group owership
sudo -R chown root:wheel /Extra/Extensions
5. Rebuilt the kext cache using as
sudo kextcache -v 1 -a i386 -m /Extra/Extensions.mkext /Extra/Extensions

System Profiler information:
nVidia Graphics Card:

Chipset Model: nVidia Graphics Card
Type: GPU
Bus: Built-In
VRAM (Total): 128 MB
Vendor: Intel (0x8086)
Device ID: 0x27a2
Revision ID: 0x0003
ROM Revision: Silent Natit x86_64 v1.0.2
Displays:
Display Connector:
Status: No Display Connected
SDM-HX75:
Resolution: 1280 x 1024 @ 75 Hz
Pixel Depth: 32-Bit Color (ARGB8888)
Display Serial Number: 6032263
Main Display: Yes
Mirror: Off
Online: Yes
Rotation: Supported

sh-3.2# ls -l /Extra/Extensions
total 0
drwxr-xr-x 3 root wheel 102 Nov 24 13:23 AppleACPIPS2Nub.kext
drwxr-xr-x 3 root wheel 102 Nov 24 13:23 AppleBCM5751Ethernet.kext
drwxr-xr-x 3 root wheel 102 Mar 23 2010 AppleIntelGMA950.kext (version 1.6.36)
drwxr-xr-x 3 root wheel 102 Mar 23 2010 AppleIntelGMA950GA.plugin
drwxr-xr-x 3 root wheel 102 Mar 23 2010 AppleIntelGMA950GLDriver.bundle
drwxr-xr-x 3 root wheel 102 Mar 23 2010 AppleIntelGMA950VADriver.bundle
drwxr-xr-x 5 root wheel 170 Nov 24 11:51 AppleIntelIntegratedFramebuffer.kext (version 1.6.36)
drwxr-xr-x 3 root wheel 102 Feb 26 2010 IOATAFamily.kext (version 2.5.1)
drwxr-xr-x 3 root wheel 102 Feb 26 2010 IOAudioFamily.kext (version 1.8.3)
drwxr-xr-x 5 root wheel 170 Nov 24 12:09 IOGraphicsFamily.kext (version 2.2.1)
drwxr-xr-x 3 root wheel 102 Feb 26 2010 IONetworkingFamily.kext (version 1.10)
drwxr-xr-x 3 root wheel 102 Nov 24 13:23 Natit.kext
drwxr-xr-x 3 root wheel 102 Nov 24 13:23 NullCPUPowerManagement.kext
drwxr-xr-x 3 root wheel 102 Feb 26 2010 OSvKernDSPLib.kext (version 1.3)
drwxr-xr-x 3 root wheel 102 Nov 24 13:23 OpenHaltRestart.kext
drwxr-xr-x 3 root wheel 102 Nov 24 13:23 PlatformUUID.kext
drwxr-xr-x 3 root wheel 102 Nov 24 13:23 VoodooBattery.kext
drwxr-xr-x 3 root wheel 102 Aug 9 2011 VoodooHDA.kext
drwxr-xr-x 3 root wheel 102 Nov 24 13:23 VoodooPS2Controller.kext
drwxr-xr-x 3 root wheel 102 Nov 24 13:23 VoodooPS2Keyboard.kext
drwxr-xr-x 3 root wheel 102 Nov 24 13:23 VoodooPS2Mouse.kext
drwxr-xr-x 4 root wheel 136 Nov 24 13:23 VoodooTSCSync.kext
drwxr-xr-x 3 root wheel 102 Nov 24 13:23 fakesmc.kext
sh-3.2#

#2
Har1

Har1

    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts
Forget my post. I found a solution to the problem by installing Chameleon using myHack-3.2.1 and the latest EDP from OSXLatitude and added the graphics kexts from the default 10.6.8 Apple distribution:

AppleIntelGMA950.kext
AppleIntelGMA950GA.plugin
AppleIntelGMA950GLDriver.bundle
AppleIntelGMA950VADriver.bundle
AppleIntelIntegratedFramebuffer.kext
IOGraphicsFamily.kext

Now enjoying a display with full hardware accelleration... :-)

Have a great day.
/Har1

#3
titanus

titanus

    InsanelyMac Protégé

  • Banned
  • Pip
  • 8 posts
  • Gender:Male

you will have some issues, with my hack 3.2.1,,it seem's i causes troubles on installation,,just a peace of advice,, i've got also, D620 GMA950 and is running cool,, it's been 3 weeks,, but, in the first install i used my hack 3.2.1 and he crashes,,need it to build again,,no possible boot,,then someone told me to use 3.1.2 and not 3.2.1. and now,, everything works,,graphics/sound/ethernet/,,bla, bla, bla,,just thing you should now, cause you got the same laptop as i
. peace,,







Also tagged with one or more of these keywords: D620, Intel GMA950 display

  Topic Stats Last Post Info

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy