Jump to content

Problema ao entrar no Lion


  • Please log in to reply
11 replies to this topic

#1
toohinc

toohinc

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
Boas.

Tenho o meu Lion instalado já à bastante tempo no meu desktop com tudo a funcionar bem :) Agora, instalei o windows7 noutra partiçao apenas para jogar os últimos jogos, o meu problema é que agora quando reinicio o pc, nao tenho opçao para escolher o sistema operativo. E preciso do Lion porque é onde trabalho.

Tenho por aqui um cd "######" e usei para tentar entrar no Lion, quando seleciono o Lion o pc reinicia. Alguém me pode dar uma dica de como resolver isto?

Obrigado.

#2
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,423 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

em principio tens de instalar de novo o chameleon...

mas o k dizes é estranho..

o hd está em MBR ou GUID

o 7 instalaste depois do mac os x ?

bom hack

#3
Rooan Kesley

Rooan Kesley

    InsanelyMac Protégé

  • Members
  • Pip
  • 33 posts
Tive o mesmo problema, a solução é que faça uma pendrive com o chameleon instalado, o meu aqui se não fosse ele ficava reiniciando em loop infinito, depois disso só instalar o chameleon na partição principal novamente

#4
toohinc

toohinc

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts

olá

em principio tens de instalar de novo o chameleon...

mas o k dizes é estranho..

o hd está em MBR ou GUID

o 7 instalaste depois do mac os x ?

bom hack


Boas.

O meu hd está em GUID.
Sim instalei o 7 muito depois de ter instalado o mac os x.


Tive o mesmo problema, a solução é que faça uma pendrive com o chameleon instalado, o meu aqui se não fosse ele ficava reiniciando em loop infinito, depois disso só instalar o chameleon na partição principal novamente


boas.
para instalar o chameleon numa pen tem que ser atraves do mac os x ? é que agora so tenho acesso ao windows 7 :(

#5
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,423 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

http://www.insanelym...n-pelo-windows/

e deves manter um cd de boot ou uma pen para em qualquer caso conseguires fazer boot ao sistema através dela.

bom hack

#6
toohinc

toohinc

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts

olá

http://www.insanelym...n-pelo-windows/

e deves manter um cd de boot ou uma pen para em qualquer caso conseguires fazer boot ao sistema através dela.

bom hack


Boas.
Depois da parte da linha de comandos, a pen esta vazia, nao tem ficheiros nehuns la dentro, é normal? já experimentei com várias pen´s.

O link para download dos binários do chameleon nao funciona :(

Obrigado pela ajuda.

#7
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,423 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

binários

http://www.insanelym...aller-binaries/

http://olarila.com/f....php?f=10&t=110

bom hack

#8
toohinc

toohinc

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts

- Desconecte e conecte novamente o pen drive
- Copie a pasta Extra do pacote de binários do Chameleon para o pen drive
- Copie o arquivo boot da pasta usr\standalone\i386 para o pen drive
- Crie uma pasta Extensions dentro da pasta Extra e copie a FakeSMC (e outras kexts que você precise) para ela

O pen drive está pronto para fazer boot.


Já fiz o download dos binários mas, dentro do zip nao tem nehuma pasta Extra nem usr\standalone\i386!

Também fiz o download desse .iso do 2º link e dentro do iso já tem todas essas pastas, copiei-as para a pen, mas nao faz boot, apenas vai directo para o win7.

Nao sei o que estou a fazer errado.

#9
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,423 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

grava o iso num cd e faz boot com ele

bom hack

#10
toohinc

toohinc

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
Boas.

Ja fiz boot com o cd, mas bloqueia em "Cannot alloc class SCSI.........", será que devo adicionar alguns kexts ao cd? O que vejo mais em legacy mode é "failed to load kext..."

Obrigado

#11
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,423 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
olá

tenta entrar em boot

-x

tens de tentar fazer o boot

e posta foto dos erros

se n consegues fazer a pen... so vejo solução o cd.. tenta usar outros cd de boot...

bom hack

#12
toohinc

toohinc

    InsanelyMac Protégé

  • Members
  • PipPip
  • 57 posts
Boas.

Peço desculpa pela demora, ja tentei com -x e bloqueia aqui:
Can't load kext com.apple.iokit.SCSITaskUserClient - failed to resolve library dependancies
Kext com.apple.iokit.SCSITaskUserClient failed to load (0xdc00800e)
Failed to load kext com.apple.iokit.SCSITaskUserClient (error 0xdc00800e)
Couldn't allo class "IOSCSIPeripheralDeviceType05"
Couldn't alloc class "SCSITaskUserClientIniter"

Estou a usar o cd para ter a opçao de boot, mas o sistema para com esse erro! :(

EDIT: Já consegui por a funcionar, instalei no windows o programa EasyBCD, adicionei a partição Mac OSX que estava a faltar, e agora tenho ambas as partiçoes no boot. Ambas funcionam!

Obrigado pela ajuda.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy