Jump to content

Ayuda con SSDT

- - - - -

  • Please log in to reply
2 replies to this topic

#1
tora

tora

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts
Hola,
primeramente presentarme, mi nombre es Víctor, de Madrid.

He instalado a mi cuñado Mountain Lion y lo he actualizado a 10.8.2 en este Medion Akoya:

MedionPC MS 7728
Chipset INTEL H61 Intel Sandy Bridget
Bios American Megatrend
Intel Core i7 2600 3400 MHz
AMD Radeon HD 6450 1GB
Realtek RTL8168/8111 PCIe Gigabit
Realtek ALC887


Parcheé el AICPUPM para quitar el Null y que no me diera KP, hasta aquí todo correcto, tengo aceleración gráfica, apaga y enciende bien, bastante rápido por cierto, también instalé los dos kext para tener sonido.

Ahora lo que quiero hacer para que funcionen bien lo de las frecuencias de la CPU es, meter en Extra el SSDT, y aquí es donde me lio un poco.

juanerson te he leído y he visto que tu lo has hecho y por eso recurro a ti, sin menospreciar a los demás foreros, se trata de sacar el SSDT, aunque tengo una vaga idea de como hacerlo, el tema es como arreglarlo o si hay que dejarlo como está una vez obtenido.

Tengo el script de Revogirld (R.I.P.) y se que hay que ejecutarlo así sudo ./ssdtPRGen.sh

Bien, tengo que introducir unos datos para que se genere el SSDT, el TDP y la máxima frecuencia del micro ¿es así?, si fuese así, me quedaría:
sudo ./ssdtPRGen.sh 95 3400 ¿sería esto correcto?, he puesto 95 porque es lo que he visto en las especificaciones de Intel, 95w.

El tema o problema que me viene es como arreglo este SSDT generado por el script para que esté correcto.

El smbios lo tengo como iMac 12.2.
Una vez tenga el SSDT correcto instalado en la carpeta Extra, en org.chamaleon.plist ¿que tengo que hacer?, ahora mismo los C y P states los tengo en si, sin Droppssdt, y claro, me da el error 18 ya que no está el SSDT, pero las preguntas son:
¿como pongo los C y P states?, en ¿si? o en ¿no?, ¿tengo que poner DropSSDT=¿Yes?, o ¿No??.

Y no me enrollo más, porque vaya un tocho que me ha salido.
Gracias a los que me leais y a los que me ayudeis.
Saludos.

Una cosa más que se me olvidaba, la aceleración gráfica funciona bien, pero me la detecta como 6xxx, osea, que no la detecta bien entonces ¿no?, que tendría que hacer para arreglarlo.
Y el DVDPlayer al ejecutarlo, me da error de que esta aplicación debe cerrarse o algo así, si parcheo el DVDPlayBack me da otro error, no recuerdo ahora, creo que era de que no se reconoce la unidad o algo asi. Ya.

#2
surfcaster

surfcaster

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 439 posts

sudo ./ssdtPRGen.sh 95 3400


deberias añadir la frecuencia maxima del turbo que son 3800 para generar el SSDT correctamente, eso no obstante no te asegurara tener speedstep correctamente funcionando, mirare los post que hay sobre ello en este mismo foro, sobre la grafica es normal que te la detecte como 6xxx series, deberias añadir al AGPM kext el ID de tu gráfica.

#3
tora

tora

    InsanelyMac Protégé

  • Members
  • PipPip
  • 58 posts

deberias añadir la frecuencia maxima del turbo que son 3800 para generar el SSDT correctamente, eso no obstante no te asegurara tener speedstep correctamente funcionando, mirare los post que hay sobre ello en este mismo foro, sobre la grafica es normal que te la detecte como 6xxx series, deberias añadir al AGPM kext el ID de tu gráfica.


Vale surfcaster, agradecido, 3800 entonces.
Miraré en AGPM a ver si está esta gráfica y si no meteré el ID.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy