Jump to content

ML on sony (i5 520M / GT330M), help anyone?

sony vaio ML

  • Please log in to reply
16 replies to this topic

#1
n00ise

n00ise

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Hello, im disperately trying to make ML run on my DAMN vaio (vpcf11m1e)
specs are:
cpu i5 520m
8gb ram
nvidia gt330m

i tried so far with chameleon but i got stuck on pci configuration error, tried a gigabillion of flags, and as SMBIOS i've set MAcbook Pro 6.2 (the macbook pro with similar specs, i5, gt330m..)
any one could direct me to a working way, possibly with easy drive through? i'm new to this world..
thanks in advance and please help me i hate windows :P

#2
n00ise

n00ise

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
updates: i fixed the pci configuration error with a iosupcifamily kext but now im stuck in a stupid error, i think it's cause of the hard drive (there is windows 8 in it), should i format it before trying to install ML?

#3
n00ise

n00ise

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
i've used a different HD and now im stuck at the boot cache BootCacheControl: Unable to open /Var/db/BootCache.playlist

#4
n00ise

n00ise

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Here's the situation:
i have an hard disk with two partition, in C: there's windows, and D: is formatted
if i boot now I still have the

BootCacheControl

error but it's not stuck, it goes until the ntfs-fs error again but this time mentions a hibernate status of Windows (WTF?). Windows is not hibernated and i ran chkdsk but I still have this error. (see attach.)

https://www.dropbox....scb2il/foto.JPG

#5
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Can't see your photo, but nothing you described as an error, normall stuff. Use boot flags -x-f -v and whatever the correct bus ratio would be, then wait

#6
n00ise

n00ise

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
thanks, i tried (busratio=18 I have i5 520M) but I'm stuck at

BootCacheControl: Unable to open /Var/db/BootCache.playlist: 2 No such file or directory



#7
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,755 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
hello

the problem is u graphics

first graphics card is intel hd , i think 8086:0046 not supported

see with system info here in forum

http://www.insanelym...ao-system-info/

if so, just remove appleintelhd*.kext from installer, and boot

but u graphics never work

good hack

#8
n00ise

n00ise

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
tried removing the 4 AppleIntelHD* kext but it is the same thing..stuck on the bootcachecontrol :(

sometime when I boot i get over that bootcache error but right after I have the error with the hibernate windows (?!) as seen here
https://www.dropbox....scb2il/foto.JPG

can i install ML on an external USB drive? (so inserting two usb while booting, one for the usb stick one with the destination hd)

#9
n00ise

n00ise

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Update: it still gives me the bootcachecontrol bur right after it says "DSMOS HAS ARRIVED"

#10
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,755 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
hello

have u windows in suspension or hibernate mode if so shutdown the system.

is only 4 kext ?

remove all appleintelhd*.kext

and boot

-f -v GraphicsEnabler=No

good hack

#11
n00ise

n00ise

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Tried already with the removing of intelHD and also ATI but with no luck :(

#12
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
remove nvidia ones too

BootCacheControl: Unable to open /Var/db/BootCache.playlist: 2 No such file or directory - even appears on real macs when verbose booting, not an error for basic config

#13
n00ise

n00ise

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
Tries also removing all video driver and nothing I have DSMOS HAS ARRIVED after the bootcache

#14
artur-pt

artur-pt

    InsanelyMacaholic

  • Local Moderators
  • 4,755 posts
  • Gender:Male
  • Location:Portugal
  • Interests:TechManiaco
hello

that is so messy , the installer

try another thing

-f -v UseKernelCache=No GraphicsEnabler=No

some versions of chameleon have problems with the flag -f and no ignore the caches

the msg DSMOS arrive and stop is graphics, and now if u don't have kext, only thing i can remember is the caches

btw what metode u use to prepare the installer ?

good hack

#15
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
yup, a graphics driver is still loading from somewhere. add -x bootflag too as I first mentioned, it should prevent some from loading. there's also some vaio tutorials and threads since they can be a pita

#16
n00ise

n00ise

    InsanelyMac Protégé

  • Members
  • Pip
  • 16 posts
thanks for helping me guys.
here's what I did so far:

created the USB stick by formatting it then restoring the base system dmg, then mach__kernel text into the new usb + partitions folder + fakeSMC + NullPowerCPU + IOSPCUFamily.kext then used chameleon to install the smblist for macbook pro 6.2 (the pro with gt330m and i5) removed all graphics kext (tried also with)
booted using a lot of flags combinations (f v x pcirootuid graphics enabler=no npci=0x2000/3000 busratio=18, not all at the same time :) )

tried with -v -x -f UseKernelCache=No GraphicsEnabler=No this is the result (same as usual)
https://www.dropbox....69qs/foto-1.JPG

this is my extension folder
https://www.dropbox....a4t18p/kext.jpg

#17
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
the 5 kexts after NullCPUPowermanagement are the nvidia ones, all start with NV in the name. Those are the ones that need deleting





Also tagged with one or more of these keywords: sony vaio, ML


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy