Jump to content

Experimental Atheros AR81(31/32/51/52/61/62/71/72) Driver for 10.7/10.8

Atheros

  • Please log in to reply
140 replies to this topic

#141
kocoman

kocoman

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 325 posts

Does it works on Yosemite?

 

 

yes for ar8131 but not reliable in 10.10 GM candidate (due to irq conflict?) (disconnects network after heavy load and error messages, see the quote below)

 

I tried the other AtherosL1cEthernet but it does not work at all with the error "cannot allocate ring descriptors", I recompiled the AtherosL1cEthernet 1.2.3 with xcode 6.1 gm and fix the gcc to llvm and set to 64bit and osx 10.10 and it works now...  doing some load testing...

 

 

I discovered on both, using Apple's "Logic Remote" from Wifi (then to ethernet) will kill the driver immediately with "incorrect zfree from zone kalloc.16 to zonekalloc.32".

 


  • XLR likes this






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy