Jump to content

Marvell Yukon 88E8059 Gigabit LAN almost working, need help with further technical


  • Please log in to reply
10 replies to this topic

#1
MacFaulty

MacFaulty

    InsanelyNut

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Tulip & Cheese country
  • Interests:IT Management and creating web apps
So, I took a legacy kext of the net from a 88E8056 and edited it for my 88E8059, just to try whether it works or not.
Well, I must say that I did got some results. I've got OS X to see my card, for the first time!
The only thing is that when OS X sees the LAN card it says that the cable is not connected or the device on the other side is not responding. But I did connected a cable to my working gbit switch.

Here is my legacy kext info.plist code:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>CFBundleDevelopmentRegion</key>
<string>English</string>
<key>CFBundleIdentifier</key>
<string>org.darwinx86.yukon2.88E8059</string>
<key>CFBundleInfoDictionaryVersion</key>
<string>6.0</string>
<key>CFBundleName</key>
<string>AppleYukon2 enabler for 88E8059</string>
<key>CFBundlePackageType</key>
<string>KEXT</string>
<key>CFBundleSignature</key>
<string>????</string>
<key>CFBundleVersion</key>
<string>1.0</string>
<key>IOKitPersonalities</key>
<dict>
<key>Yukon-88E8059</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.iokit.AppleYukon2</string>
<key>EnableLowPwr</key>
<integer>1</integer>
<key>IOClass</key>
<string>yukon2osx</string>
<key>IOPCIPrimaryMatch</key>
<string>0x11ab4381</string>
<key>IOProviderClass</key>
<string>IOPCIDevice</string>
<key>MACNumber</key>
<integer>1</integer>
<key>Model</key>
<string>Yukon Gigabit Adapter 88E8059 Singleport Copper SA</string>
<key>NetworkNumber</key>
<integer>1</integer>
<key>RxDeadman</key>
<integer>0</integer>
<key>RxRingGrowonpause</key>
<integer>10</integer>
<key>RxRingSize</key>
<integer>0</integer>
<key>RxRingSize_100MBit</key>
<integer>128</integer>
<key>RxRingSize_10MBit</key>
<integer>64</integer>
<key>RxRingSize_GigaBit</key>
<integer>256</integer>
<key>TxRingSize</key>
<integer>256</integer>
<key>Vendor</key>
<string>Marvell</string>
</dict>
</dict>
<key>OSBundleRequired</key>
<string>Root</string>
</dict>
</plist>

Now that I'm this far I really would like to get it working. I added the IOSecondaryMatch in the kext with my, in Windows given, subsystem ID. Is this correct? I also edited the IOPrimaryMatch to reflect my device and vendor ID.

Is there anything else I can try to get this working?

#2
MacFaulty

MacFaulty

    InsanelyNut

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Tulip & Cheese country
  • Interests:IT Management and creating web apps
Anybody got any ideas?

Also, whenever I boot in to my Windows installation. The card goes just missing. So I have to reboot, do a fake PXE boot and then I get at POST: System Configuration Data Updated.

This is only when I leave OS X.

#3
廿浮沉

廿浮沉

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
I have a 88e8059 nic too.And I have found this problem one years ago.The AppleYukon2 has a fatal error when it inits. I just hope someone could develop a kext for this card.

#4
MacFaulty

MacFaulty

    InsanelyNut

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Tulip & Cheese country
  • Interests:IT Management and creating web apps
I know there is a linux driver for this card, isn't there a possibility that a tech know-how could fix it up for OS X? He/she would make a lot of people very happy with such a present :)

#5
MacFaulty

MacFaulty

    InsanelyNut

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Tulip & Cheese country
  • Interests:IT Management and creating web apps
If I go with the verbose boot log created by the system I don't see any errors. It even reads my MAC address:

edit: There is an error. Check the block code below this one. I really want this to work, is there anything I might try? Other Rx values or what-so-ever?

Nov 3 22:21:27 Mac-Pro-van-Wout kernel[0]: AppleYukon2: Marvell Yukon Gigabit Adapter 88E8059 Singleport Copper SA
Nov 3 22:21:27 Mac-Pro-van-Wout kernel[0]: AppleYukon2: RxRingSize <= 1024, TxRingSize 256, RX_MAX_LE 1024, TX_MAX_LE 768, ST_MAX_LE 3328
Nov 3 22:21:27 Mac-Pro-van-Wout kernel[0]: yukon: Ethernet address 00:24:54:a6:a6:a2
Nov 3 22:21:27 Mac-Pro-van-Wout.local WindowServer[91]: Session 256 retained (2 references)
Nov 3 22:21:27 Mac-Pro-van-Wout.local WindowServer[91]: init_page_flip: page flip mode is on
Nov 3 22:21:27 Mac-Pro-van-Wout.local apsd[70]: CGSLookupServerRootPort: Failed to look up the port for "com.apple.windowserver.active" (1102)
Nov 3 22:21:29 Mac-Pro-van-Wout.local awacsd[68]: Exiting
Nov 3 22:21:29 Mac-Pro-van-Wout.local WindowServer[91]: mux_initialize: kAGCGetMuxState (kMuxControl, kMuxControl_switchingMode) failed (0xe0000001)
Nov 3 22:21:29 Mac-Pro-van-Wout.local WindowServer[91]: mux_initialize: Mode is safe
Nov 3 22:21:29 Mac-Pro-van-Wout.local WindowServer[91]: GLCompositor enabled for tile size [256 x 256]
Nov 3 22:21:29 Mac-Pro-van-Wout.local WindowServer[91]: CGXGLInitMipMap: mip map mode is on
Nov 3 22:21:29 Mac-Pro-van-Wout.local WindowServer[91]: WSMachineUsesNewStyleMirroring: false
Nov 3 22:21:29 Mac-Pro-van-Wout.local WindowServer[91]: Display 0x6bc5a000: GL mask 0x1; bounds (0, 0)[1366 x 768], 24 modes available
Main, Active, on-line, enabled, built-in, boot, Vendor daf, Model 1680, S/N 0, Unit 0, Rotation 0
UUID 0x00000daf00001680000000006bc5a000
Nov 3 22:21:29 Mac-Pro-van-Wout.local WindowServer[91]: Display 0x003f003d: GL mask 0x2; bounds (0, 0)[0 x 0], 1 modes available
off-line, enabled, Vendor ffffffff, Model ffffffff, S/N ffffffff, Unit 1, Rotation 0
UUID 0xffffffffffffffffffffffff003f003d
Nov 3 22:21:29 Mac-Pro-van-Wout.local WindowServer[91]: Created shield window 0x5 for display 0x6bc5a000

Nov  3 22:23:17 Mac-Pro-van-Wout kernel[0]: AppleYukon2: error - FATAL: SkGeStopPort() does not terminate (Rx)
Nov  3 22:23:17 Mac-Pro-van-Wout.local com.apple.SecurityServer[15]: Succeeded authorizing right 'system.services.systemconfiguration.network' by client '/System/Library/Frameworks/SystemConfiguration.framework/Versions/A/Resources/SCHelper' [223] for authorization created by '/Applications/System Preferences.app' [145] (100003,0)
Nov  3 22:23:17 Mac-Pro-van-Wout kernel[0]: AppleYukon2: error - FATAL: SkGeStopPort() does not terminate (Rx)
Nov  3 22:23:17 Mac-Pro-van-Wout.local configd[17]: network changed: v4(en0!:192.168.178.27) v6(en0!:fe80::be05:43ff:feeb:48c4) DNS Proxy SMB


#6
廿浮沉

廿浮沉

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
I think if we want to fix the error(AppleYukon2: error - FATAL: SkGeStopPort() does not terminate (Rx)),we should patch the binary file in AppleYukon2.But I don't have any knowledge about it.Maybe someone could make a driver for this nic from linux driver.

#7
廿浮沉

廿浮沉

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
Are you good at programming? If you can make a driver,just like you say,you make a lot of people very happy with such a present.

#8
MacFaulty

MacFaulty

    InsanelyNut

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Tulip & Cheese country
  • Interests:IT Management and creating web apps

Are you good at programming? If you can make a driver,just like you say,you make a lot of people very happy with such a present.


Hahah, thanks. Well I'm no programmer yet. It will take 3 years before I'll have all the I/O systems under control. So, for the short run, I'm no programmer. But when I will gain more and more knowledge I'll try of course :) Hope somebody else could help us (and many others) out :)

By the way. What is the most appropriate section for this topic? (Where most programmers look here on the forum? :P). I just opened this topic, but I don't know whether it belongs in this section.

#9
廿浮沉

廿浮沉

    InsanelyMac Protégé

  • Members
  • Pip
  • 5 posts
  • Gender:Male
I also don't know :)

#10
MacFaulty

MacFaulty

    InsanelyNut

  • Members
  • PipPipPip
  • 158 posts
  • Gender:Male
  • Location:Tulip & Cheese country
  • Interests:IT Management and creating web apps
Hmm... I'm trying to pick up some binary patching, but I don't get much of it. Some easy guides around? Want to patch this {censored}!! :D

#11
Evgeniy

Evgeniy

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts

up : any news about Yukon 8059 ?







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy