Jump to content

Cannot install iWork and dyld_shared_cache issue


  • Please log in to reply
1 reply to this topic

#1
Alby128

Alby128

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 157 posts
  • Gender:Male
  • Location:Pisa, Italy
Hi,
I installed 10.8.2 on the system in signature. Everything works fine, the OS feels even smoother than Lion.
I have this problem though when I install some Apple software, like Aperture or iLife or iWork. At the end of the installation procedure, many things happen at once, like, for instance
- any application won't open
- mission control, launchpad nor notification center won't work
- desktop background becomes solid gray
- dock disappears

Moreover, when I reboot the (now unusable) system, the boot hangs before the start of the graphics module and there's only one way I found to fix this (after several attempts):
- boot in safe mode, then delete caches and rebuild kernelcache
- reboot ignoring caches, than rebuild prelinked cache
- reboot without flags

After restoring the boot, the system works perfectly again, but not iWork. If I open any iWork application, a message appears: "Files that iWork needs are missing. To restore the missing files, use the iWork installer to reinstall iWork."
Of course if I try to reinstall the suite, the system would break again in the same way as before.

So I have two questions:
- Did some of you have this issue before, or is the first time you all heard about this?
- Do you have any idea to solve this?

Some technical notes that might help you:
From system.log, I understand applications won't open because of launchd error "catch_mach_exception_raise_state_identity()" and then Segmentation fault: 11 . This happens for any new PID the OS tries to start.
From install.log there are some dyld_shared_cache errors. Apparently, iWork installer tried to update dyld_shared update_dyld_shared_cache -overlay /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/Cleanup At Startup/PKInstallSandboxManager/1.sandbox/Root" but, for some unknown reason, it fails. So, when it tries to move the update cache, it reports this on the log "Failed to move active dyld cache file /var/db/dyld/dyld_shared_cache_x86_64 to /var/run: No such file or directory". Any idea why the installer couldn't update the dyld_shared_cache?
Now the dyld_shared is in the correct path and works like charm, but of course is the previous version, before the install of iWork. That is certainly causing the "iWork: missing files" error from before.

Thanks in advance for your help,
Alberto

#2
Alby128

Alby128

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 157 posts
  • Gender:Male
  • Location:Pisa, Italy
Up...





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy