Jump to content

Help me sleep!


  • Please log in to reply
No replies to this topic

#1
ramdass

ramdass

    InsanelyMac Protégé

  • Members
  • Pip
  • 11 posts
  • Gender:Male
I've built an OSx86 machine with Snow Leopard (10.6.7) on an Asus P5G41T-M, and I have everything working but sleep. What seems to me to be happening is that any time the system gets a 'sleep' command - either manually from the menu, or automatically from the Energy Saver timer - something in the hardware immediately produces a 'wake-up' command, so there appears to be no sleep at all. The screen stays on, the computer keeps running at full power, but the hard drives go to sleep (whether the put hard drives to sleep box is checked or not). It shuts down and restarts properly. Using the SleepEnabler kext has no effect on the behavior.

I'm using the DSDT from the Auto-Patcher for the P5G41T-M LX, a slightly different board, but the closest one for which a patch exists. I also tried the DSDT for the P5G41T-M LX 2, with the same result as far as the sleep issue goes.

Assuming I'm right, and something is providing a constant 'wake-up' signal, has anyone experienced anything like this, and does anyone have an idea what causes it, and how to remedy it? Is this something that could be fixed by fine tuning the DSDT (which would be above my own skill level :| ). Or could it be a question of the BIOS settings, and if so, which ones. I did check the obvious: all of the "Wake on ___" settings are disabled.

Any advice appreciated. Thanks.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy