Jump to content

Chameleon selects wrong partition

chameleon wrong partition default partition boot partition

  • Please log in to reply
6 replies to this topic

#1
rakusson

rakusson

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Location:Denmark
Hi,
I've dual boot (win 7, ML) MBR partition using EasyBCD. When I select ML from the boot menu, then chameleon enoch 2070 takes command but it chooses wrong default boot partition. I have to select manually 'MacintoshHD (ML partition)' to boot. It's not a problem but quite annoying. Apart from MacintoshHD partition, I do have another HFS+ partition (named MacBackup). This is diskutil list output:

/dev/disk0
#:					 TYPE NAME				 SIZE	 IDENTIFIER
0:	 FDisk_partition_scheme					 *320.1 GB disk0
1:					 0x27						 15.0 GB disk0s1
2:			 Windows_NTFS SYSTEM RESERVED		 106.9 MB disk0s2
3:			 Windows_NTFS eMachines			 154.6 GB disk0s3
4:			 Windows_NTFS Backup				 95.3 GB disk0s5
5:				 Apple_HFS MacBackup			 12.1 GB disk0s6
6:				 Apple_HFS MacintoshHD			 43.0 GB disk0s7

I did add following in org.chameleon.Boot.plist

<key>Default Partition</key>
<string>hd(0,6)</string>
However, it didn't help. I want chameleon to point MacintoshHD as a default NOT MacBackup.

#2
rockinron_1

rockinron_1

    InsanelyMac Sage

  • FAQ Team
  • 394 posts
  • Gender:Male
  • Location:UK
you answered your own question, you've told it to boot from your backup. change default partition hd(0,6) to hd(0,7) and you should be good to go

#3
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 738 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod
You simply set the wrong partition.
It should be hd(0,7)
As far as I know, you can set the default partition by it's name too.

#4
rakusson

rakusson

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Location:Denmark

you answered your own question, you've told it to boot from your backup. change default partition hd(0,6) to hd(0,7) and you should be good to go

You simply set the wrong partition.
It should be hd(0,7)
As far as I know, you can set the default partition by it's name too.

I changed to hd(0,7) but didn't work. Any suggestions? It seems chameleon is selecting the first HFS+ partition (i.e. MacBackup) as a default one.

#5
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 738 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

I changed to hd(0,7) but didn't work. Any suggestions? It seems chameleon is selecting the first HFS+ partition (i.e. MacBackup) as a default one.

Used the Name for that drive.

#6
rakusson

rakusson

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Location:Denmark

Used the Name for that drive.

I did it, unfortunately, not working. strange. Looks like Chameleon is ignoring 'default partition' option.

#7
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 738 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

I did it, unfortunately, not working. strange. Looks like Chameleon is ignoring 'default partition' option.

For me, as long as I set the name of the drive, everything works fine here.





Also tagged with one or more of these keywords: chameleon, wrong partition, default partition, boot partition


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy