Jump to content

Trying to rebuild kextcache in /extra/extensions Retail installation

Help pls

  • Please log in to reply
2 replies to this topic

#1
mini1k

mini1k

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts
Hi, first time hackintoshing my pc and I could really use some help from you hackontosh experts.

Here is what I did:

1. Download chameleon 2.1 boot cd.

2. Boot up installed fine.

3. Rebooted with boot cd in. Completed the account creation.

4. Installed chameleon bootloader from the cd.

5. made /Extra/Extensions folders

6. copied disabler.kext and fakesmc.kext to Extensions folder.

7. Put modified DSDT.aml in root

8. Fired up terminal and ran the following commands:

a. sudo chown -R root:wheel /Extra/Extensions

b. sudo chmod -R 755 /Extra/Extensions

When I run: sudo kextcache -v 1 -a i386 -a x86_64 -m /Extra/Extensions.mkext /Extra/Extensions

it gives me a lot of lines, something about no dependency on com.apple. something something...

Everything works fine. Graphics enabled. Just this annoying thing that stops me from booting up the system without the cd.

I tried googling for a solution but no go.

Can someone help me?

Thanks in advance.

System spec:
E5200
2gb ddr2
320gb sata
disabled onboard audio, floppy, ethernet.
usb sound card
usb wifi

#2
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
use kext wizard, it has utilities tab which can take care of it

#3
westwaerts

westwaerts

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 880 posts
  • Gender:Male
you need to install chameleon on your HD too.

chameleon is the booter for osx, without no music.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy