Jump to content

Inspiron 9400 10.6.8 troubleshoot

x1400 verbose Inspiron 9400 Dell KP snow leopard 10.6.8

  • Please log in to reply
1 reply to this topic

#1
SamuelL421

SamuelL421

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
Hello all, longtime lurker and first of all - thanks for all the amazing info the community here has supplied me with! This forum has helped me put together two great builds in the past (x58 on gigabyte boards - mostly foolproof, but still great info/learning to be found on these boards...)

So here's the current project - I have an old Dell Inspiron 9400. Its got a 1.83ghz core duo (not core2duo - so 32bit only I believe), 2gb ddr2, Sigmatel 9200HD audio, Broadcom 440 nic, 30gb ssd (placeholder for troubleshooting this install), and a Radeon x1400 Mobility. LINK to full specs

I had decent luck running everything on this system at 10.6.3 - audio working, wireless working, basic video functionality (x1400 unrecognized however). I was also running with only one core throughout this part of the install (OSX then identified as a core solo). I've since added in TSCsync kext and activating both cores works, although I can only boot currently with -x/safemode (see below)

------------------------------------------------------------------------------------------------------------------------

After things were going smoothly I installed the 440 broadcom kext, voodoo HDA 2.2, and my best guesses for the x1400 Radeon kexts - I used RadeonHD.kext (from this thread - mine was the 5/26/2010 - before extension modes/nubs added in), and ATIx1000 kext with <key>IOPCIMatch</key>
<string>0x71451002</string> added in (supposedly the x1400 ID...)


....From this point on out things have gotten progressively worse, I keep saving backups of kexts I'm editing and trying different combinations of bios settings, kext files, and workarounds. I'm in over my head and need some help from some pros in order to sort this out and continue learning. I have a feeling I'm doing something really idiotic in terms of my boot problems.

As of now I cannot boot normally, only with safe mode. Also, booting with verbose/-v results in the images below. "Photo-1" shows a snapshot of verbose and "Photo-2" (apologies, slightly blurry) is fractions of a second prior to the next screen appearing "Photo-3". This chain of events is consistent and always occurs when booting with only the "-v" flag. I have also reproduced this with and without my boot plist i386 setting and PCIRootUID=1 (not sure if I even need these??). As you can see in the pic, "Photo-3" is a scrambled grey bar on a white page. This occurs every time following the verbose boot. Attempting to boot with no flags results in a hang on the apple loading screen (wheel stops spinning and boot hangs/system unresponsive). Only means of successful boot at this point is using safe mode. Below I've attached the full listing of my system/library/extensions, extras/extensions, smbiost plist, and apple boot plist:

System\Library\Extensions:

ACard62xxM.kext

ACard68xxM.kext

ACard671xSCSI.kext

ACard6280ATA.kext

ACard6885M.kext

ACard67162.kext

Accusys6xxxx.kext

ALF.kext

Apple_iSight.kext

Apple16X50Serial.kext

AppleACPIPlatform.kext

AppleAHCIPort.kext

AppleAPIC.kext

AppleBacklight.kext

AppleBacklightExpert.kext

AppleBCM440XEthernet.kext

AppleBluetoothMultitouch.kext

AppleBMC.kext

AppleEFIRuntime.kext

AppleFileSystemDriver.kext

AppleFSCompressionTypeZlib.kext

AppleFWAudio.kext

AppleGraphicsControl.kext

AppleGraphicsPowerManagement.kext

AppleHIDKeyboard.kext

AppleHIDMouse.kext

AppleHPET.kext

AppleHWSensor.kext

AppleIntelCPUPowerManagement.kext

AppleIntelCPUPowerManagementClient.kext

AppleIntelE1000e.kext

AppleIntelGMA950.kext

AppleIntelGMA950GA.plugin

AppleIntelGMA950GLDriver.bundle

AppleIntelGMA950VADriver.bundle

AppleIntelGMAX3100.kext

AppleIntelGMAX3100FB.kext

AppleIntelGMAX3100GA.plugin

AppleIntelGMAX3100GLDriver.bundle

AppleIntelGMAX3100VADriver.bundle

AppleIntelHDGraphics.kext

AppleIntelHDGraphicsFB.kext

AppleIntelHDGraphicsGA.plugin

AppleIntelHDGraphicsGLDriver.bundle

AppleIntelHDGraphicsVADriver.bundle

AppleIntelIntegratedFramebuffer.kext

AppleIntelSNBGraphicsFB.kext

AppleIntelSNBVA.bundle

AppleIRController.kext

AppleKeyswitch.kext

AppleLPC.kext

AppleLSIFusionMPT.kext

AppleMatch.kext

AppleMCCSControl.kext

AppleMCEDriver.kext

AppleMCP89RootPortPM.kext

AppleMIDIFWDriver.plugin

AppleMIDIIACDriver.plugin

AppleMIDIRTPDriver.plugin

AppleMIDIUSBDriver.plugin

AppleMikeyHIDDriver.kext

AppleMobileDevice.kext

AppleMultitouchDriver.kext

AppleOnboardDisplay.kext

ApplePlatformEnabler.kext

AppleProfileFamily.kext

AppleRAID.kext

AppleRAIDCard.kext

AppleRTC.kext

AppleSDXC.kext

AppleSEP.kext

AppleSmartBatteryManager.kext

AppleSMBIOS.kext

AppleSMBusController.kext

AppleSMBusPCI.kext

AppleSMC.kext

AppleSMCLMU.kext

AppleStorageDrivers.kext

AppleThunderboltDPAdapters.kext

AppleThunderboltEDMService.kext

AppleThunderboltNHI.kext

AppleThunderboltPCIAdapters.kext

AppleThunderboltUTDM.kext

AppleTyMCEDriver.kext

AppleUpstreamUserClient.kext

AppleUSBAudio.kext

AppleUSBDisplays.kext

AppleUSBEthernetHost.kext

AppleUSBMultitouch.kext

AppleUSBTopCase.kext

AppleVADriver.bundle

AppleXsanFilter.kext

ArcMSR.kext

ATI1300Controller.kext

ATI1600Controller.kext

ATI1900Controller.kext

ATI2400Controller.kext

ATI2600Controller.kext

ATI3800Controller.kext

ATI4500Controller.kext

ATI4600Controller.kext

ATI4800Controller.kext

ATI5000Controller.kext

ATI6000Controller.kext

ATIRadeonX1000.kext

ATIRadeonX1000GA.plugin

ATIRadeonX1000GLDriver.bundle

ATIRadeonX1000VADriver.bundle

ATIRadeonX2000.kext

ATIRadeonX2000GA.plugin

ATIRadeonX2000GLDriver.bundle

ATIRadeonX2000VADriver.bundle

ATIRadeonX3000.kext

ATIRadeonX3000GA.plugin

ATIRadeonX3000GLDriver.bundle

ATIRadeonX3000VADriver.bundle

ATTOCelerityFC.kext

ATTOCelerityFC8.kext

ATTOExpressPCI4.kext

ATTOExpressSASHBA.kext

ATTOExpressSASHBA2.kext

ATTOExpressSASRAID.kext

AudioAUUC.kext

AudioIPCDriver.kext

autofs.kext

BootCache.kext

CalDigitHDProDrv.kext

cd9660.kext

cddafs.kext

CellPhoneHelper.kext

Dont Steal Mac OS X.kext

DSACL.ppp

DSAuth.ppp

DVFamily.bundle

EAP-KRB.ppp

EAP-RSA.ppp

EAP-TLS.ppp

exfat.kext

HighPointIOP.kext

HighPointRR.kext

ICAFWKodakProDriver.kext

ImmersionForceFeedback.kext

IO80211Family.kext

IOACPIFamily.kext

IOAHCIFamily.kext

IOATAFamily.kext

IOAudioFamily.kext

IOBDStorageFamily.kext

IOBluetoothFamily.kext

IOBluetoothHIDDriver.kext

IOCDStorageFamily.kext

IODVDStorageFamily.kext

IOFireWireAVC.kext

IOFireWireFamily.kext

IOFireWireIP.kext

IOFireWireSBP2.kext

IOFireWireSerialBusProtocolTransport.kext

IOGraphicsFamily.kext

IOHDIXController.kext

IOHIDFamily.kext

IONDRVSupport.kext

IONetworkingFamily.kext

IOPCIFamily.kext

IOPlatformPluginFamily.kext

IOSCSIArchitectureModelFamily.kext

IOSCSIParallelFamily.kext

IOSerialFamily.kext

IOSMBusFamily.kext

IOStorageFamily.kext

IOStreamFamily.kext

IOSurface.kext

IOThunderboltFamily.kext

IOUSBFamily.kext

IOUSBMassStorageClass.kext

IOVideoFamily.kext

iPodDriver.kext

iTunesPhoneDriver.kext

JMicronATA.kext

L2TP.ppp

LogitechForceFeedback.kext

mcxalr.kext

msdosfs.kext

ntfs.kext

NullCPUPowerManagement.kext

NVDANV40Hal.kext

NVDANV50Hal.kext

NVDAResman.kext

NVSMU.kext

OSvKernDSPLib.kext

PPP.kext

PPPoE.ppp

PPPSerial.ppp

PPTP.ppp

PromiseSTEX.kext

Quarantine.kext

RadeonHD.kext

Radius.ppp

Sandbox.kext

SM56KUSBAudioFamily.kext

SMARTLib.plugin

smbfs.kext

SMCMotionSensor.kext

SoftRAID.kext

System.kext

TMSafetyNet.kext

udf.kext

ufs.kext

VoodooHDA.kext

VoodooTSCSync.kext

webcontentfilter.kext

webdav_fs.kext



Extras/Extensions:


ACPIMonitor.kext

AppleACPIPS2Nub.kext

ApplePS2Controller.kext

ATI48xxInjector.kext

EvOreboot.kext

FakeSMC.kext

IntelCPUMonitor.kext

IOAHCIBlockStorageInjector.kext

JMicron36xATA.kext

NullCPUPowerManagement.kext

RadeonMonitor.kext

SuperIOFamily.kext



smbios.plist


<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">

<plist version="1.0">

<dict>

<key>SMbiosversion</key>

<string>######.tonymacx86.com</string>

<key>SMboardproduct</key>

<string>Mac-F22589C8</string>

<key>SMfamily</key>

<string>MacBook Pro</string>

<key>SMproductname</key>

<string>MacBookPro6,1</string>

<key>SMserial</key>

<string>C02CGEE6DC79</string>

</dict>

</plist>




com.apple.boot.plist


<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">

<plist version="1.0">

<dict>

<key>Kernel Flags</key>

<string>arch=i386, PCIRootUID=1</string>

</dict>

</plist>



Any ideas as to what's going on with my install? Is this happening because of the "ACPI_SMC_... WARNING..." (in photo 2) or more likely because of the Radeon x1400 kexts?

Any thoughts, ideas, or general help would be much appreciated!

Attached Files



#2
SamuelL421

SamuelL421

    InsanelyMac Protégé

  • Members
  • Pip
  • 6 posts
***Update - found an old link ID'ing one of my problems!!

Using ACPI files from 10.6.7, I now have 10.6.8 running correctly with both cores of my core duo. Turns out that I had two completely separate issues. Now that ACPI problems are resolved I am still having boot issues though... All of this seems to relate to my inspiron 9400's ATI mobility x1400 card. Deleting RadeonHD kext and ATIRadeonx1000 kext allows me to boot without safe mode but installing these seems to always result in the grey/crash screen below (photo 3 on first post).

Also attached below is a zip with the two Radeon kexts I'm trying to use, here's the full (but unformatted) info from those two kexts.... Any thoughts on what is causing the issue in the attached image?? (taken from moment before verbose mode crashes to grey/white screen)


RadeonHD.kext

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">

<plist version="1.0">

<dict>

<key>CFBundleDevelopmentRegion</key>

<string>English</string>

<key>CFBundleExecutable</key>

<string>RadeonHD</string>

<key>CFBundleIdentifier</key>

<string>com.dong.driver.RadeonHD</string>

<key>CFBundleInfoDictionaryVersion</key>

<string>6.0</string>

<key>CFBundleName</key>

<string>RadeonHD</string>

<key>CFBundlePackageType</key>

<string>KEXT</string>

<key>CFBundleShortVersionString</key>

<string>1.0</string>

<key>CFBundleSignature</key>

<string>????</string>

<key>CFBundleVersion</key>

<string>1</string>

<key>IOKitPersonalities</key>

<dict>

<key>RadeonDump</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.dong.driver.RadeonHD</string>

<key>IOClass</key>

<string>RadeonDump</string>

<key>IOMatchCategory</key>

<string>RadeonDump</string>

<key>IOProbeScore</key>

<integer>0</integer>

<key>IOProviderClass</key>

<string>RadeonHD</string>

<key>IOUserClientClass</key>

<string>RadeonHDUserClient</string>

</dict>

<key>RadeonHD</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.dong.driver.RadeonHD</string>

<key>IOClass</key>

<string>RadeonHD</string>

<key>IOMatchCategory</key>

<string>IOFramebuffer</string>

<key>IONameMatch</key>

<string>display</string>

<key>IOProbeScore</key>

<integer>30000</integer>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

<key>UserOptions</key>

<dict>

<key>BackLightLevel</key>

<integer>255</integer>

<key>MsgBufferSize</key>

<integer>65535</integer>

<key>debugMode</key>

<false/>

<key>enableGammaTable</key>

<false/>

<key>enableHWCursor</key>

<true/>

<key>lowPowerMode</key>

<false/>

<key>verboseLevel</key>

<integer>1</integer>

</dict>

</dict>

</dict>

<key>OSBundleLibraries</key>

<dict>

<key>com.apple.iokit.IOGraphicsFamily</key>

<string>1.1</string>

<key>com.apple.iokit.IONDRVSupport</key>

<string>1.1</string>

<key>com.apple.iokit.IOPCIFamily</key>

<string>1.1</string>

<key>com.apple.kpi.bsd</key>

<string>8.0</string>

<key>com.apple.kpi.iokit</key>

<string>8.0</string>

<key>com.apple.kpi.libkern</key>

<string>8.0</string>

<key>com.apple.kpi.mach</key>

<string>8.0</string>

</dict>

</dict>

</plist>




ATIRadeonx1000.kext


<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">

<plist version="1.0">

<dict>

<key>CFBundleDevelopmentRegion</key>

<string>English</string>

<key>CFBundleExecutable</key>

<string>ATIRadeonX1000</string>

<key>CFBundleGetInfoString</key>

<string>ATIRadeonX1000 1.6.10.32 (7770)</string>

<key>CFBundleIdentifier</key>

<string>com.apple.ATIRadeonX1000</string>

<key>CFBundleInfoDictionaryVersion</key>

<string>6.0</string>

<key>CFBundleName</key>

<string>ATI RadeonX1000 Kernel Extension</string>

<key>CFBundlePackageType</key>

<string>KEXT</string>

<key>CFBundleShortVersionString</key>

<string>1.6.10</string>

<key>CFBundleSignature</key>

<string>????</string>

<key>CFBundleVersion</key>

<string>6.1.0</string>

<key>IOKitPersonalities</key>

<dict>

<key>ATIRadeonX1000</key>

<dict>

<key>ATIEnableWideBlitSupport</key>

<true/>

<key>ATIUseTearingWideBlit</key>

<false/>

<key>CFBundleIdentifier</key>

<string>com.apple.ATIRadeonX1000</string>

<key>GpuDebugPolicy</key>

<integer>0</integer>

<key>IOCFPlugInTypes</key>

<dict>

<key>ACCF0000-0000-0000-0000-000a2789904e</key>

<string>ATIRadeonX1000GA.plugin</string>

</dict>

<key>IOClass</key>

<string>ATIRadeonX1000</string>

<key>IODVDBundleName</key>

<string>ATIRadeonX1000VADriver</string>

<key>IOMatchCategory</key>

<string>IOAccelerator</string>

<key>IOPCIMatch</key>

<string>0x71451002</string>

<key>IOProviderClass</key>

<string>IOPCIDevice</string>

<key>IOSourceVersion</key>

<string>1.6.10.32</string>

<key>sensor-properties</key>

<array>

<dict>

<key>device_type</key>

<data>

Z3B1LXNlbnNvcg==

</data>

<key>location</key>

<string>GPU</string>

<key>name</key>

<string>gpu-sensor</string>

<key>polling-period</key>

<data>

AAAAAQAAAAA=

</data>

<key>reg</key>

<data>

AAAAAg==

</data>

<key>sample-period</key>

<data>

AAAAAACYmAA=

</data>

<key>sensor-id</key>

<data>

AAAABg==

</data>

<key>version</key>

<data>

AAAAAg==

</data>

<key>zone</key>

<data>

AAAAAg==

</data>

</dict>

</array>

</dict>

</dict>

<key>NSHumanReadableCopyright</key>

<string>Copyright © 2004-2009 Apple Inc. All rights reserved.</string>

<key>OSBundleLibraries</key>

<dict>

<key>com.apple.iokit.IOGraphicsFamily</key>

<string>1.0.0b1</string>

<key>com.apple.iokit.IONDRVSupport</key>

<string>1.0.0b1</string>

<key>com.apple.iokit.IOPCIFamily</key>

<string>1.0.0b1</string>

<key>com.apple.kpi.bsd</key>

<string>8.0.0</string>

<key>com.apple.kpi.iokit</key>

<string>8.0.0</string>

<key>com.apple.kpi.libkern</key>

<string>8.0.0</string>

<key>com.apple.kpi.mach</key>

<string>8.0.0</string>

<key>com.apple.kpi.private</key>

<string>8.0.0</string>

<key>com.apple.kpi.unsupported</key>

<string>8.0.0</string>

</dict>

</dict>

</plist>

Attached Files







Also tagged with one or more of these keywords: x1400, verbose, Inspiron 9400, Dell, KP, snow leopard, 10.6.8


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy