Jump to content

chains boot error vs efi_inject_get_devprop_string null trying. Can't load Lion


  • Please log in to reply
1 reply to this topic

#1
Shasoosh

Shasoosh

    InsanelyMac Protégé

  • Members
  • Pip
  • 39 posts
I have a Windows 7 install and a Lion one.
Recently I added a new HFS+ empty partition to my system and since then i can't boot my Lion.
I tried recreating my MBR with easybcd, adding new entries etc' but i always get "Chains boot error".
If i try to use the EFI option in easybcd i see the chameleon screen on boot but after a few secons i see an error msg: efi_inject_get_devprop_string null trying stringdata and my system restarts.

My last try was downloading tboot that i found, renaming it to nst_mac.mbr anf that worked! I'm getting a Non-gui camelion screen that let me choose my OS.

So basicly i don't really understand what's going on.. why the EasyBCD EFI crash while other works fine?
Also, what ever i tried i couldn't change chameleon settings. I tried changing stuff in Chameleon Preference Pane in Lion but it's like the chameleon version that boots up ignore those settings. Is there a way to change chameleon settings from the chameleon screen itself without actually booting?

Thanks

#2
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
edit /Extra/org.chameleon.Boot.plist





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy