Jump to content

[GUIDE] Install OS X Mountain Lion 10.8.2 and Mavericks 10.9.1 on ASUS N53SN/N53SV/N53SM Notebooks

* * * * * 4 votes Asus N53SN Asus N53SV Asus N53SM Asus N53sn

  • Please log in to reply
157 replies to this topic

#121
Aidass

Aidass

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 173 posts
  • Gender:Male
  • Location:Vilnius, Lithuania

Today I've successfully updated to Mavericks

Screenshot%202013-10-08%2017.29.26.png

created bootable USB with myHack, copied my smbios.plist to usb's /Extra/ folder and that's all! you may need to backup your Extra folder as myHack can try to overwrite it and it's not possible to boot without correct smbios.plist (8,1 or 8,2). 

 

Actually even when installing 10.8 you don't need to replace any Intel HD kexts, just copy correct smbios to Extra folder



#122
manmal

manmal

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts

thanks!

are all other devices working properly (wifi,audio,etc)?

mal



#123
Aidass

Aidass

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 173 posts
  • Gender:Male
  • Location:Vilnius, Lithuania

yes, only USB 3.0 kexts are not working with Mavericks. But I don't use it so dunno if there are any compatible kexts



#124
manmal

manmal

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts

Very nice! Does sleep also work for you? Would you share your "Extra" folder (with your dsdt) with us? Thanks!! Mal



#125
Aidass

Aidass

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 173 posts
  • Gender:Male
  • Location:Vilnius, Lithuania

https://dl.dropboxus...12503/Extra.zip

just don't use my ssdt, as you're going to get KP.

and yes, sleep is working



#126
manmal

manmal

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts

Thank you! will try it too... what about SLE kexts? Which ones did you use? which bootloader are you using?  chameleon or clover and which version? Thanks!! 



#127
Aidass

Aidass

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 173 posts
  • Gender:Male
  • Location:Vilnius, Lithuania

No problem :)

here's my SLE folder (note, this is from 10.9)

https://dl.dropboxus...Extensions.zip 

Most of the kexts I used from first post, like battery kexts, Fn keys kext, and PS2 kexts. Intel HD kexts are stock maverick kexts, except they're modified to suppport VGA display port. IONetworkingFamily is bone stock, I just use Atheros injector kext. VoodooHDA for the audio and Modified AICPUPM.kext+DSDT+SSDT for the power management (fully working sleep)

I'm using newest version of Chameleon bootloader.



#128
eng_matt

eng_matt

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

@Aidass or anyone tried this for wifi ? 

 

http://www.insanelym...4-atheros-9285/

 

 

installed today  10.9 mavericks most os drivers working great but I have a problem Atheros Ar9285 wifi driver.  , installed kext but wifi didnt work. 

 

Also @Aidass  I tried your added ahteros injector , no luck :)  didnt work for me.

 

I guess we need dsdt patch edit , like my added link thread.  

 

I dont have time this days ,  İf anyone fix this issue .  on mavericks 10.9 , please share with us. ar9285 wifi kext , plist or injector or new pached duallink dsdt for full hd screen.

 

 

Thanks guys ,  anyone have this issue ? this days.  

 

see you soon.



#129
Aidass

Aidass

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 173 posts
  • Gender:Male
  • Location:Vilnius, Lithuania

I use stock wifi kexts, only with the atheros injector. You can try my DSDT, just add the dual link patch



#130
Shaom

Shaom

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Anyone got working usb 3.0 kext?

 

edit: In Mavericks of course :)



#131
dig_lam

dig_lam

    InsanelyMac Protégé

  • Members
  • Pip
  • 9 posts
  • Gender:Male
  • Location:Türkiye

Anyone got working usb 3.0 kext?

 

edit: In Mavericks of course :)

 

try :

 

http://www.insanelym...-x-with-source/

 

working fine


@Aidass or anyone tried this for wifi ? 

 

http://www.insanelym...4-atheros-9285/

 

 

installed today  10.9 mavericks most os drivers working great but I have a problem Atheros Ar9285 wifi driver.  , installed kext but wifi didnt work. 

 

Also @Aidass  I tried your added ahteros injector , no luck :)  didnt work for me.

 

I guess we need dsdt patch edit , like my added link thread.  

 

I dont have time this days ,  İf anyone fix this issue .  on mavericks 10.9 , please share with us. ar9285 wifi kext , plist or injector or new pached duallink dsdt for full hd screen.

 

 

Thanks guys ,  anyone have this issue ? this days.  

 

see you soon.

 

 

I managed to run wifi and Bluetooth with native kexts by DSDT edit. I also attached my DSDT.dsl file.

Device (RP02)
            {
                Name (_ADR, 0x001C0001)
                Device (ARPT)
                {
                    Name (_ADR, Zero)
                    Name (_SUN, One)
                    Name (_PRW, Package (0x02)
                    {
                        0x09, 
                        0x04
                    })
                    Method (_DSM, 4, NotSerialized)
                    {
                        Store (Package ()
                            {
                                "AAPL,slot-name", 
                                Buffer (0x08)
                                {
                                    "AirPort"
                                }, 

                                "device-id",
                                Buffer() 
                                { 0x30, 0x00, 0x00, 0x00 }, 
                                "device_type", 
                                Buffer (0x08)
                                {
                                    "AirPort"
                                },
                                "name", 
                                Buffer() 
                                { "pci168c,30" },

                                "model", 
                                Buffer ()
                                {
                                    "Atheros 9x8x 802.11 b/g/n Wireless Network Adapter"
                                }, 

                                "subsystem-id", 
                                Buffer (0x04)
                                {
                                    0x8F, 0x00, 0x00, 0x00
                                }, 

                                "subsystem-vendor-id", 
                                Buffer (0x04)
                                {
                                    0x6B, 0x10, 0x00, 0x00
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
                    }
                }

UPDATE 1: Bluetooth have some problems but Wi-Fi working.

Attached Files



#132
nikasio15

nikasio15

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
 
Maybe someone can help me!
 
I have an ASUS NS53SV-SX336V (i3, 4gb RAM, nvidia gt540m, Intel HD3000...), I'm running on it a ML 1.8.2 with almost working:
(HD3000, Sound, Sleep, Ethernet, Touchpad, FnKeys, USB 3.0)

 

But I can't get wifi card working. I tried with all kexts in this post but when I want to load it, I get an error saying : 
"/Extra/Extensions/IO80211Family.kext - no dependecy found for com.apple.iokit.IONetworkingFamily.".

The strange part is that I have that kext loaded (because my ethernet card is working ok).

I checked dependecies versions and all seems ok, also I added my wifi deviceId:vendorId .... and get nothing.
 
If I run lspci, it's said:
NetworkController: Intel Corporation Centrino Wireless-N 100
But if I checked it using System Information, it said:
"Atheros AR9285 802.11b/g/n Wireless Network Adapter"
 
Could someone get this card working?
 
Thanks in advanced.


#133
anerik70

anerik70

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
  • Gender:Male

 

 
Maybe someone can help me!
 
I have an ASUS NS53SV-SX336V (i3, 4gb RAM, nvidia gt540m, Intel HD3000...), I'm running on it a ML 1.8.2 with almost working:
(HD3000, Sound, Sleep, Ethernet, Touchpad, FnKeys, USB 3.0)

 

But I can't get wifi card working. I tried with all kexts in this post but when I want to load it, I get an error saying : 
"/Extra/Extensions/IO80211Family.kext - no dependecy found for com.apple.iokit.IONetworkingFamily.".

The strange part is that I have that kext loaded (because my ethernet card is working ok).

I checked dependecies versions and all seems ok, also I added my wifi deviceId:vendorId .... and get nothing.
 
If I run lspci, it's said:
NetworkController: Intel Corporation Centrino Wireless-N 100
But if I checked it using System Information, it said:
"Atheros AR9285 802.11b/g/n Wireless Network Adapter"
 
Could someone get this card working?
 
Thanks in advanced.

 

post your dsdt and i will inject wifi in it



#134
nikasio15

nikasio15

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

Hi anerik70.

 

Here is my DSDT. Thanks a lot

Attached Files



#135
anerik70

anerik70

    InsanelyMac Protégé

  • Members
  • PipPip
  • 79 posts
  • Gender:Male

Hi anerik70.

 

Here is my DSDT. Thanks a lot

try with unmodified kext



#136
eng_matt

eng_matt

    InsanelyMac Protégé

  • Members
  • Pip
  • 34 posts

try :

 

http://www.insanelym...-x-with-source/

 

working fine


 

 

I managed to run wifi and Bluetooth with native kexts by DSDT edit. I also attached my DSDT.dsl file.

Device (RP02)
            {
                Name (_ADR, 0x001C0001)
                Device (ARPT)
                {
                    Name (_ADR, Zero)
                    Name (_SUN, One)
                    Name (_PRW, Package (0x02)
                    {
                        0x09, 
                        0x04
                    })
                    Method (_DSM, 4, NotSerialized)
                    {
                        Store (Package ()
                            {
                                "AAPL,slot-name", 
                                Buffer (0x08)
                                {
                                    "AirPort"
                                }, 

                                "device-id",
                                Buffer() 
                                { 0x30, 0x00, 0x00, 0x00 }, 
                                "device_type", 
                                Buffer (0x08)
                                {
                                    "AirPort"
                                },
                                "name", 
                                Buffer() 
                                { "pci168c,30" },

                                "model", 
                                Buffer ()
                                {
                                    "Atheros 9x8x 802.11 b/g/n Wireless Network Adapter"
                                }, 

                                "subsystem-id", 
                                Buffer (0x04)
                                {
                                    0x8F, 0x00, 0x00, 0x00
                                }, 

                                "subsystem-vendor-id", 
                                Buffer (0x04)
                                {
                                    0x6B, 0x10, 0x00, 0x00
                                }
                            }, Local0)
                        DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
                        Return (Local0)
                    }
                }

UPDATE 1: Bluetooth have some problems but Wi-Fi working.

 

 

 

into device name_adr 0x00020000 insert

begin
 
Method (_DSM, 4, NotSerialized)\n
{\n
Store (Package (0x02)\n
        {\n
            "AAPL00,DualLink",\n
            Buffer (0x04)\n
            {\n
                0x01, 0x00, 0x00, 0x00\n
            }\n
        }, Local0)\n
    DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))\n
    Return (Local0)\n
}
end
 

 

@dig_lam

 

 

Can you add this duallink patch and compile your dsdt.aml here ? ,  I tried but failed , something wrong.   I deleted my macosx from laptop so  I didnt use dsdt editor or MasASL.app again.   

 

Thanks. :)



#137
nikasio15

nikasio15

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts

try with unmodified kext

 

It didn't work. Thanks anyway I'll keep trying.



#138
flitskikker

flitskikker

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:The Netherlands

@Aidass or anyone tried this for wifi ? 

 

http://www.insanelym...4-atheros-9285/

 

 

installed today  10.9 mavericks most os drivers working great but I have a problem Atheros Ar9285 wifi driver.  , installed kext but wifi didnt work. 

 

Also @Aidass  I tried your added ahteros injector , no luck :)  didnt work for me.

 

I guess we need dsdt patch edit , like my added link thread.  

 

I dont have time this days ,  İf anyone fix this issue .  on mavericks 10.9 , please share with us. ar9285 wifi kext , plist or injector or new pached duallink dsdt for full hd screen.

 

 

Thanks guys ,  anyone have this issue ? this days.  

 

see you soon.

 

Hi,

 

I'm on 10.8.2 thanks to your instructions, kexts and DSDT patches (to disable the NVIDIA GPU and such), so thank you very much. :D

Now I'm wanting to update to 10.9 Mavericks. Since your stuff apparently works for me, too, I was wondering if everything works okay for you now.

 

@Others:

Anyone experience with running 10.9 on this type of laptop?

 

Asus N53SV-SZ404V

Intel Core i7 2630QM @ 2 GHz
Intel Mobile HM65 Chipset
6 GB DDR3 RAM
Intel HD 3000 + NVIDIA GeForce GT540M (only Intel is fine)
750 GB HDD with MBR partition table (important, because of Win8 dual-boot)
Atheros Wi-Fi (don't know which model)
1920x1080 Full HD Resolution
 
10.8.2 works fine, but I'm using a lot of custom drivers (eng_matt's), so I'm hesitating to update.

 

Thanks in advance!

 

Cheers,

Flitskikker



#139
manmal

manmal

    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 435 posts

What about bluetooth? It disappeared with 10.9 ... and is there any applehda 10.9 patched for this laptop? if there is an update-kexts-extra pack for 10.9 it will be appreciated a lot! thanks



#140
AndriusT

AndriusT

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Today installed 10.9 on my Asus N53SV. Works everything except bluetooth.







Also tagged with one or more of these keywords: Asus N53SN, Asus N53SV, Asus N53SM, Asus, N53sn

  Topic Stats Last Post Info

1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy