Jump to content

Need help! - How get fully working AMD on Snow Leopard

AMD Snow leopard HDMI audio

  • Please log in to reply
4 replies to this topic

#1
cerealkiller140

cerealkiller140

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Hi all,

First I want to thank you for this fantastic forum is incredible.

Moving on, I have a team for some time, before of course you want me immersed in the world of hackintosh, which I could install Snow Leopard fully updated and without serious problems.

My PC is:

AMD Phenom II 925 4-core
Mobo: Gigabyte GA-MA69VM-S2 (F11 BIOS).
2GB DDR2 Kingston Hyper-X 1066.
Graphics: Sapphire Radeon HD 6450 512 DDR3.
Disks: 1 TB Caviar Green wdigital.
60GB OCZ Agility 3 SSD.

My installation and distro:

Snow Leopard (iatkos s3 v2) flly updated 10.6.8 and running in 64 bits.
Bootloader: 6.10 PC_EFI

My boot options:


<key>Boot Graphics</key>
<string>Yes</string>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>Kernel</key>
<string>legacy_kernel</string>
<key>Darkwake</key>
<string>0</string>
<key>Kernel Flags</key>
<string>-force64 arch=i386</string>
<key>Quiet Boot</key>
<string>Yes</string>
<key>Timeout</key>
<string>5</string>

What I want is to fix some things that do not work and I have not managed to solve.

1 HDMI audio through my Radeon HD. No how.
2 When restarting the computer, the screen goes black and does nothing. I have to reset it.
3 The Sleep mode does not work, when I click on sleep, the computer turns off and when I turn it on the screen goes black.

I've been reading a lot, and I think my option is to create a custom DSDT for my motherboard, but I'm totally lost on this issue.

So I need your help, to help me create a DSDT to fix these things.

With DSDTSE I extracted my DSDT, but now I'm not using any dsdt. I installed everything using kexts.

This link is my extracted dsdt:

http://depositfiles....files/c3rdsinhf


Some screenshots of my pc:



Posted Image

Posted Image

Posted Image

Posted Image




Thank you all in advance. I hope your answers carefully :)

#2
cerealkiller140

cerealkiller140

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Please, I'm so impatient to make my system full. Thanks in advance! ^^

#3
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 2,990 posts
  • Gender:Male
Hi

and justly to have a stable and fluid system, it takes patience! ;)

yes, maybe a proper dsdt would resolve those issues

or

1) try this patching ATIConnectors !

2) try with EvOreboot.kext

3) try with SleepEnabler.kext


Good luck



Cordially

#4
cerealkiller140

cerealkiller140

    InsanelyMac Protégé

  • Members
  • Pip
  • 3 posts
Hi fantomas1,


I've tried these kexts without results (EvoReboot and Sleepenabler). I'll have a look at patching connectors.

Anyway, I just realized that when I compile my dsdt with DSDTSE jumps me a "Warning 1081 - Reserved method must return a value ^ (_WAK)".

Can anyone help me fix this error?

Thanks in advance. Greetings ;)

#5
DayvG

DayvG

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hi, did you manage to get audio working over HDMI? I have a very similar setup and I'm unable to get audio over HDMI.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy