Jump to content

Atheros AR5007 on Compaq

Compaq Atheros AR5007 Presario CQ61 Laptop Wireless Mac OS X Airport

  • Please log in to reply
8 replies to this topic

#1
Aviv258958

Aviv258958

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Hello Dear Friends,
This is my first post. But I'm not new,
I have a Laptop (Compaq Presario CQ61) with the Following Specifications (http://h10010.www1.h...8492.html?dnr=1).
I've been trying to find a Driver / Kext that matches my Computer for months, When I didn't found (last year) I finally gave up and Uninstalled Mac From my Laptop, This time I decided to Install it again and See if there Any updates on the Subjects, Unfortunately I didn't find Anything. I did found "AR5007.pkg" "AirportAtheros.kext" "IO80211Family.kext", But these Never worked. Now I installed those and I see theres a Wifi Icon says "Wifi: No hardwere detected", No Airport, Nothing. I tried finding Wifi with KisMac, Didn't find any, I've been researching this for Too Long alone,

So I thought maybe here I'll get my help and I won't need to retire from Mac again, I just love mac :)
Please Help me? As I said Above, these are My Computer Details - http://h10010.www1.h...8492.html?dnr=1

P.S: I got iATKOS L2, 10.7.2. Runing PdaNet with My iPhone provides me Internet for this time..

- Thanks for Reading,
Aviv Amar.

#2
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
Kissmac is for scanning wifi networks, so would still require already working wifi adapter. Use this System Info, an app to get hardware and kexts info and get device/vendor ID's first, and from there can see about enabling it.

#3
Aviv258958

Aviv258958

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Umm, Thanks for Answering me. I really thought no one will help me :)

Here is a screen shot of the Program with the Atheros Card Selected:
Posted Image

Thanks for helping, Can We do something with this? can this be fixed?

#4
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
For that card, rebranding may be needed or it may not be possible to work at all, so first will need some more detailed info. Download and install attached lspci and then run this command in terminal:
lspci -vvnn
and post results section for wifi only, will looks kinda like this, but with your cards info:
05:00.0 Network controller [0280]: Atheros Communications Inc. AR5418 Wireless Network Adapter [AR5008E 802.11(a)bgn] (PCI-Express) [168c:0024] (rev 01)
Subsystem: Apple Inc. AR5BXB72 802.11abgn Mini PCIe Card [AR5008E-3NX] [106b:0087]
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 256 bytes
Interrupt: pin A routed to IRQ 17
Region 0: Memory at fbdf0000 (64-bit, non-prefetchable)
Capabilities: [40] Power Management version 2
  Flags: PMEClk- DSI- D1+ D2- AuxCurrent=375mA PME(D0+,D1+,D2-,D3hot+,D3cold-)
  Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
  Address: fee00000  Data: 4097
Capabilities: [60] Express (v1) Legacy Endpoint, MSI 00
  DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
   ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
  DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
   RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
   MaxPayload 128 bytes, MaxReadReq 512 bytes
  DevSta: CorrErr- UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
  LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
   ClockPM- Suprise- LLActRep- BwNot-
  LnkCtl: ASPM Disabled; RCB 128 bytes Disabled- Retrain- CommClk-
   ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
  LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
  Vector table: BAR=0 offset=00000000
  PBA: BAR=0 offset=00000000
Capabilities: [100] #168c
Capabilities: [002] #24

Attached Files



#5
Aviv258958

Aviv258958

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Umm, Okay I just downloaded it and Installed.
It gave me "lspci: Cannot find any working access method."
So I booted up to 32 bit mode. It fixed it. This is My Atheros Details:

02:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR5001 Wireless Network Adapter [168c:001c] (rev 01)
Subsystem: Hewlett-Packard Company Unknown device [103c:137b]
Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr+ Stepping- SERR+ FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Latency: 0, Cache Line Size: 64 bytes
Interrupt: pin A routed to IRQ 16
Region 0: Memory at d3500000 (64-bit, non-prefetchable)
Capabilities: [40] Power Management version 2
Flags: PMEClk- DSI- D1- D2- AuxCurrent=375mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
Status: D0 PME-Enable- DSel=0 DScale=0 PME-
Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
Address: fee00000 Data: 4093
Capabilities: [60] Express (v1) Legacy Endpoint, MSI 00
DevCap: MaxPayload 128 bytes, PhantFunc 0, Latency L0s <512ns, L1 <64us
ExtTag- AttnBtn- AttnInd- PwrInd- RBE- FLReset-
DevCtl: Report errors: Correctable- Non-Fatal- Fatal- Unsupported-
RlxdOrd+ ExtTag- PhantFunc- AuxPwr- NoSnoop-
MaxPayload 128 bytes, MaxReadReq 512 bytes
DevSta: CorrErr+ UncorrErr+ FatalErr- UnsuppReq+ AuxPwr- TransPend-
LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <64us
ClockPM- Suprise- LLActRep- BwNot-
LnkCtl: ASPM L1 Enabled; RCB 128 bytes Disabled- Retrain- CommClk+
ExtSynch- ClockPM- AutWidDis- BWInt- AutBWInt-
LnkSta: Speed 2.5GT/s, Width x1, TrErr- Train- SlotClk+ DLActive- BWMgmt- ABWMgmt-
Capabilities: [90] MSI-X: Enable- Mask- TabSize=1
Vector table: BAR=0 offset=00000000
PBA: BAR=0 offset=00000000
Capabilities: [100] #168c
Capabilities: [001] #1c16
Capabilities: [470] #4a
Capabilities: [101] #1c16
Capabilities: [470] <chain looped>

Thanks For Helping again, :)

#6
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
http://www.insanelym...a-vanilla-card/ This is your only possible option afaik. I can't help you with the process due to the possibility of bricking your wifi card, and I don't want to be responsible. Read entire thread as many times as needed to fully understand as best you can and see what others may have done wrong prior to doing anything yourself. Or buy a new compatible card or compatible USB wifi.

#7
Aviv258958

Aviv258958

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
F**ck, I think I'll buy an TP-Link Card in $12
Or I'll try it untill then.
Thank you very much for helping. I'll update you IF I have any problem if thats okay :)

#8
eep357

eep357

    Triple Platinum

  • Supervisors
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
If your willing to buy a replacement anyway, might as well try and if you brick it, at least gain experience in the process :)

#9
LatinMcG

LatinMcG

    Insanely digesting DSDT

  • Members
  • PipPipPipPipPipPipPipPipPipPipPip
  • 2,508 posts
  • Gender:Male
  • Location:Tampa, Florida
his card is AR5BXB63 =bad , no rebrand.. give up.

buy ar5b91 (with no pins missing... look at pic of cards on ebay, some have a few pins missing. not preffered) works out of box.. but the comapaq 104 unauthorized bios error locks it out.

bios mod for NO WHITELIST(so u can use any wifi card inside it) for your laptop model =SP51527.exe http://www.bios-mods..._ByCamiloml.exe
if u need help flashing from usb dos, i can help.





Also tagged with one or more of these keywords: Compaq, Atheros, AR5007, Presario, CQ61, Laptop, Wireless, Mac OS X, Airport


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   Web hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy