Jump to content

[Solved] Strange boot delay

slow boot

  • Please log in to reply
3 replies to this topic

#1
tepaks

tepaks

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Interests:Sinclair ZX Spectrum 48 +
    x86/x64 PC
    x86/x64 iHack
Ever sins I updated my iHack to 10.7 a strange boot delay occurs.
Ok long story short. I've cleared all kernel.log errors and shaved 15 sec but major
62 sec delay is still there. Here is my kernel.log:
Any ideas?

kernel log

Oct  5 19:13:25 kernel[0]: fsauth: EventQueueUserClient::clientMemoryForType()
Oct  5 19:14:27 kernel[0]: virtual bool IOHIDEventSystemUserClient::initWithTask(task*, void*, UInt32): Client task not privileged to open IOHIDSystem for mapping memory (e00002c1)


#2
iFIRE

iFIRE

    InsanelyMacaholic

  • Moderators
  • 3,769 posts
  • Gender:Male
  • Location:Bcn-Spain

DISABLE SECURE VIRTUAL MEMORY

sudo defaults write /Library/Preferences/com.apple.virtualMemory DisableEncryptedSwap -boolean yes


#3
tepaks

tepaks

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Interests:Sinclair ZX Spectrum 48 +
    x86/x64 PC
    x86/x64 iHack
Thank You for trying, unfortunately it shaved only a few seconds from boot time :(

kernel log looks different but a huge delay is still present

Oct 6 16:11:45 kernel[0]: DSMOS has arrived
Oct 6 16:12:38 kernel[0]: com_lnx2mac_RealtekRTL81xx: Ethernet address ( entry removed from post )
Oct 6 16:12:47 kernel[0]: virtual bool IOHIDEventSystemUserClient::initWithTask(task*, void*, UInt32): Client task not privileged to open IOHIDSystem for mapping memory (e00002c1)
Oct 6 16:12:47 kernel[0]: CODE SIGNING: cs_invalid_page(0x1000): p=143[GoogleSoftwareUp] clearing CS_VALID

no difference in window server log

Oct 06 16:10:54 [81] loginwindow connection closed; closing server.
Oct 06 16:11:44 [81] Server is starting up
Oct 06 16:12:44 [81] CGXDisplayInitPageFlip: page flip mode is on


#4
tepaks

tepaks

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Interests:Sinclair ZX Spectrum 48 +
    x86/x64 PC
    x86/x64 iHack
After countless hours of reading flaming Lion comments and clearing all ASL log error messages, average boot time was still 1:50 ( cold boot ).
And than, jus like Sherlock Holmes said, "When you have eliminated the impossible, whatever remains, however improbable, must be the truth".
Well only thing remaining was the hardware itself :wallbash: My second iHack running 10.6.8 mislead me all the time ( booting within < 60 sec with same MB & BIOS)
So to cut the long story short, BIOS was the culprit, to be more specific the AHCI option. Soon enough i've found a good working modified BIOS and voila!

This old fart boots within < 40 sec ( cold boot, kernel cache rebuild & enabled )

n.b. if everything went OK you shod see something like this in your system report:

( Steve Jobs R.I.P & Bill Gates go f**** Y'r self, pardon my french, i mean Eat My Dust! )

Attached Files







Also tagged with one or more of these keywords: slow boot


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy