Jump to content

9800 GT woes (nvenabler, efi string, GE/Y and disappearing .plists)


  • Please log in to reply
8 replies to this topic

#1
djfremen

djfremen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
I've done a ton of leg work but still am coming up empty every time.

From another forum a user with my same setup reported enable the 9800's full graphics potential. He can now change resolutions, view duel screens and has QE.

Here's my setup:
GA-EP45T-DS3R w/ F4c beta BIOS
Sparkle 9800 GT, 512 DDR3
Quad Xeon processor @ 2.83

Post installation (used Tseug scripted method) I add EFI strings via OSX86 tools to org.chameleon.plist and also enable GE/yes.

Then I replace (per success story) NVDANV50Hal.kext with a DP4 I downloaded.

When I reboot it says the following in system profiler and has no video resolutions outside my default in org.chameleon.plist. (See screenshot)

I have three HD's with various versions of working installs in this box (10.5.7, 10.6.8) but I keep hitting the wall here on ML with this video resolution issue.

What makes matters worse, I use this system remotely (screen share) and the graphics issue causes the entire computer to choke. Really frustrating.

Attached File  ImageUploadedByTapatalk1349064899.993992.jpg   366.04KB   44 downloads

Lastly, I've read about people adding device Ids to their Nvidia kext files but when I check console, it says it "removed personalities from kernel" and sure enough when I view "show contents" on the specific kext, it deleted the info.plist file! Why is this happening on a fresh install?

Currently have two identically 10.8.2 installs (one of which I'm mucking up and then replace kext files again)

Anyone have any thoughts please?



Ugh! Double post. Sorry!! Hate this app.

#2
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 742 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod
as for losing plist files, after installing check the original install media.
Get the kext from it (remember to add your id if needed) and put the kext in SLE again
See if it works.

#3
djfremen

djfremen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
Quick question about DP4. What does that refer to? Developers Preview? Also, why would replacing those kexts from a previous version work? Seems like an antiquated process.

Did a complete reinstall and the kext plists are still getting messed up. When I replace with DP4, the system KPs. Ugh.

#4
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 742 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

Quick question about DP4. What does that refer to? Developers Preview? Also, why would replacing those kexts from a previous version work? Seems like an antiquated process.

Did a complete reinstall and the kext plists are still getting messed up. When I replace with DP4, the system KPs. Ugh.

Yes, DP means Developers Preview.
Some people have met the situation when you finished installing the os x and you'll find the plist file disappear in the kext file
So you need to replace it with the original one

#5
djfremen

djfremen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
Yes. I think I've discovered the culprit. Since I had to delete kexts from the ML boot key to avoid "black screen" and KP during install. The ones copied to the system now lack that plist file.

I've replaced now I KP with the GeForce.kext (no KP without it).

My next move is to install a different DSDT as maybe that has something to do with my graphics problem.

#6
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,884 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Dont use both : dsdt / EFI gpu injection together with chameleon graphicsenabler=yes.
USe only one of them, because both try the same "thing" and you get bad results.

9800GT is 8800GT chipset which is very compatible / easy OS X handling and doent need any patch nor (in mots cases) dev iD addings in the .kext.

First tell use which dev-id your gpu has (for checking chamleon graphicsenabler support).
0x605 is normaly dev-id for 9800GT and is supported by chameleon. (2030+)

#7
djfremen

djfremen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
That's really interesting about GE support. It literally never worked for me. Andrew from Rampage Dev was nice enough to help me inject my DSDT. So I'm no longer using kexts other than Fakesmc.

Strangely enough, still not getting Q/E.
He suggested starting from scratch.
Reinstalling now...
I'll check back if I figure this out.

#8
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,884 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Normally you DONT need any DSDT or enabler.kext using newer Chameleon bootloaders (newer than 6 months) if you use graphicsenabler=y in chameleon .plist.
I use 9600 GT in the past also with dsdt gpu injection but removed that since 1 year and use chameleon.

#9
djfremen

djfremen

    InsanelyMac Protégé

  • Members
  • PipPip
  • 50 posts
New install worked! Now full Q/E with GraphicsEnabler=No in ML 10.8.2!

Interestingly though, max resolution on both displays is 1600x1200. Thought the 9800 for sure would spit out 1920x1200.

It's never good enough is it ;)





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy