Jump to content

Help with AGPM


  • Please log in to reply
6 replies to this topic

#1
mcdougal33

mcdougal33

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
  • Gender:Male
Ok I am on 10.8.2 and using the nvidia drivers that come with 10.8.2. I have a gtx 560ti and I'm trying to wrap my head around the thresholds in AGPM kext. Here is what I have for threshold values. Can somebody tell me why my card never enters state 2? I don't want state 3 to be used at all. Right now it sits in state 1 most of the time and it will switch to 0 when it needs to.

<key>Threshold_High</key>
<array>
<integer>55</integer>
<integer>45</integer>
<integer>75</integer>
<integer>100</integer>
</array>
<key>Threshold_Low</key>
<array>
<integer>0</integer>
<integer>85</integer>
<integer>99</integer>
<integer>100</integer>
</array>


#2
Rampage Dev

Rampage Dev

    InsanelyMac Deity

  • Local Moderators
  • 1,978 posts
  • Gender:Male
Read my mountain lion AGPM guide here:

http://rampagedev.wo...raphic-cards-2/

#3
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,880 posts
  • Gender:Male
  • Location:Stuttgart / Germany
You can use tool OpenGL Triangles (together with atMonitor 2.7.1 for gpu load % view) to figure out AGPM working / Pstate switching.
http://www.insanelym...engl-triangles/

If you put more gpu load % (a few % up to full load (>= 90%))) by highering the triangles count (from 20 up to a few thousand) you can check AGPM switches (console output by setting Logcontrol=1 in AGPM kext).

#4
mcdougal33

mcdougal33

    InsanelyMac Protégé

  • Members
  • PipPip
  • 82 posts
  • Gender:Male
Thanks. I got it working now. It switches between states 0,1 and 2 like it should now. It looks like my card (according to cpu-z in windows) only has 3 power states. 50mhz, 405mhz and 822mhz. Those clock speeds correspond with states 2,1 and 0. State 3 is useless in my case. I'm hoping that by locking out state 3 that it fixes the random channel timeout errors I've been getting (so far no issues in 2 days). If that doesn't work then I'll keep it in state 1 and see what happens.

#5
stefano.85

stefano.85

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 229 posts
  • Gender:Male
  • Location:Italy
Hi guys, i have similar problem with a geforce 9400m (ATOM n330+ ION). my GFX has 4 states according to CPUZ.
In snow leopard 10.6.8 with a modded legacyAGPM.kext when in idle it stays in state2 but in ML (with vanilla agpm.kext modded) it always switch from 1 and 0 states only.
I've read Rampage Dev article related to AGPM and i think i don't understand at all the difference between 10.6-7 and 10.8 power management.
I've tried both atmonitor+opengl triangles bench, and even if the gpu percentage is low (8-10%) the state is always 1.
Where am i wrong? tnx for troubleshooting
cheers

#6
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,880 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Maybe, because of your AGPM parameters even running only 8% gpu load (using OpenGL triangles at lowest count + atMonitor to show gpu load) are some wrong.
Try to run only atMonitor and check back gpu % load (shoud be 1%) and the G-State in console. You must wait some time (1-2 sec ) for changes shown in console.
Only if there is also no G-State 2 (or 3) = lower gpu State something is wrong with your AGPM settings.

I found out that switching up to faster G-Step (G-State down) goes fast / at less gpu loads. But switsching down needs really less gpu loads.
2>1 is for me if less than around 21% gpu load.

#7
stefano.85

stefano.85

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 229 posts
  • Gender:Male
  • Location:Italy
ok, i'll try that.
i'll make some screenshots to show you in case of problem.
tnx mitch





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy