Jump to content

Problema installazione .pkg

- - - - -

  • Please log in to reply
4 replies to this topic

#1
cili0

cili0

    InsanelyMacaholic

  • FAQ Team
  • 3,008 posts
  • Gender:Male
  • Location:Italy
Ciao a tutti,

ho notato che tutte le volte che installo un .pkg che implichi l'installazione di qualche kext in /S/L/E (come i combo update) l'installer mi da il seguente errore:

Sep 23 11:18:30 localhost installd[494]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=121 "An error occurred while updating system extension information." UserInfo=0x7fa0e9c46840 {NSUnderlyingError=0x7fa0e9eaa910 "The operation couldn’t be completed. (kextcache error 71.)", NSLocalizedDescription=An error occurred while updating system extension information., arguments=(
"-update-volume",
"/",
"-Installer"
)} {
NSLocalizedDescription = "An error occurred while updating system extension information.";
NSUnderlyingError = "Error Domain=kextcache Code=71 \"The operation couldn\U2019t be completed. (kextcache error 71.)\"";
arguments = (
"-update-volume",
"/",
"-Installer"
);
}


Sembra ci sia un qualche problema con kextcache o i permessi. Ma non riesco a venirne a capo. L'installazione alla fine va a buon fine, ma è decisamente irritante questo problema.

Qualcuno ha qualche idea?

grazie,
cili0.

#2
joe2009

joe2009

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 363 posts
  • Location:Firenze
Ho fatto un giro sul web ed ho visto che il problema, in molti casi, è relativo ad un conflitto con altro kext già presenti/installati sul Mac.

#3
cili0

cili0

    InsanelyMacaholic

  • FAQ Team
  • 3,008 posts
  • Gender:Male
  • Location:Italy
Ciao joe,

grazie per l'aiuto. Potresti gentilmente passarmi il link ai riferimenti che hai trovato?

Grazie,
cili0.

#4
joe2009

joe2009

    InsanelyMac Sage

  • Members
  • PipPipPipPipPip
  • 363 posts
  • Location:Firenze

Qui Parla di problemi causati da kext di terze parti:


http://www.insanelym...cache-error-71/


..in questa discussione si parla anche della directory: /System/Library/Caches/com.apple.kext.caches/Startup/ dove (anche se a mio avviso l'utente ci ha un po' pasticciato piazzandoci Extensions.mkext dentro) ci sono dei files interessanti… tra cui il "KextIdentifiers.plist.gz" che se provi a copiare da parte e poi (dopo averlo scompattato) ti troverai un file .plist che probabilmente serve al mac per il controllo della genuinità di alcuni kext (ma qui la sparo lì tanto per fare un'ipotesi)





Qui si parla di kext che danno noia, nel caso specifico: Sierraxxx.kext, LogitechHIDDevices.kext and LogitechUnifying.kext, per l'installazione di un certo software.


https://discussions....tart=0&tstart=0



Ci sono anche altre discussioni (soprattutto sul sito delle bestie)....ma pare che il problema sia dovuto principalmente ad un conflitto.... bisognerebbe analizzare bene il log completo dell'errore.


#5
cili0

cili0

    InsanelyMacaholic

  • FAQ Team
  • 3,008 posts
  • Gender:Male
  • Location:Italy
Grazier per la dritta. Vedo sembra possa dipendere dai kext non autenticati, io effettivamente ho un errore usando:

sudo kextcache -system-prelinked-kernel -all-loaded


dovuto a SuperIOSensors.kext

Prelink failed for org.hwsensors.driver.SuperIOSensors; aborting prelink.


Adesso ho tolto il kext ed il comando sembra andare. Non riesco però a trovare sul git di HWSensors il kext in questione per 10.8. Ha forse cambiato nome?

ciao!





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy