Jump to content

ASUS Zenbook Prime UX31A-DB51 Ultrabook - fixes, mods, tweaks, etc


  • Please log in to reply
960 replies to this topic

#101
Thomas2111

Thomas2111

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts

1_
Someone also suggested adding this to the plist:
<key>HD4000PlatformId</key>
<string>3</string>
I'll have to try it.

2_
BTW, is there a reason why you left some kexts in the /E/E folder? Why not move the kexts in the mkexts into the /S/L/E folder on the install drive too?

3_
Did you get the App Store to work?

1_For what?
2_There's no kext in /E/E in the hope.zip i've uploaded?
3_I didn't get that :/ if you want updates, you should search the .DMG files

Sorry, but, instead of deleting AppleUSBXHCI.kext, use my dsdt at first/second page, patched for a lot of things (maybe you need to add your audio edit under HDEF).

_Thank you, i'll try this, (there is a chance that my DSDT works already with AppleUSBXHCI.kext cause my dsdt is based on yours)
[EDIT] tested, but freeze when plug usb key. that work without AppleUSBXHCI.kext, i don't care, don't worry.


I'll reinstall mac osx soon, trying the kext added on the first post

#102
duklaa

duklaa

    InsanelyMac Protégé

  • Members
  • Pip
  • 47 posts
Does USB 3.0 work on UX31A? My USB ports show up as 2.0 in the system profile.

#103
cyf

cyf

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts

1_For what?

To get the video to work. Mine is still not working--at least only the external is working. I added in the SSDT's and maybe that's messing with it too.

2_There's no kext in /E/E in the hope.zip i've uploaded?


There ARE kexts in the /E/E that you uploaded. My question is "why do you have kexts in the /E/E (I presume on the partition where you installed ML) instead of putting it in the /S/L/E?" Is it because Chameleon looks for it there?

3_I didn't get that :/ if you want updates, you should search the .DMG files


Still working on it. I'm mainly interested because I want to get iCloud and download apps (e.g., Evernote). AND you never know when something is going to show up on the App Store that you want instead of looking all over the place for it. I'm afraid to update anything at this point. :/

I'll reinstall mac osx soon, trying the kext added on the first post


If you're going to do a complete reinstall, can you install using GPT and UEFI? I would, but I'm still having problems booting into the installer. Thomas, your instructions, while helpful, was for non-UEFI windows 7.

This may be a Clover question (still trying to get that to work, but because of all my messing around, my partitions are on odd numbers (e.g., EFI that has Windows bootloader is on 1, Windows 8 is on 3, while Mac OS X is on 5 and a data partition NTFS is on 6.) Maybe I should reformat and start over once (IF) Thomas you redo yours. :-)

For the USB-Ethernet adapter, don't install the official drivers--they didn't install for me either. Did you try the kext I posted for the Network that had the kext for the adapter in the plugins? That works for me still, even though I'm messinga round with the DSDT and SSDT's.


Does USB 3.0 work on UX31A? My USB ports show up as 2.0 in the system profile.


My USB 3.0 doesn't work either, but that's because I also took out the AppleUSBXHCI.kext, which is for USB 3.0 support. I'll have to mess with that later. I don't use USB 3.0 often, except for this one 3.0 USB drive I have for backup, which runs overnight anyway. However, it would be nice.

Re: Clover--Yep. Did you use that Aptio driver under Drivers64x or whatever it's called. I should ask on the Clover forum. Are you dual booted? Which did you install first (Windows or Mac OS X)? Did you install Chameleon directly on the partition? Details, please.

Lastly, I have a UX21A, again the same as the UX31A, but without the card reader.

Going to mess around with the PciUID setting, because I remember setting to 0 seemed to work for the video (getting it to output to both internal LCD and external HDMI monitor)--right now it only works with external, which has to be connected to work, otherwise the internal LCD just sits there with the last message of finished booting and does not show desktop. I'll post pictures when I get home.

Someone point me to a good guide for learning how to edit DDST's!!!

Edited by Lejenk, 29 March 2013 - 07:35 PM.
Removed reference.


#104
cyf

cyf

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts

Sorry, but, instead of deleting AppleUSBXHCI.kext, use my dsdt at first/second page, patched for a lot of things (maybe you need to add your audio edit under HDEF).


You mean take the DSDT you posted and add this HDEF from this post?

http://www.insanelym...20#entry1855804

Sorry I'm total noob to the DSDT patching thing, but I'm trying to figure it out.

Also, in Chameleon, I click on Drop SSDT, but it seems to load only one SSDT as it can't find a "SSDT.aml". I noticed the ones I have in /Extra on my Chameleon boot USB starts with "SSDT-0.aml" and ends with "SSDT-10.aml". Should I move them to /System/Extra on my partition where I installed ML?

#105
cyf

cyf

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
Okay, so I followed the instructions and re-did my system. Amazingly, I didn't have to reinstall ML. I just used Kext Wizard to (re)install nhart's kexts, subbed in the DSDT/SSDTs from you guys, and voila, everything worked. I did keep my IONetworkingFamily.kext as that had my working AX88772B driver, and I also found a IOBluetoothFamily.kext and IOBluetoothHIDDriver.kext that seems to address error message related to a dependency on some bluetooth error. However, I still get this:

11/5/12 5:47:12.000 PM kernel[0]: **** [AppleBluetoothHCIControllerUSBTransport][configurePM] -- ERROR -- waited 30 seconds and still did not get the commandWakeup() notification -- this = 0xffffff800a99a800 ****
11/5/12 5:47:12.000 PM kernel[0]: [IOBluetoothHCIController::setConfigState] calling registerService

Is there a reason why MacBook 9,2 was chosen for the UX31A? The MacBook Air 5,2 seems a lot closer in spec?

I put together a zip package for UX21A people -- through technically it should work for UX31A people as the kexts, DDST, and SSDTs were taken from this thread. :wink2:

I put together a table of my notes as well:

https://docs.google....RXRhLUpXcTFZRHc

People can feel free to edit it.

Attached Files



#106
Thomas2111

Thomas2111

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts

Okay, so I followed the instructions and re-did my system. Amazingly, I didn't have to reinstall ML. I just used Kext Wizard to (re)install nhart's kexts, subbed in the DSDT/SSDTs from you guys, and voila, everything worked.


I did it too, that worked for me :), i have to test the hdmi (maybe i'ts plugged on the nvidia card, and will not work).


I tryed Clover, but did'nt understood anything aha :) i'll keep my old Chameleon.

#107
cyf

cyf

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts
CLOVER LIVES!!! Or should I say lived, because right after I had it working (video was not working right as I think I need to manually insert the EDID), I decided to change my Data partition from NTFS to ExFat, and then mount a Truecrypt volume on it for security and both Mac and Windows could use it.

Basically, when I first installed OS X, I noticed it had screwed up said same Data partition, and I didn't really pay attention because I was more worried about the Windows EFI boot partition. Turns out the OS X installer had probably corrupted the GPT table--or maybe it was all the reboots I had to do to finally get things working. Either way, the deletion of the Data partition took the OS X partition with it.

Yes, back to reformatting the hard drive and reinstalling OS X--this time, though, I think I'm going to leave off Windows for now...

#108
nhart12

nhart12

    InsanelyMac Protégé

  • Members
  • PipPip
  • 87 posts
Just out of curiosity, what is the benefit of using clover?

Also, those of you with the i7 processors, are you able to generate all the speedstep and turbo states for your processor? It seems that every laptop with the i5 3317u model processor cannot get more than 2 cpu states, has anyone else noticed this issue?

I also found this thread for fn keys, it gets some of them working for me so I would like some feedback for others so try it out and let me know.

I am also researching a more permanent solution for wifi since I am having a hard time finding a card that fits the micro UFL connectors that come with this laptop. I had to tape on the connectors on but the signal strength seems to suffer. The app store didnt work with the asix adapter so I am hoping to find a card that works a little better.

Edited by Lejenk, 29 March 2013 - 03:32 PM.
URL Removed

  • cyf likes this

#109
tommyleebass

tommyleebass

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Location:Milano Italy
bluetooth? work on ux31 or ux32?
If yes,which kext are you used?

#110
Thomas2111

Thomas2111

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
ux32vd as you ! (works on UX31a/Ux21a too) here is the kext. place it in SLE with kext wizard
Do you remember that Zenlion deleted this kext and you too after? that work with. Why you deleted that? Idk

note about bluetooth in zenbooks:
there is two bluetooth adapters integrated:

2.1 bluetooth USB that work with the kext
[edit] addded screenshot of 2.1 bluetooth module on usb concentrator
4.0 bluetooth in the intel wireless Wifi / bluetooth Combo 6235 pci card, actually not working.

I bought a 3.0 bluetooth & wifi N combo card for 13$, 10 € in france:
Atheros AR5B195 AR3011 WiFi WLAN Bluetooth Combo Half Mini PCI-E Card
I'll tell soon if it works.

Attached Files



#111
tommyleebass

tommyleebass

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Location:Milano Italy
I have ux32vd with same card,but nothing bt work,no bt usb and no ar3011


#112
cyf

cyf

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts

Just out of curiosity, what is the benefit of using clover?

Clover: http://www.projectos...?showtopic=2304 (It's supposed to offer better UEFI integration--i.e., makes your hardware seem "more compatible" to OS X. At this point, with all the headaches, I'm not sure it's worth it, haha. Then again, I should be more proactive in asking the dev. questions--they seem fairly responsive.

Also, those of you with the i7 processors, are you able to generate all the speedstep and turbo states for your processor? It seems that every laptop with the i5 3317u model processor cannot get more than 2 cpu states, has anyone else noticed this issue?

Speedstep: I see the same issues (HW Monitor tells me it's running at 1.7 GHz or thereabouts, and sometimes goes down to 7xx MHz--however, with Clover (for that brief boot when I was able to get it to work--before i tried changing my data partition) I think it was running properly.

I also found this thread for fn keys, it gets some of them working for me so I would like some feedback for others so try it out and let me know.

Fn Key: Investigating other solutions as well because my keyboard is the Japanese keyboard, and it has a lot of other "spare" keys I'm not using to input Japanese (the layout is different when it comes to anything other than the QWERTY and numbers. Thank goodness for touch-typing) and I'd like to see if I can get those to do something else. Right now it's just in ANSI/US mode. Have you seen this:

http://emptysodacan....brightness.html

I think it may be better/more time efficient to just do it programmatically. I note that even ASUS has us installing software for many of these keys to "work" under Windows.

Thomas2111--what are you using that keymapper to do?

I am also researching a more permanent solution for wifi since I am having a hard time finding a card that fits the micro UFL connectors that come with this laptop. ... The app store didnt work with the asix adapter ... .

WiFi: Goodness yes. Please let me know if anything else works. Do you have any close-up pictures of your configuration? I do note that other laptops with WiFi have had issues too. As for the app store, I will (continue to) work on this later. See this thread though:
http://www.insanelym...s/#entry1865580

bluetooth? work on ux31 or ux32?
If yes,which kext are you used?


I didn't know we had two BT modules, but looking at the System Information report, I see it (this is with the ASIX adapter attached to the left port and an external Seagate 3.0 USB drive attached to the right, next to the power input--the USB portion of System Information report is also attached):

Screen Shot 2012-11-07 at 5.41.13 AM.png
Attached File  UX21A USB with network adapter and USB 3.0 external HD attached.txt   3.78KB   25 downloads

Ironically, I note that even though I have the Super-Speed kext, the drive still comes up as a 2.0 drive. Maybe it's because we removed

IOUSBAttachSCSI.kext?



ux32vd as you ! (works on UX31a/Ux21a too) here is the kext. place it in SLE with kext wizard
Do you remember that Zenlion deleted this kext and you too after? that work with. Why you deleted that? Idk

note about bluetooth in zenbooks:
there is two bluetooth adapters integrated:

2.1 bluetooth USB that work with the kext
[edit] addded screenshot of 2.1 bluetooth module on usb concentrator
4.0 bluetooth in the intel wireless Wifi / bluetooth Combo 6235 pci card, actually not working.

I bought a 3.0 bluetooth & wifi N combo card for 13$, 10 € in france:
Atheros AR5B195 AR3011 WiFi WLAN Bluetooth Combo Half Mini PCI-E Card
I'll tell soon if it works.


I'm betting you'll make it work. :moil: With the kext in, it should work.
I note people may have taken it out because I have been stuck at boot-up where the sysetm displays an error message waiting for some BT module to respond. However, I believe that the being stuck is due to something else, although I could be wrong because it seems like the OS would want the BT to come up before login for purposes of using keyboards and such. THEN AGAIN, you would think those programmers at Apple would not have boot-up stop just because some "insignificant" wireless module is not responding -- maybe the user's BT keyboard/mouse is out of batteries.

I did it too, that worked for me :), i have to test the hdmi (maybe i'ts plugged on the nvidia card, and will not work).


FYI: HDMI works AWESOME, so hopefully it will work on yours.

Attached Files


Edited by Lejenk, 29 March 2013 - 03:32 PM.
URL Removed


#113
Thomas2111

Thomas2111

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
My HDMI and my mini display port actually works AWESOME, i got tree Extended screens, : Internal display 1080p, VGA 1280*1204 and HDMI 1080p with sound on hdmi or internal speakers
I have done this Airplay demo with Air Server ( :ahem: ) on the PC by mirroring screen on tv.

just one bug, the mini display port adapter must be connected at the boot of the computer

Thomas2111--what are you using that keymapper to do?


I'm using Keyremaps4macbooks, i tryed that (URL Removed)but that did'nt changed anything on my fn keys or keyboard
maybe i done somethig wrong, i'll retry
i'm still waiting for my bluetooth combo card coming, hope i'll works, it's tagged compatible with Mountain lion on this page http://www.osx86.net...do=file&id=2628

Attached Files


Edited by Lejenk, 29 March 2013 - 07:37 PM.
URL Removed


#114
cyf

cyf

    InsanelyMac Protégé

  • Members
  • PipPip
  • 93 posts

My HDMI and my mini display port actually works AWESOME, i got tree Extended screens, : Internal display 1080p, VGA 1280*1204 and HDMI 1080p with sound on hdmi or internal speakers
I have done this Airplay demo with Air Server ( :ahem: ) on the PC by mirroring screen on tv.

just one bug, the mini display port adapter must be connected at the boot of the computer


Nice. Thanks for the mini display port tip. Does it crash the system if it is not connected at boot? Or does it just not work?

#115
Thomas2111

Thomas2111

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts

Nice. Thanks for the mini display port tip. Does it crash the system if it is not connected at boot? Or does it just not work?

Just not work :) that's not very bad

#116
tommyleebass

tommyleebass

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Location:Milano Italy
try this for bluetooth ...my bluetooth don't work with this key:

goto /System/Library/Extensions/IOBluetoothFamily.kext/Contents/Plusgins/

edit AppleUSBBluetoothHCIController.kext/Contents/Info.plist
duplicate the EricssonROK101 key section to add your device info or insert this block of text ;

<key>Generic BTD</key>
<dict>
<key>CFBundleIdentifier</key>
<string>com.apple.driver.AppleUSBBluetoothHCIController</string>
<key>IOClass</key>
<string>AppleUSBBluetoothHCIController</string>
<key>IOProviderClass</key>
<string>IOUSBDevice</string>
<key>bcdDevice</key>
<integer>Your ID</integer>
<key>idProduct</key>
<integer>Your ID</integer>
<key>idVendor</key>
<integer>Your ID</integer>
</dict>

#117
Thomas2111

Thomas2111

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
tommy, we have the same ux32vd, and the same bluetooth module than cyf
all should work for you like us.


the only kext needed to delete post install on ux32vd is geforce.kext, bluetooth works out of the box

#118
tommyleebass

tommyleebass

    InsanelyMac Protégé

  • Members
  • Pip
  • 26 posts
  • Gender:Male
  • Location:Milano Italy

tommy, we have the same ux32vd, and the same bluetooth module than cyf
all should work for you like us.


the only kext needed to delete post install on ux32vd is geforce.kext, bluetooth works out of the box


i tried but don't work

#119
Thomas2111

Thomas2111

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
thats very strange! i'm sorry but you should reinstall and use this archive i just made
(uploading)
I hope that the info.txt i wrote will be helpfull for other people

ps: tommy, thank you for the chameleon.pkg
have you found anything for the nvidia 620 gtm?

Attached Files



#120
Thomas2111

Thomas2111

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
part 1 (obsolete)

Attached Files







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy