Jump to content

ASUS Zenbook Prime UX31A-DB51 Ultrabook - fixes, mods, tweaks, etc


  • Please log in to reply
1037 replies to this topic

#1021
pavn

pavn

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts

I am trying to get to work iMessage on El Capitan.

 

iCloud seems to work.

 

What kind of Clover SMBIOS setting should I use for my ASUS ZENBOOK UX32VD-R4010P, Intel i7-3517U, 10GB RAM, 2x256SSD, NV 620m?

I tried to use various SMBIOS settings, but when booted it displayed only 8GB of my 10GB RAM in About this Mac Overview.

 

And still iMessage displays:

"You cannot sign in to FaceTime on this Mac at this time."

"To use FaceTime with this Mac, contact Apple Support and provide the code below."

And then displays code and my apple id.

iMessage works for me iPad though for this apple id.

 

If Clover SMBIOS setting configuration is empty (is not used at all), then correctly 10GB RAM is displayed, but iMessage still does not work and displays the same message though.



#1022
Banduri1984

Banduri1984

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Hi Guys 

 

I found a solution for the Wifi Pin Connector issue. 

It cost you pennys. It is from China.

I ordered it today. I cant tell about any experience.

 

http://www.aliexpres...ff-1c81f1816325

 

Regards

 


 



#1023
gsly

gsly

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
  • Gender:Male
  • Location:The Great White North

Hi Guys 

 

I found a solution for the Wifi Pin Connector issue. 

It cost you pennys. It is from China.

I ordered it today. I cant tell about any experience.

 

http://www.aliexpres...ff-1c81f1816325

 

Regards

 

I bought the same item but I haven't yet installed it in my UX32VD.  I had hacked an antenna from an old Dell that worked until the incredibly small wire broken where I connected it to the lid and then my wi-fi signal went to {censored}. This should provide a better solution. 



#1024
SeppDepp

SeppDepp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 86 posts

I found a solution for the Wifi Pin Connector issue.


Great!

So maybe we can upgrade our wifi to 802.11ac with an AzureWave AW-CE123H!?

http://www.aliexpres...f3-a7e75a94c3f0

#1025
Banduri1984

Banduri1984

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Hi Guys

I installed today successfully El Capitan on my UX31A. The only thing is, that there is no Clover

boot option in my bios. Max OS. What do I have My Bios Rom is 219.  

Can anyone help me?


I have done that twice. Still the same. Only Mac Os in the Boot options.



#1026
SeppDepp

SeppDepp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 86 posts

I found a solution for the Wifi Pin Connector issue. 

It cost you pennys. It is from China.

I ordered it today. I cant tell about any experience.
 
http://www.aliexpres...ff-1c81f1816325


@Banduri1984: Any news? Did it work?

#1027
Banduri1984

Banduri1984

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Yes it works great. The AW CE 123H give me now 30Mbits more speed.

I took the shrink tubing once to fix the connector and once to insulate from 

the electrical system.

 

After 4 weeks of installing everything is still fine.  

 

Here is a picture: 

 

https://www.dropbox....G_5457.JPG?dl=0

 

Regards

 


 



#1028
Banduri1984

Banduri1984

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Every sixt boot my Display is craching with psychedelic piciture. 

Is there anybody who has a similarly problem?

 

https://www.dropbox....G_5451.JPG?dl=0

 

https://www.dropbox....G_5454.JPG?dl=0

 

 

I have one of the latest DSDT from this forum.

It is called UX31A fully working.

I can not remember the Member. 

 

I have done till now: 

 

- Changed several plattform igs in the dsdt 

- Installed a new brightness fix kext

- Fix Display in Clover

- Incect Intel in Clover

- Clover Framebuffer Patch for HDMI Fix.

Nothing really resolved my problem  



#1029
SeppDepp

SeppDepp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 86 posts

Every sixt boot my Display is craching with psychedelic piciture. 

Is there anybody who has a similarly problem?


Same problem on UX32VD. The problem introduced with an update of HD4000 drivers/kext a few OS X version releases ago (maybe 2 years ago!?). Maybe there is a new fix... ?

Workarround: Standby. After standby the problem does not show up.

#1030
SeppDepp

SeppDepp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 86 posts
Great!

I ordered the antenna cable adapters from your link and a BCM94352HMB based wifi-card today. :)
http://www.aliexpres...ff-1c81f1816325

(I ordered the wifi adapter here: http://www.ebay.co.uk/itm/222055448833 Hope it will work:)
 

Yes it works great. The AW CE 123H give me now 30Mbits more speed.
I took the shrink tubing once to fix the connector and once to insulate from 
the electrical system.
 
After 4 weeks of installing everything is still fine.  
 
Here is a picture:  
https://www.dropbox....G_5457.JPG?dl=0



#1031
SeppDepp

SeppDepp

    InsanelyMac Protégé

  • Members
  • PipPip
  • 86 posts

I ordered the antenna cable adapters from your link and a BCM94352HMB based wifi-card today.
(I ordered the wifi adapter here: http://www.ebay.co.uk/itm/222055448833 Hope it will work:)


So the wifi BCM94352HMB adapter and the wifi cable adapter really works in UX32VD! 2.4G and 5G :)

I'm just having some problems to force the country code to s.th. that allows channel 12 and channel 13.
I tried these binary patches (http://www.insanelym...pcie-half-mini/) on AirPortBrcm4360 with US, DE and XX. No luck :(

#1032
Banduri1984

Banduri1984

    InsanelyMac Protégé

  • Members
  • Pip
  • 7 posts

Hey SeppDepp 

 

I have tried to patch another Method in the DSDT for our HD4000.
From the rampagedev homepage you can find 3 Methods. 

Perhaps thats a way to resolve the problem?  

But everytime if I want to compile the new DSDT this error massege come 3000 lines further out.

Code 6126 syntax error, unexpected`}`,expecting $end and premature End-Of-File

 

Any Idea? 

 

 

  



#1033
mssmison

mssmison

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts

Hey SeppDepp 

 

I have tried to patch another Method in the DSDT for our HD4000.
From the rampagedev homepage you can find 3 Methods. 

Perhaps thats a way to resolve the problem?  

But everytime if I want to compile the new DSDT this error massege come 3000 lines further out.

Code 6126 syntax error, unexpected`}`,expecting $end and premature End-Of-File

 

Any Idea? 

Did you ever get this figured?

 Sounds like you were just missing the } where you added the patch.



#1034
mssmison

mssmison

    InsanelyMac Protégé

  • Members
  • Pip
  • 37 posts

Anyone tried Sierra yet? I think I'm going to give it a go this weekend..



#1035
jsl

jsl

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 630 posts
  • Gender:Male

Anyone tried Sierra yet? I think I'm going to give it a go this weekend..

With proper DSDT.aml and Chameleon Enoch 2839, macos Sierra 10.12. beta 4 worked in my Asus ZenBook UX31A.

The only unsolved problem is HDMI audio.

Anyone got its HDMI audio working in 10.9.x~10.11.x ?

Please share working DSDT.aml and related Kexts to us.



#1036
oliwek2

oliwek2

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hi everyone.

 

For those of you looking for the wifi cable adapter for the BCM94352HMB Broadcom wifi card, and as the previous link is not a purchasable item anymore, this is a new valid link : http://www.ebay.com/...=item2a54c2e8ff



#1037
pavn

pavn

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts

Did you try upgrade El Capitan to Sierra?

 

Or is it fresh install?

 

With proper DSDT.aml and Chameleon Enoch 2839, macos Sierra 10.12. beta 4 worked in my Asus ZenBook UX31A.

The only unsolved problem is HDMI audio.

Anyone got its HDMI audio working in 10.9.x~10.11.x ?

Please share working DSDT.aml and related Kexts to us.



#1038
pavn

pavn

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 115 posts

Ok. I successfully seamlessly updated from El Capitan to macOS Sierra without any issue during the installation process! :)

 

Siri works! In place video works!

 

What does not work for me is: FaceTime, iMessage, Universal Clipboard - Copy/Paste.

 

(FaceTime and iMessage did not work for me in El Capitan also. Do you know how to get it work?) 







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2016 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy