Jump to content

ASUS Zenbook Prime UX31A-DB51 Ultrabook - fixes, mods, tweaks, etc


  • Please log in to reply
967 replies to this topic

#841
68x

68x

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 162 posts

@68x

 

I wrote:

I've Uploaded UX32A Dsdt, to my github...
 
I need anyone with a UX31A, im going to support this model too :-)
And who know already the base things, and have osx already running :-)
 
Cheers :-) 

He Answered:

I Answered what i need:

 

----------------------

How you easily can see here, is, that I HAVE REQUESTED files from UX31A! To Support this model in my Github!

And he have osx already running and asked me what i need!

 

So your Post here makes no sense:

 

 

 

Cheers :-)


Im Going to debug this next week with 2 osx machines :-)

 

I will post, what i found out :-)

 

Cheers :-)

 

 

Indeed you are correct. I mistook him for asking for help; I dislike people asking the same thing over and over again.

 

An update on the USB 3.0 ...  It doesn't look too good .. I am having troubles mapping the correct USB 3.0 port to the USB 2.0 port in the DSDT. I cna patch my DSDT, but the issue is the actual "multiplex".

 

 

 

Hello everyone, 
I have a problem with audio after updating to 10.9.2: no audio output from headphones.
The speaker works fine but when I connect the headphones the system recognizes them but there's no audio coming out.
 
I'm using AppleHDA.kext v2.6.0 vanilla, but patched with clover with these for ALC269 (without the other kext AppleHDA269.kext). FixHDA_8000 is set to true in clover. I tried with the DSDT I was already using and with the one found on GitHub here.
Everything else on my hackintosh works fine included sleep, even with 10.9.2.
 
My Laptop:
ASUS UX32A, BIOS 215
Intel i3-3217U
ALC269VB
 
Attached: both DSDT, CodecCommander kext, audio codec dump, AppleHDA right after 10.9.2 update and ioreg (done with the dsdt from github, I don't know if matters). I don't know if there's something else I should have attached.
 
 
Thank you everyone for your help and for everything you've done and shared on this forum and in other places! 

 

 

Try my patched AppleHDA from 10.9.1, I posted it a couple pages ago, The UX32A and UX32VD should have the same pin configuration. Make sure to disable the FIX_HDA in Clover, and ensure that you are injecting layout id 28 in your DSDT, like so http://forum.osxlati...inary-patching/

 

On a side note, I do believe that I have sleep working perfectly now (using Clover). I will my config.plist whenever I get the chance.

 

What did I was:

- Disabled USB injection (AddClockID,FixOwnership,Inject are false under Devices -> USB in the plist)

- Disabled SLP SMI option(SlpSmiAtWake = false)

- Disabled Suspend Override (SuspendOverride = false)

- Enabled Fix Regions in the DSDT section



#842
ammor

ammor

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:China

---> All your Tables exported from Clover (Hit in Clover "F4" Key / "Efi/Clover/ACPI/origin" Folder)

---> Aida64 Report.html (Windows)

---> And maybe a codec_dump from linux (but this we going to see later, maybe there exists some with 164bit Patched Verbs)

---> And a list of the UX31A Versions, (Only the differences related to GPU and CPU)

 

Thats all :-)

--->Is there another way to export all tables? Cuz  I am using Chameleon instead of Clover, which does not work on my laptop.

--->I will attach it later.

--->codec_dump? do you mean the codec of sound card?

--->I only know three versions of UX31A series, which are DH51(I5-3317U, HD4000) , XB52(I5-3317U, HD4000)and DH71(i7-3517U, HD4000)



#843
Voskot

Voskot

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Italy

...

Try my patched AppleHDA from 10.9.1, I posted it a couple pages ago, The UX32A and UX32VD should have the same pin configuration. Make sure to disable the FIX_HDA in Clover, and ensure that you are injecting layout id 28 in your DSDT, like so http://forum.osxlati...inary-patching/

 

On a side note, I do believe that I have sleep working perfectly now (using Clover). I will my config.plist whenever I get the chance.

 

What did I was:

- Disabled USB injection (AddClockID,FixOwnership,Inject are false under Devices -> USB in the plist)

- Disabled SLP SMI option(SlpSmiAtWake = false)

- Disabled Suspend Override (SuspendOverride = false)

- Enabled Fix Regions in the DSDT section

 

First of all, thank you for helping me!
 
I tried this applehda, I disabled fix_hda and I think layouts id 28 is injected, I just need method _dsm inside hdef with 0x1C? in clover, audio > inject id is 28. In system information > sound > id audio is 28. 
Even with these configuration speaker and mic work, it recognizes the headphones but no sound comes out. For a moment I thought the headphones jack was broken but works fine on linux.


#844
ammor

ammor

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:China

My patched Applehda.kext (V2.6.0) from OSX 10.9.2, ENJOY! My laptop is UX31A-DH51. :D  

Attached Files



#845
Voskot

Voskot

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Italy

My patched Applehda.kext (V2.6.0) from OSX 10.9.2, ENJOY! My laptop is UX31A-DH51. :D  

 

Thank you!

I tried it but there's no audio output from headphones as before, maybe applehda is not the problem... :(



#846
ammor

ammor

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:China

Thank you!
I tried it but there's no audio output from headphones as before, maybe applehda is not the problem... :(

Maybe the version of alc269 on your laptop is different from mine, as far as I know, there are at least 3 versions. I fully test the driver before releasing, both speaker and headphone work properly.

#847
Voskot

Voskot

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Italy

Maybe the version of alc269 on your laptop is different from mine, as far as I know, there are at least 3 versions. I fully test the driver before releasing, both speaker and headphone work properly.

 

My laptop has an alc269vb, what's yours?

 

Anyway, I believe you when you say it's working for you, maybe that's something else in my system to fix...



#848
68x

68x

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 162 posts

My laptop has an alc269vb, what's yours?

 

Anyway, I believe you when you say it's working for you, maybe that's something else in my system to fix...

 

I recommend you contact EmlyDinesh on OSXLaitude. Post here, http://forum.osxlati...inary-patching/, with a dump of your pin configuration. I am 99% sure it's a wrong codec verb.



#849
Voskot

Voskot

    InsanelyMac Protégé

  • Members
  • Pip
  • 13 posts
  • Gender:Male
  • Location:Italy

I recommend you contact EmlyDinesh on OSXLaitude. Post here, http://forum.osxlati...inary-patching/, with a dump of your pin configuration. I am 99% sure it's a wrong codec verb.

 

Good news! :thumbsup_anim:

I followed that guide to calculate the codec verbs commands relative to the headphones, I replaced those from ammor's AppleHDA with the new ones and now everything works perfectly! Thank you 68x and ammor for your help  :)

 

In case someone needs it, here's my AppleHDA (v2.6, 10.9.2) for ASUS UX32A (ALC269VB).

Attached Files



#850
cowjam

cowjam

    InsanelyMac Protégé

  • Members
  • Pip
  • 14 posts

Sleep not working anymore after 10.9.2 update - UX31A

 

Anyone else experience this?  Everything else is working fine.

 

:(

 

 



#851
Ramalama

Ramalama

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Not Telling
  • Location:Germany

Sleep not working anymore after 10.9.2 update - UX31A

 

Anyone else experience this?  Everything else is working fine.

 

:(

 

Haha xD

 

I have the same on UX301LA :-)

 

Just relax, and wait till we find out why :-)



#852
68x

68x

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 162 posts

If you have sleep issues, can you please try Clover rev. 2620 or greater? OsxAptioFix has some changes which may positively effect sleep.



#853
Ramalama

Ramalama

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Not Telling
  • Location:Germany

If you have sleep issues, can you please try Clover rev. 2620 or greater? OsxAptioFix has some changes which may positively effect sleep.

 

Nothing changed :-)



#854
68x

68x

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 162 posts

Nothing changed :-)

 

I took a look at your repo, disable 

AddClockID

and let me kno if you have any results.



#855
Ramalama

Ramalama

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Not Telling
  • Location:Germany

I took a look at your repo, disable 

AddClockID

and let me kno if you have any results.

 

<im not using any injectings from clover:-)

 

Cheers :-)



#856
68x

68x

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 162 posts

<im not using any injectings from clover:-)

 

Cheers :-)

 

Mind posting your config.plist then?



#857
Ramalama

Ramalama

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Not Telling
  • Location:Germany

Np, here you have it :-)

Attached Files



#858
68x

68x

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 162 posts

Np, here you have it :-)

What are your current BIOS settings, do you have LaunchCSM disabled and UEFI enabled?

These options only appear if you have a modded BIOS ...



#859
Ramalama

Ramalama

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 232 posts
  • Gender:Not Telling
  • Location:Germany

What are your current BIOS settings, do you have LaunchCSM disabled and UEFI enabled?

These options only appear if you have a modded BIOS ...

 

CSM is disabled, and UEFI is enabled :-) + Secure boot is enabled "without keys" and VT-d is disabled :-)



#860
68x

68x

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 162 posts

CSM is disabled, and UEFI is enabled :-) + Secure boot is enabled "without keys" and VT-d is disabled :-)

 

Mind giving these keys a try?

			<key>Fixes</key>
			<dict>
				<key>FIX_ACST_4000000</key>
				<true/>
				<key>FixRegions_10000000</key>
				<true/>
				<key>NewWay_80000000</key>
				<true/>
			</dict>

DSDT -> Fixes







1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy