Jump to content

Intel HD 4000 + NVS 5200M


  • Please log in to reply
3 replies to this topic

#1
Monkey D. Luffy

Monkey D. Luffy

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 175 posts
  • Gender:Male
  • Location:US
  • Interests:I will become the Pirate King!
Hey Guys,

I got a Lenovo T430S which has Intel HD 4000 + Nvidia NVS 5200M in it.

So far, I've searched the interwebz and found nothing useful for the HD 4000 FOR LAPTOPS (desktops seems easy).

I'm really used to desktops and the last time I installed a hackintosh in a laptop was like 3-4 years ago.

Could someone please point me to the right direction on making Intel HD 4000 work on a laptop?

Is the Nvidia NVS 5200M working in OSX as well?

I really am hoping I could get QE/CI on either those videocards.

I would make a guide as soon as I make it work! Thanks

#2
TheRacerMaster

TheRacerMaster

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
The Intel HD 4000 guide for desktops should work exactly the same on laptops. I don't see why it would be different; in fact, the MacBooks are the only laptops with the HD 4000, no Apple desktop (iMac or Mac Pro) has them. Try this for getting the Intel HD 4000 working. Getting the nVidia card working would take some extra hacking. In a nutshell: If you have Optimus, you're gonna have a bad time.

You could also try this EFI string:
8800000001000000010000007c0000000200000002010c00d041030a000000000101060000027fff0400100000006d006f00640065006c0000001a000000496e74656c20484420477261706869637320343030302c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000005006201

#3
Monkey D. Luffy

Monkey D. Luffy

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 175 posts
  • Gender:Male
  • Location:US
  • Interests:I will become the Pirate King!

The Intel HD 4000 guide for desktops should work exactly the same on laptops. I don't see why it would be different; in fact, the MacBooks are the only laptops with the HD 4000, no Apple desktop (iMac or Mac Pro) has them. Try this for getting the Intel HD 4000 working. Getting the nVidia card working would take some extra hacking. In a nutshell: If you have Optimus, you're gonna have a bad time.

You could also try this EFI string:
8800000001000000010000007c0000000200000002010c00d041030a000000000101060000027fff0400100000006d006f00640065006c0000001a000000496e74656c20484420477261706869637320343030302c0000004100410050004c002c00690067002d0070006c006100740066006f0072006d002d006900640000000800000005006201


Thanks for the reply. I actually don't mind using the nvidia card ever. I'm fine with HD 4000. I'll give it a try. thanks!

EDIT: That EFI string is for the nvidia card or the intel hd?

#4
TheRacerMaster

TheRacerMaster

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 189 posts
  • Gender:Male
That EFI string is for the HD 4000.

EDIT: And this will only work on OS X 10.7.5 or higher. You should also make sure you are using a MacBookPro9,1 SMBios.plist, which you can get here.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy