Jump to content

CPUS=1 Intel i3 2310m

cpus=1 intel i3 2310 kernel flags uncommon behavior

  • Please log in to reply
3 replies to this topic



    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Hi everyone,

I have this laptop:
Toshiba Satellite C660-1MG
  • Intel core i3 2310m Works using 1 core
  • 4GB 1333MHZ DDR3 Ram Works!
  • NVidia GeForce 315m Works! I guess because of Graphics Enabler = Yes. It isn't detected (Graphics Unknown nVidia card 1024 MB) but that's not important as long as it works.
  • Atheros AR9007 (Not Sure) Works! With kexts found on kexts.com
  • Realtek RTL8136 (Not sure if 8136 or 8196) Does not work! But I got Wi-Fi so this is not important for me.
  • Not sure about my Audio Card Works! Using VoodooHDA I think it's version 2.7
  • Card Reader Works!
  • USBs Work!
  • Lion 10.7.4 (updating to 10.7.5)
  • (Tried Mountain Lion but the kexts that work on Lion didn't work there so I'm sticking with Lion for a little bit)
My Problem:
My cpu has 2 cores and 4 logic cores.
When I boot without the "cpus=1" flag, OSX starts and loads, everything works. The only problem is that is stops every second. It doesn't restart. Just stops for like 200ms or so and starts again. I don't know how to explain this another way. It becomes extremely slow.
When I add the "cpus=1" flag, it works and it doesn't have this continuous stopping.

I don't use a DSDT file, but when I installed ML I tried a modified DSDT that I found in the Internet and then it started working normally with all four cores.
You would think that I solved the problem but that's not true because that DSDT didn't work on Lion.

I checked the original DSDT (the one that is loaded by the system when no custom DSDT is provided) and it doesn't have Alias entries under _PR (cpu). And that is the oddest part.
The system never panics, neither with the "cpus=1" flag nor without it.

Does anyone have any idea why this happens?
If I wasn't clear enough just ask. :)


Maybe it's more than 200ms now that I'm thinking about it because 200ms wouldn't be noticeable.




  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
try the kext VodooTSYnc.kext and edit it for you CPU



    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 850 posts
  • Gender:Male



    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
Thank's! I'll check it out as soon as possible and then I will comment my results.


Your solution(s) worked. Thanks, I don't know why I didn't ask earlier. I've used Lion for a year with only one core.

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy