Jump to content

10.6.8 on ASUS M2N68CM (MCP68) SUCCESS!

success snow leopard

  • Please log in to reply
2 replies to this topic



    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 448 posts
  • Gender:Male
  • Location:Oz
My iMac is in for repairs, so I whipped up an AMD Athlon64 X2 6000+ hackintosh with a machine I had lying around. Specs as follows:

Mobo: ASUS M2N68-CM (super cheap with integrated NVIDIA 7050pv graphics)
GRAPHICS: NVIDIA GeForce 6600 (since replaced with better/faster GeForce 8400 GS)
RAM: 3GB (2x1GB, 2x500MB)
NET: PCI 8169 Gigabit card.
HDD: 200GB SATA, taken from an old G5.
Generic card reader installed
MONITOR: ViewSonic 19" VGA-only (1440x900)
2TB External Time Machine USB HDD

A very short and inaccurate guide

Retail 10.6.3
Nawcom boot CD
Marvin's AMD Utility
MacOS 10.6.7 Combo Update
MacOS 10.6.8 Combo Update
###### for Snow.
Pacifist (to install 10.6.8 Combo Update if needed)
10.6.3 Legacy Kernel
10.6.8 Legacy Kernel + Sleep Enabler

You should be able to boot from Nawcom CD and install Mac OS X 10.6.3 retail.
You should then be able to boot from the Nawcom CD, using the kernel on CD to patch everything with Marvin's AMD Utility (you cannot use this above 10.6.5, so patch everything you need NOW).
Use the same CD kernel to boot OS and update to 10.6.7 & 10.6.8 (You could try going directly to 10.6.8, I just do it this way out of habit, having another intel Sandy Bridge PC, which cannot update from 10.6.3 to 10.6.8 directly.

I am currently using this on a daily basis with Adobe CS5.5 and MS Office 2011, with no problems whatsoever. The integrated NIC might well have worked perfectly, but I do not trust NVENET kext, so went with 8169, worked great OOTB.

PS. If you do not have a PS/2 mouse & keyboard handy, you will have to enable Legacy USB in the BIOS, which makes USB very flakey indeed. I could only ever get ports 1 & 2 working, and even then, not all the time. Just use this to get everything set up, then use ###### to install bootloader, required kexts, and VoodooHDA (audio working great!), as well as rolling back the USB drivers. Now break into the BIOS and disable Legacy USB Support. This should get all USB working fine, and full speed.

Change /Extra/org.chameleon.boot.plist to the following:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<key>Kernel Flags</key>
<string>npci=0x2000 arch=i386 -force64 std_dyld=yes</string>
<key>Legacy Logo</key>

Posted Image

To be honest, I didn't really pay too much attention while installing, thinking it would be a massive failure, but it isn't, and I'm sorry I didn't take notes. There are kexts available to get ATA/IDE drives working, and also a patch to install onto MBR, but mine works fine with AHCI and SATA only, so I will leave it at that. Also, I am not dual-booting, so everything will remain working fine I hope, and the clock won't get out of sync.

A quick list of what is working:

Mac OS X 10.6.8 (DUH!)
Firefox, Chrome, Apple Store, Steam, HP, Fuji-Xerox and Brother printers/scanners, Wireless N adaptor (Asus USB-N10), Networking, Stereo audio out (volume saved), DVD burning, Time Machine backups.

64-bit apps all working, no serious crashes as of last week. Afraid to restart computer in case something goes wrong. Just putting it to sleep overnight.



    InsanelyMac Sage

  • Members
  • PipPipPipPipPipPip
  • 448 posts
  • Gender:Male
  • Location:Oz
Now have sensors working (HDD, CPU, GPU and FAN & VOLTAGE) thanks to FakeSMC plugins (rev609 on Google Code) and HWMonitor.app/iStat Menus.

Also, was not succinct before, but have full QE/CI support, with full OpenGL as well, and always have.

Looking to get a replacement Radeon HD 5770 or similar.



    InsanelyMac Protégé

  • Members
  • Pip
  • 2 posts


How can I get to knoiw what is "###### for Snow", and "###### to install bootloader"?. I'm an absolute newby. And I've -exactly-  an m2n68-com, 4 GB RAM DDR 2,  Athlon64 x2  2200 GHz Seagate 500 gb sata.


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2017 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy