Jump to content

10.8.2 Final! (C54)


  • Please log in to reply
127 replies to this topic

#101
xela

xela

    InsanelyMac Protégé

  • Donators
  • 26 posts
  • Gender:Male

Hi,


Maybe this will help someone: I updated to 10.8.2 via combo updater, but couldn't boot past the gray startup screen, because of OemSMBIOS.kext. After replacing AppleACPIPlatform.kext with the old one from a previous post in this (or an other) thread, my system booted without any problems.


Now, as I really don't like having legacy kexts on my system, I tried out various methods to allow me to keep the vanilla 10.8.2 AppleACPIPlatform.kext. The solution was quite easy and had a nice benefit to it. I installed Kozleks branch of FakeSMC + optional Kexts for sensors:

https://github.com/kozlek/HWSensors


Not only can I now boot with the original 10.8.2 AppleACPIPlatform.kext, without having OemSMBIOS.kext throwing an error, but I also get much more information from my hardware sensors opposed to the original FlakeSMC-Plugins I had been using. Furthermore a serial number is generated for my machine (so no problems with iCloud and Appstore) and VT-d can stay enabled in BIOS!



Using the kexts from Kozlek was a win-win for me - thanks Kozlek!!!

Posted Image



This is great but sadly it did not work out for me :(

#102
lulighttec

lulighttec

    InsanelyMac Protégé

  • Donators
  • 91 posts
  • Gender:Male
  • Interests:Lasers, Hackintoshes, Macs, Windows

Ok, so, I tried running the update package, then installing the rollback ACPI kext *before* rebooting. That did make a difference, in that now, instead of a kernel panic, it just hangs on the PCI Configuration thing, regardless of safe boot, normal boot, npci=[insert value here], doesn't matter... just hangs at that point. The only thing I didn't add was NullCPUPowerManagement, because I didn't get an answer to my last inquiry about it. Since I have written my DSDT and configured my boot plist to use P-states and C-states, and since the DSDT tutorial advised me not to use it, I didn't want to put it in. Let me know if you want new screen shots.

Thanks,

LULightTec


Shameless bump. Anyone got any ideas?

#103
theconnactic

theconnactic

    Stubborn AMD user

  • Local Moderators
  • 2,988 posts
  • Gender:Male
Hey, Lulight!

Sorry not to answer before. In fact, i pointed to the solutions i know. I'm really amazed it didn't work.

#104
lulighttec

lulighttec

    InsanelyMac Protégé

  • Donators
  • 91 posts
  • Gender:Male
  • Interests:Lasers, Hackintoshes, Macs, Windows

Hey, Lulight!

Sorry not to answer before. In fact, i pointed to the solutions i know. I'm really amazed it didn't work.


I'll keep watching and waiting.... I don't need the update *right* now, and I'm sure someone will figure it out for my laptop pretty soon...

:-)

#105
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 772 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

Hi,

Maybe this will help someone: I updated to 10.8.2 via combo updater, but couldn't boot past the gray startup screen, because of OemSMBIOS.kext. After replacing AppleACPIPlatform.kext with the old one from a previous post in this (or an other) thread, my system booted without any problems.

Now, as I really don't like having legacy kexts on my system, I tried out various methods to allow me to keep the vanilla 10.8.2 AppleACPIPlatform.kext. The solution was quite easy and had a nice benefit to it. I installed Kozleks branch of FakeSMC + optional Kexts for sensors:
https://github.com/kozlek/HWSensors


Not only can I now boot with the original 10.8.2 AppleACPIPlatform.kext, without having OemSMBIOS.kext throwing an error, but I also get much more information from my hardware sensors opposed to the original FlakeSMC-Plugins I had been using. Furthermore a serial number is generated for my machine (so no problems with iCloud and Appstore) and VT-d can stay enabled in BIOS!


Using the kexts from Kozlek was a win-win for me - thanks Kozlek!!!
Posted Image


Yep, I'm using kozlek's version of fakesmc too
And I upgraded successfully without replacing kexts other than some kexts that I always replace after upgrading or installing.

#106
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff

You're running your hack without fakesmc ?

Not anymore, and it wasn't on purpose, but it ran surprisingly well without it, which is why I didn't even realize it for almost a week. Was running 10.8.1 at the time, most likely one of the developer preview but don't remember exactly.

#107
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 772 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod

Not anymore, and it wasn't on purpose, but it ran surprisingly well without it, which is why I didn't even realize it for almost a week. Was running 10.8.1 at the time, most likely one of the developer preview but don't remember exactly.

you're using kernelcache which contains fakesmc ?

#108
eep357

eep357

    Triple Platinum

  • Retired
  • 2,527 posts
  • Gender:Male
  • Location:Dark Side of The Wall
  • Interests:things and stuff
I rebuild it, running RAID-0 so I keep an eye on it and make sure it rebuilds error free or else I can't boot at all. Keep in mind, I'm in no way recommending running without it, or even suggesting it's a slightly good idea and there are zero positive effects to doing so, no hardware monitoring for one and is just a bad idea. Many have booted without it at least once, like on first launch after a new install racing to install b4 a kernel panic. Maybe stars were just aligned properly, since unintentional I can't say much about other details as I wasn't looking and happened to be at a time I was very busy with other projects.

#109
xela

xela

    InsanelyMac Protégé

  • Donators
  • 26 posts
  • Gender:Male

I'll keep watching and waiting.... I don't need the update *right* now, and I'm sure someone will figure it out for my laptop pretty soon...

:-)

What happen if everyone is doing the same thing ...... keep watching and waiting.... :hysterical:
This thread is getting hysterically interesting ...

#110
stellarola

stellarola

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 682 posts
  • Gender:Male
  • Location:Lextown, KY

Confusingly, the version is still 1.6. But the binary inside has changed. I md5-summed the old and new ones to see for myself.

Anyone who needed to rollback ACPIPlatform, are you using the ACPISensors or OemSMBIOS kexts? I'm just wondering what triggers the problem with the updated kext. I use Kozlek's HWSensors branch of FakeSMC but only with the CPU, GPU and MB sensor kexts.

Confusingly, the version is still 1.6. But the binary inside has changed. I md5-summed the old and new ones to see for myself.

Anyone who needed to rollback ACPIPlatform, are you using the ACPISensors or OemSMBIOS kexts? I'm just wondering what triggers the problem with the updated kext. I use Kozlek's HWSensors branch of FakeSMC but only with the CPU, GPU and MB sensor kexts.

Confusingly, the version is still 1.6. But the binary inside has changed. I md5-summed the old and new ones to see for myself.

Anyone who needed to rollback ACPIPlatform, are you using the ACPISensors or OemSMBIOS kexts? I'm just wondering what triggers the problem with the updated kext. I use Kozlek's HWSensors branch of FakeSMC but only with the CPU, GPU and MB sensor kexts.


I had to remove OemSMBIOS kext in order to boot after 10.8.2 update. This kext is usually found in various compilations of HWSensor extensions.

-Stell

#111
macusers

macusers

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 195 posts
  • Gender:Male
  • Location:S.California

Guys, could someone be so kind to upload AppleHDA patched kext for ALC888 working with 10.8.2, please.

TIA :)


You could easily find that kext for your alc888 at osx86dotnet. Hope this help.

#112
CooSee

CooSee

    InsanelyMac Legend

  • Donators
  • 598 posts
  • Gender:Male
used ComboUpdate !

no problems at all :weight_lift:

no kext change needed!

greetings

#113
daxure

daxure

    InsanelyMac Protégé

  • Members
  • PipPip
  • 53 posts
Update from 10.8.1 to 10.8.2 went with problems!

Replaced: AppleACPI.kext given from fellow on 5th page
No Audio AppleHDA.kext must be patched + Audio ALC889A with ##### 5.0.2 but had to use again DSDT.aml 0x0C in HDEF ID instead of 0x75 again credit goes to fellow from 5th page Thanx mitch_de

P.S.USB3.0 can`t transfer data from PC to HDD Seagate 3TB drive even though it`s mounting well on system (maybe it has to do with AVCHD video file transfer incompatibility?) other small size data transfers without problems.

P.P.S. using UPd720200 Nec/Renesas chip No name china $10 PCIe card with PXHCD.kext from kext.com

#114
xopher

xopher

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 178 posts
  • Gender:Male
  • Location:Finland

Hi,

Maybe this will help someone: I updated to 10.8.2 via combo updater, but couldn't boot past the gray startup screen, because of OemSMBIOS.kext. After replacing AppleACPIPlatform.kext with the old one from a previous post in this (or an other) thread, my system booted without any problems.

Now, as I really don't like having legacy kexts on my system, I tried out various methods to allow me to keep the vanilla 10.8.2 AppleACPIPlatform.kext. The solution was quite easy and had a nice benefit to it. I installed Kozleks branch of FakeSMC + optional Kexts for sensors:
https://github.com/kozlek/HWSensors


Not only can I now boot with the original 10.8.2 AppleACPIPlatform.kext, without having OemSMBIOS.kext throwing an error, but I also get much more information from my hardware sensors opposed to the original FlakeSMC-Plugins I had been using. Furthermore a serial number is generated for my machine (so no problems with iCloud and Appstore) and VT-d can stay enabled in BIOS!


Using the kexts from Kozlek was a win-win for me - thanks Kozlek!!!
Posted Image



Switching to this worked for me as well. I only needed to fix audio.

Thanks.

#115
hiphopboy

hiphopboy

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 101 posts
Can't work, alway kernel panic i do any way, tut, replace files, anything but still kernel panic

#116
C.Frio

C.Frio

    InsanelyMac Legend

  • Pandora Team
  • 1,321 posts
  • Gender:Male
  • Location:Cabo frio - Brasil
Hi...

small update some minutes ago.. on 10.8.2....it is now ...."12C60"

c.frio

#117
mitch_de

mitch_de

    InsanelyMacaholic

  • Retired
  • 2,914 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Yep, 30MB .dmg is available.
Should not harm working 10.8.2 on hackintosh (near no system driver changes).

Attached Files



#118
RobertX

RobertX

    Yosemite Sam

  • Members
  • PipPipPipPipPipPipPip
  • 573 posts
  • Gender:Not Telling
all good here... :smoke:
Attached File  build 12C60.png   38.22KB   24 downloads

...27.5 mb dl from appstore

#119
SMF

SMF

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 188 posts
All good for me.

#120
p.H

p.H

    InsanelyMac Legend

  • FAQ Team
  • 772 posts
  • Gender:Male
  • Interests:Hackintosh & NBA & COD4 promod
smooth update~





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy