Jump to content

Radeon HD 6770 FULL QE/CI ML/Mavericks/Yosemite

HD 6770 QE/CI OS X ML Mavericks Yosemite

  • Please log in to reply
72 replies to this topic

#61
AleAutomatic

AleAutomatic

    InsanelyMac Protégé

  • Members
  • PipPip
  • 94 posts
  • Gender:Male
  • Location:Novara

Hi, does it work for Radeon HD6870?



#62
danielito9898

danielito9898

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hi, will it work with this card http://www.amazon.it...rds=radeon 6770 ????

I have an 2011 iMac 21,5" and I'm going to upgrade the GPU.

Thanks.



#63
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 3,232 posts
  • Gender:Male

@danielito9898

 

hi

 

this tutorial is for the desktop version

 

the card that you want to buy is a laptop version, maybe you have to take a look on this thread: http://www.insanelym...qeci-mavericks/

 

good luck  ;)



#64
ZB0X

ZB0X

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Germany, Stuttgart

I updated to 10.10.2 last night, which somehow broke the QE/CI.

My 6770 was working fine with the kexts in the first post. Is anybody on here experiencing the same issues?

"About this Mac" is just showing 5MB Monitor for graphics.

I´m using clover, if thats important for my situation.

 

Hope somebody has a fix! :-(



#65
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 3,232 posts
  • Gender:Male

hi ZBOX

 

post here your config.plist, please



#66
ZB0X

ZB0X

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Germany, Stuttgart

Hello Fantomas,

 

Hope this is what you are looking for!

 

The forum tells me I´m not allowed to upload this type of file so I put in in a text file.

Attached Files



#67
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 3,232 posts
  • Gender:Male

you have to compress your file in .zip file to be allowed to upload it

 

never mind... please try this config.plist   Attached File  config.plist.zip   1.6KB   9 downloads

 

your kexts should be patched 'on the fly'

 

maybe you have to boot with kext-dev-mode=1 flag first time

 



#68
ZB0X

ZB0X

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Germany, Stuttgart

Oh, thats embarrassing did not know about that!

 

Tried your config.plist, now its showing up as Radeon 6770 Series but still with 5MB Memory.

Still really slow and full of artifacts.

 

I was booting with kext-dev-mode=1



#69
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 3,232 posts
  • Gender:Male

ok

 

open Terminal and tape this

 

cd /System/Library/Extensions

 

sudo chown -R 0:0 AMD5000Controller.kext AMDRadeonX3000.kext

 

sudo chmod -R 755 AMD5000Controller.kext AMDRadeonX3000.kext

 

sudo kextload -v AMD5000Controller.kext AMDRadeonX3000.kext

 

sudo touch /System/Library/Extensions

 

or

 

sudo kextcache -prelinked-kernel

 

reboot



#70
ZB0X

ZB0X

    InsanelyMac Protégé

  • Members
  • Pip
  • 8 posts
  • Gender:Male
  • Location:Germany, Stuttgart

Your first solution didn't do anything after the reboot.

 

I saved the log of the second one, seems like dependecies are missing. What does that mean?

 

Attached Files



#71
fantomas1

fantomas1

    InsanelyMacaholic

  • Supervisors
  • 3,232 posts
  • Gender:Male
AMD5000Controller.kext - no compatible dependency found for com.apple.kext.AMDSupport.

 

 

it means that AMD5000Controller.kext version is not the same as AMDSupport version

 

could you check it, please? open the version.plist file from both kexts and compare

 

 

EDIT

 

Your first solution didn't do anything after the reboot.

 

 

 

did you successfully loaded those both kexts... before reboot?



#72
Pilufo

Pilufo

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Hi fantomas1,

I had this card working on ML 10.8.2, but after updating to 1.8.5 and with kext modifications it didn't work anymore (a grey screen appears just after startup). Well, in fact, I have 2 cards running (quad monitor), and both worked well in 1.8.2.

Can you explain me how to inject that code in DSDT?

Thank you!



#73
maion

maion

    InsanelyMac Protégé

  • Members
  • Pip
  • 1 posts

Dear all,

 

I am trying to make my video card (AMD Radeon 6770 0x68ba1002) works on Maverics 10.9.5.

 

It was working on 10.9, but not after the update (just to have XCode with Swift, that I am learning)

 

I have tried the two kexts (AMD5000Controller and RadeonX3000) but the computer won`t boot. Shows a lot of: "change trust on" " process name YYYYY (pid XXX)" and never finishes. (both GE=Yes and No).
 

After rm -rf the kexts and clean caches with single mode, I am able to boot with GE=No at Chamaleon. But the video card has poor performance.

It shows "ATI Radeon HD 5700 Series 7 MB" with one monitor on, or "ATI Radeon HD 5700 Series 3 MB" with two monitors on.
 

I was not able to figure out how to inject the DSDT of the post #20. (I looked for it, but was not able to find an easy how to)

 

Can anybody help me?

 

Tnks!

 

 

AMD FX 6100 3.3GHz Core 6.

ASUSTek M5A88-M

AMD Radeon 6770 0x68ba1002







Also tagged with one or more of these keywords: HD 6770, QE/CI, OS X, ML, Mavericks, Yosemite


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2015 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy