Jump to content

[Solved]SATA and IDE drives not detected [Intel ICH10r in RAID mode]


  • Please log in to reply
7 replies to this topic

#1
iPablo

iPablo

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
OK, so I was wondering if any of you might have a tip for me:

I've got an ASUS P5QL-E - onboard SATA controller: Intel ICH10R/JMicron JMB363 (btw - could anyone explain to me why it is always two different controllers, or is it just two different names for the same controller?)

Anyway, atm, the SATA controller is set to RAID because of my windows array (2x1TB HDDs)
This might be why these two drives are not detected by the ML setup, might even cause that any other (non-raid) drives connected to the same controller won't be detected, but what I don't get is:

I connected my old 300GB IDE HDD (via IDE, obviously) and tried setting the IDE controller to IDE and AHCI, in both cases, the IDE HDD is not detected by the setup.

Right now I have installed ML onto another USB stick, it works perfectly well, including audio, graphics and network, but of course it's slow and unresponsive and it doesn't recognize the other drives either.
I would be happy to be able to install/move OSX onto the 300GB IDE drive or a single SATA drive so I could keep my RAID array intact for now, but I could also try deleting the RAID.

So If I managed to backup my 2TB data and delete the RAID array, then set the onboard controller to AHCI or IDE, would all drives be detected? or is this just a question of a missing kext?

Thanks very much in advance,
any tips or hints would be greatly appreciated.

Pablo

#2
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,123 posts
  • Gender:Male
  • Location:Brazil

I've got an ASUS P5QL-E - onboard SATA controller: Intel ICH10R/JMicron JMB363 (btw - could anyone explain to me why it is always two different controllers


There's a second controller because the ICH10 has no PATA support. I believe this is mentioned on the ICH10 wiki page.

Try asking here: http://www.insanelym...howtopic=282274
Although not spot on for what you're asking I think it's sufficiently related..

#3
tot318

tot318

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
IF you create a RAID array using Intel's RAID software, during installation those RAID array can't be detected and yes if you can backup your existing Intel's RAID and break the array and set to AHCI then ML setup will detect those drive. You can build a RAID array using AppleRAID software if you want ML in RAID. The ML installation only detects Intel ICH10R controller and after installation you can install a driver named AHCI_3rdParty_SATA.kext in order to use the JMicron JMB363 controller.

#4
Gringo Vermelho

Gringo Vermelho

    The Jan Bird fix

  • Supervisors
  • 6,123 posts
  • Gender:Male
  • Location:Brazil
Yes, ICHx hardware RAID does not work in OS X, and no, you don't have to change to AHCI, RAID implies AHCI. You can keep your Windows installation on hardware RAID and still run OS X from a drive connected to the ICH10R. You'll need AHCIPortInjector.kext
Well in theory anyway, I've never done it. But AHCIPortInjector has the device IDs for ICH10R in RAID mode.

Or you can use the JMicron controller for your OS X drive(s).

#5
iPablo

iPablo

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
wow, that was fast...
thanks, first of all!
I don't need the JMicron controller to work if I get the Setup or my running system to detect the ICH10r and the SATA drives..

not to sound stupid,but i wasn't able to find the

AHCIPortInjector.kext for ICH10r, not on this site, not on OSX86.com, kexts.com is not working at all for some reason..could you help me a little finding the Ich10r k

ext?


Two more questions:

1. Having found the next for my SATA controller, how do I integrate it into my setup? create an /E/E folder for chameleon?

2. What do you guys think (know) is faster? A 3,5" 7200RPM IDE drive (with IDE->SATA converter) or a 2,5" 5400RPM SATAII Notebook HDD?


Thanks in advance

Pablo



#6
tot318

tot318

    InsanelyMac Protégé

  • Members
  • PipPip
  • 81 posts
http://lmgtfy.com/?q...rtInjector.kext

#7
iPablo

iPablo

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
sorry, lmgtfy is too old to be funny...
which link do you mean, I can only find kexts for ich7/8/9, no working kexts for Ich10r..

EDIT: found a kext here: http://digitaldj.net...leopard-part-2/ inside the Chameleon package, working well on my running system. I will try to install on the IDE HDD via IDE->SATA adapter and report back.

#8
iPablo

iPablo

    InsanelyMac Protégé

  • Members
  • Pip
  • 4 posts
Okay, system is now up and running, everything working fine so far. might need to get rid of the stupid intel software raid soon...maybe move OSX to an SSD.

Thanks for the support, especially Gringo Vermelho ;)

I didn't try to get the JMicron IDE controller to run - I Usually don't need a DVD drive..guess it would work with the kexts from the Chameleon package aswell, it contained some IDE kexts. or prabably with the

AHCI_3rdParty_SATA.kext.







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy