Jump to content

Optimisation and stabilization of my Hackintosh

optimization stabilization lion

  • Please log in to reply
2 replies to this topic

#1
gostbuster

gostbuster

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
Hello !

This has been 2 months I'm using my new hackintosh. Sure I love it but it has some issues that I would like to solve. This will be quite hard to explain but I'll try.


First, here is my entire configuration. I tried to get a Golden build coz when I bought my computer, getting an hackintosh was my aim.
Well :

Gigabyte GA-Z68X-UD3H-B3 (rev 1,3) with EFI BIOS (uh1d)
Intel iCore 7 2700k
16 Go GSkill Ripjaws-X F3-12800CL9Q
2 x Crucial M4 (SSD) 128 Go (one for Osx and the other for WIn 7)
WD caviar Green 2To (for data)
Gainward GTX 570
Sony optiarc


I installed Lion 10,7,4 then upgraded to Lion without problem.
Everything seems to work : graphics ok, network, USB (didn't tried USB 3), sleep also work.

The problem I notice, is that my system is quite slow for the configuration I have. I mean, when I use Win 7, everything goes fast (very fast). Booting, opening programs, etc.. (normal due to the SSD),
but on Lion, even if my boot is fast, the rest is slower.... and I'm wondering if it's normal. I wish I could have a system very very reactive thanks of my hardware configuration,

Another problem I have is that I have sometimes and randomly grey screen of death (you need to restart your computer.....) this happens very randomly even if I'm not doing something special.
Last problem is that some programs just crash for example I have guitar rig which start and crash getting this error :


Crashed Thread: 0 Dispatch queue: com.apple.main-thread

Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000f7f


I tought that it could be because my kext are In a mess, but I don't know what to do, how to clean them, etc.... Actually I don't know how to start, what I have to check etc....
I tried to repair permissions and clean cache, but it's the same.

Can the community and experts help me to optimize everything in my hackintosh to get it near 100% stable ?

Here are some information that could help you :


my plist file :


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com...yList-1.0.dtd">
<plist version="1.0">
<dict>
<key>EthernetBuiltIn</key>
<string>Yes</string>
<key>GenerateCStates</key>
<string>Yes</string>
<key>GeneratePStates</key>
<string>Yes</string>
<key>GraphicsEnabler</key>
<string>Yes</string>
<key>Kernel</key>
<string>mach_kernel</string>
<key>Kernel Flags</key>
<string>npci=0x3000 darkwake=0</string>
<key>Legacy Logo</key>
<string>Yes</string>
<key>Timeout</key>
<string>2</string>
<key>UseKernelCache</key>
<string>Yes</string>
</dict>
</plist>

Do you need something else ?


Thank you very much in advance !

Attached Files



#2
gostbuster

gostbuster

    InsanelyMac Protégé

  • Members
  • Pip
  • 43 posts
Here are the screens converted in jpg

Attached Files



#3
westwaerts

westwaerts

    InsanelyMac Legend

  • Members
  • PipPipPipPipPipPipPip
  • 880 posts
  • Gender:Male
looks like speedstep is frozen at 16
try MSR Dumper to see if speedstep works





Also tagged with one or more of these keywords: optimization, stabilization, lion


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy