Jump to content

(Solved )Elantech ps2 trackpad works using Chimera but not using Chameleon

elantech trackpad ps2 chameleon chimera

  • Please log in to reply
3 replies to this topic

#1
rakusson

rakusson

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Location:Denmark
I've an Elantech ps2 trackpad in my laptop(see signature below). It was working fine while using Lion. Now, It works only when I boot using Chimera v.1.11 but not using even the latest chameleon(enoch 2050). This is very strange as I was using Chameleon with Lion and there was no problem. I have added these strings attached to identify the device ID (this was done too in Lion and it worked).
<string>ApplePS2MouseDevice</string>
   <key>ProductID</key>
   <string>PNP0F13</string>
   <key>VendorID</key>
   <integer>1452</integer

However, trackpad wont work despite this. but I dont need these strings at all when I use Chimera. Chimera seems to identify my trackpad as if some sort of code is hardcoded in it. Can anybody explain why?

UPDATE:Found two kexts which helped trackpad working in Chameleon. http://www.osx86.net...do=file&id=3191

Edited by rakusson, 10 September 2012 - 07:47 PM.


#2
sniper9911

sniper9911

    InsanelyMac Protégé

  • Members
  • PipPip
  • 73 posts
  • Gender:Male
i used to have this problem but i figured it out
you need to rebuild you kext cache in the place where you have put the appleps2nub and the other kexts via kextutility
i used to have my kexts in the \extra\extension folder
i only need to drag extensions folder to the kext utility app and then write my password then done
reboot
every thing works as it should but no multi touch support
hope it works for you too !

#3
LesGaR

LesGaR

    InsanelyMac Protégé

  • Members
  • PipPip
  • 51 posts

I've an Elantech ps2 trackpad in my laptop(see signature below). It was working fine while using Lion. Now, It works only when I boot using Chimera v.1.11 but not using even the latest chameleon(enoch 2050). This is very strange as I was using Chameleon with Lion and there was no problem. I have added these strings attached to identify the device ID (this was done too in Lion and it worked).

<string>ApplePS2MouseDevice</string>
   <key>ProductID</key>
   <string>PNP0F13</string>
   <key>VendorID</key>
   <integer>1452</integer

However, trackpad wont work despite this. but I dont need these strings at all when I use Chimera. Chimera seems to identify my trackpad as if some sort of code is hardcoded in it. Can anybody explain why?

I've an Elantech ps2 trackpad in my laptop(see signature below). It was working fine while using Lion. Now, It works only when I boot using Chimera v.1.11 but not using even the latest chameleon(enoch 2050). This is very strange as I was using Chameleon with Lion and there was no problem. I have added these strings attached to identify the device ID (this was done too in Lion and it worked).

<string>ApplePS2MouseDevice</string>
   <key>ProductID</key>
   <string>PNP0F13</string>
   <key>VendorID</key>
   <integer>1452</integer

However, trackpad wont work despite this. but I dont need these strings at all when I use Chimera. Chimera seems to identify my trackpad as if some sort of code is hardcoded in it. Can anybody explain why?

You have multitouch on

Elantech ps2 trackpad when boot with chimera v1.11?


What kext as used?

because i use AppleACPIPS2Nub.kext and VoodooPS2Controller.kext and only have multitouch for vertical scroll

#4
rakusson

rakusson

    InsanelyMac Protégé

  • Members
  • PipPip
  • 62 posts
  • Location:Denmark
sorry, my apologies. I've only vertical scroll and two finger scroll. I referred to this page for multi-touch in os x.
http://www.apple.com...s/gestures.html





Also tagged with one or more of these keywords: elantech, trackpad, ps2, chameleon, chimera


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy