Jump to content

10.8.2 Beta > a Strange ? Update for hackint0sh machines


  • Please log in to reply
163 replies to this topic

#21
xmen107

xmen107

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 111 posts

olá

aki está applehda original



bom hack


Muito obrigado artur, vou tentar aplicar o patch a ver se funciona bem ;)

Artur, reparei que você removeu a pasta resources, mas já editei e está a funcionar na minha mobo. Partilho-a se alguém precisar. Obrigado

é necessário alteração em DSDT:

Device (HDEF)
{
Name (_ADR, 0x001B0000)
Method (_PRW, 0, NotSerialized)
{
Return (Package (0x02)
{
0x0D,
0x05
})
}

Method (_DSM, 4, NotSerialized)
{
Store (Package (0x04)
{
"layout-id",
Buffer (0x04)
{
0x0C, 0x00, 0x00, 0x00
},

"PinConfigurations",
Buffer (One)
{
0x00
}
}, Local0)
DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))
Return (Local0)
}
}

Attached Files



#22
tle88

tle88

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 144 posts
  • Gender:Male
  • Location:Finland
I update yesterday 10.8.2 (12C31a)

Base was made myHack 3.1 (=removed 3 kext, and returned back AppleHDA 2.11)

After update, I must delete 2 same kext, which myHack removed from early. I do not find
third kext. I must remove OemSMBIOS.kext, which belongs to FakeSMC.

First boot with -v -f parameter in Chameleon.

Works well.


T -.-

#23
segfault

segfault

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Interests:unix
    Reverse Engineering
Hi i found this bootflag for chameleon documentation:


io=0xffffffff -v


booting 10.8.2

Registering: IOService:/

waitForSystemMapper

Backtrace

Kernel Extensions in backtrace:

com.apple.driverAppleACPIPlatform (1.6)

dependency: com.apple.iokit.IOACPIFamily (1.4)

dependency: com.apple.iokit.IOPCIFamily (2.7.1)



any idea?

#24
segfault

segfault

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Interests:unix
    Reverse Engineering

Hi i found this bootflag for chameleon documentation:


io=0xffffffff -v

booting 10.8.2
Registering: IOService:/
waitForSystemMapper
Backtrace
Kernel Extensions in backtrace:
com.apple.driverAppleACPIPlatform (1.6)
dependency: com.apple.iokit.IOACPIFamily (1.4)
dependency: com.apple.iokit.IOPCIFamily (2.7.1)


any idea?



chameleon not recognize ACPI

ACPI: System State [S0 S3 S4 S5]

#25
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,446 posts
  • Gender:Male
Man you have write same problem in post ufficial chemeleon...asked again here?
You are off topic now...

#26
segfault

segfault

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Interests:unix
    Reverse Engineering

Man you have write same problem in post ufficial chemeleon...asked again here?
You are off topic now...


Thanks for trolling.

not clear this problem chameleon or fakesmc problem.

#27
magnifico

magnifico

    InsanelyMac Deity

  • Donators
  • 2,446 posts
  • Gender:Male

Thanks for trolling.

not clear this problem chameleon or fakesmc problem.

I have no idea

#28
Kynyo

Kynyo

    InsanelyMac Geek

  • Members
  • PipPipPipPip
  • 241 posts
  • Gender:Male
  • Location:Not your bisnizz...
  • Interests:
I think it's a FakeSMC one...
Install latest fakeSMC+Plugins then go in FakeSMC Kext in S/L/E right click on fake smc, show package contents, plugins, then remove OemSMBIOS.

#29
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,884 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Yep, if sou have installed that fakesmc + oemsmbios. But i dont have it and kernel boot probs (KP) if i boot with -v since 10.8.2 Beta 1.
So the probs listed here may come from such .kext / Apple kext or in my case from kernel + chameleon probs itself.

NEW:

OS X 10.8.2 Beta Build 12C35

is out.
I have C31 and will try C35 (second 10.8.2 beta combo) soon.

#30
segfault

segfault

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Interests:unix
    Reverse Engineering

Yep, if sou have installed that fakesmc + oemsmbios. But i dont have it and kernel boot probs (KP) since 10.8.2 Beta 1.
So the probs listed here may come from such .kext / Apple kext or in my case from kernel + chameleon probs itself.

NEW:

OS X 10.8.2 Beta Build 12C35

is out.
I have C31 and will try C35 (second 10.8.2 beta combo) soon.



new build same problem no acpi recognise,only safe mode booting.


edit:

im rollback patched appleacpiplatform and iopcifamily kext and iousbfamily.

booting system normal mode,verbose boot perfect,normal boot perfect.

sorry my bad english

im attached three kext.

Attached File  acpirollback.zip   1.33MB   298 downloads

#31
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,884 posts
  • Gender:Male
  • Location:Stuttgart / Germany
For me no probs with C35 - at least booting with -v (verbose). Without -v boot not tested already.
As i told, booting C31 without -v i get an very early KP - has in my case nothing to do with kext usage. Its kernel only related.
I have no probs with that IOCPI, IOACPI kext, which i use native/vanilla (since ever) on my C2D, Intel P35 Chipset "Oldiboard".

#32
segfault

segfault

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Interests:unix
    Reverse Engineering

For me no probs with C35 - at least booting with -v (verbose). Without -v boot not tested already.
As i told, booting C31 without -v i get an very early KP - has in my case nothing to do with kext usage. Its kernel only related.
I have no probs with that IOCPI, IOACPI kext, which i use native/vanilla (since ever) on my C2D, Intel P35 Chipset "Oldiboard".


Andreas chck please ACPI state (booting -v)

thanks


my boot is:

Darwin Kernel Version 12.2.0: Sat Aug 25 00:48:52 PDT 2012; root:xnu-2050.18.24~1/RELEASE_X86_64
vm_page_bootstrap: 2031082 free pages and 49686 wired pages
kext submap [0xffffff7f80741000 - 0xffffff8000000000], kernel text [0xffffff8000200000 - 0xffffff8000741000]
zone leak detection enabled
standard timeslicing quantum is 10000 us
standard background quantum is 2500 us
mig_table_max_displ = 74
corecrypto kext started!
Running kernel space in FIPS MODE
Plist hmac value is	735d392b68241ef173d81097b1c8ce9ba283521626d1c973ac376838c466757d
Computed hmac value is 735d392b68241ef173d81097b1c8ce9ba283521626d1c973ac376838c466757d
corecrypto.kext FIPS integrity POST test passed!
corecrypto.kext FIPS AES CBC POST test passed!
corecrypto.kext FIPS TDES CBC POST test passed!
corecrypto.kext FIPS SHA POST test passed!
corecrypto.kext FIPS HMAC POST test passed!
corecrypto.kext FIPS ECDSA POST test passed!
corecrypto.kext FIPS DRBG POST test passed!
corecrypto.kext FIPS POST passed!
AppleACPICPU: ProcessorId=0 LocalApicId=0 Enabled
AppleACPICPU: ProcessorId=1 LocalApicId=1 Enabled
calling mpo_policy_init for Sandbox
Security policy loaded: Seatbelt sandbox policy (Sandbox)
calling mpo_policy_init for Quarantine
Security policy loaded: Quarantine policy (Quarantine)
calling mpo_policy_init for TMSafetyNet
Security policy loaded: Safety net for Time Machine (TMSafetyNet)
Copyright (c) 1982, 1986, 1989, 1991, 1993
		The Regents of the University of California. All rights reserved.
MAC Framework successfully initialized
using 16384 buffer headers and 10240 cluster IO buffer headers
IOAPIC: Version 0x20 Vectors 88:111
IOAPIC: Version 0x20 Vectors 64:87
ACPI: System State [S0 S3 S4 S5] (S3)


ACPI: System State [S0 S3 S4 S5] (S3)

#33
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,884 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Made an new (sharper) foro of my early KP (without -v, keepsyms=y). 10.8.2 C35 keeps KPing without -v.
Attached File  11678899zd.jpg   253.77KB   81 downloads


ACPI:
older OS X versions (10.8.1)

Aug 16 17:38:07 localhost kernel[0]: IOAPIC: Version 0x20 Vectors 64:87
Aug 16 17:38:07 localhost kernel[0]: ACPI: System State [S0 S3 S4 S5] (S3)

since 10.8.2

Aug 16 17:38:07 localhost kernel[0]: IOAPIC: Version 0x20 Vectors 64:87
Aug 16 17:38:07 localhost kernel[0]: ACPI: System State [S0 S3 S4 S5]


Can it be that problem (KP without -v) if in the KP screenshoot not any of those IOPCI/IOACPI kext are listed (like yours)?
And why does -v (verbose mode) help to aviod that KP?!
It does nothing else as putting some log text on an device. Needs some time of course - timimg probs?

#34
segfault

segfault

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Interests:unix
    Reverse Engineering

Attached File  acpirollback.zip   1.33MB   298 downloads


Andreas try rollback this three kext.

this workaround is work correctly.

#35
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,884 posts
  • Gender:Male
  • Location:Stuttgart / Germany
I tried.
Now:
Aug 31 12:53:56 localhost kernel[0]: ACPI: System State [S0 S3 S4 S5] (S3) // (S3) back again like 10.8.1
Aug 31 12:53:56 localhost kernel[0]: PCI configuration changed (bridge=0 device=2 yenta=0)

before (vanilla 10.8.2 C31/C35):
Aug 31 12:11:18 localhost kernel[0]: ACPI: System State [S0 S3 S4 S5] // no (S3)
Aug 31 12:11:18 localhost kernel[0]: PCI configuration changed (bridge=6 device=1 cardbus=0) /diff to new set
Aug 31 12:11:18 localhost kernel[0]: [ PCI configuration end, bridges 6 devices 15 ] // now missed?. now also ..begin missed

Booted once without -v - no KP :). Will have to try a few times more to be sure. In 1/10 of booting without -v it also got no KP.

For me interesting is, that with your set, i cant find any of the [PCI configuration end and [ PCI configuration begin ]
entries anymore. I can find them in older system.logs always.
Only PCI configuration changed is listed on both, your set and my old/ vanilla installs.

Can you look in your log if those ..begin and ...end are listed or also not anymore.

#36
segfault

segfault

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Interests:unix
    Reverse Engineering
not anymore :)

IOAPIC: Version 0x20 Vectors 88:111
IOAPIC: Version 0x20 Vectors 64:87
ACPI: System State [S0 S3 S4 S5] (S3)
PCI configuration changed (bridge=0 device=17 yenta=0)


#37
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,884 posts
  • Gender:Male
  • Location:Stuttgart / Germany
Ok, (no PCI begin / end anymore - only

PCI configuration changed

) if it works - doesnt matter. :wink2:

#38
segfault

segfault

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Interests:unix
    Reverse Engineering

Ok, (no PCI begin / end anymore - only

PCI configuration changed

) if it works - doesnt matter. :wink2:


Sounds good. :pirate2:

#39
mitch_de

mitch_de

    InsanelyMacaholic

  • Local Moderators
  • 2,884 posts
  • Gender:Male
  • Location:Stuttgart / Germany
I would have had those IOPCI & Co kext in focus, if the KP screen had listed those kext used as last steps before KP.
Mostly such info about last used kexts (before KP) listed in the KP screen points to the reason / problematic kext.

#40
segfault

segfault

    InsanelyMac Protégé

  • Members
  • PipPip
  • 78 posts
  • Gender:Male
  • Interests:unix
    Reverse Engineering
Special thank's Blackosx DarwinDumper app...

and

io=0xffffffff ««« bootflag help for debug ioservice problem







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy