Jump to content

[Risolto] Post-Installazione ML 10.8.3 su Acer Aspire 5740G

- - - - - acer aspire 5740G Mountain Lion retail mac os x 10.8

  • Please log in to reply
33 replies to this topic

#1
claver

claver

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts
  • Gender:Male
  • Interests:Informatica, musica, cinema e amici
Salve a tutti, dopo la mia positiva esperienza con Lion 10.7.3 (iAtkos L2 + Combo Update) sul mio Acer Aspire 5740G (http://www.insanelym...howtopic=275774) ho deciso di cimentarmi nell'installazione di Mountain Lion.

Per fare ciò ho seguito questa utilissima guida di Fiox89 per creare un'USB contenente l'installer di Mountain Lion:
http://www.insanelym...howtopic=258485

L'installazione è andata liscia e, al primo avvio, wifi, lettore DVD, lettore di schede di memoria e USB funzionavano perfettamente. Al contrario le altre periferiche non ne volevano sapere. Alcune sono riuscito a farle funzionare mentre altre no ... ed ecco che mi appello a voi Tutto risolto! :)

Prima di continuare eccovi le caratteristiche del mio pc (reperibili anche in firma):

Mobo: Acer Aspire 5740
CPU: Intel Core i5 430M (2.26 GHz, 1066 MHz FSB)
RAM: 3956 MB (DDR3-1066 DDR3 SDRAM)
GPU: ATI Mobility Radeon HD 5470 (512 MB)
Scheda Audio: Realtek ALC272
Scheda Wifi: Atheros AR5B93
Scheda di Rete: Broadcom NetLink BCM57780

Qui invece elenco i miei problemi Tutto risolto!:

- SCHEDA ETHERNET: Funziona dopo aver installato questo kext.
- TRACKPAD-TASTIERA PS2: Funzionano perfettamente dopo aver installato questi kext.
- SCHEDA AUDIO: Funziona perfettamente dopo aver installato i kext presenti in questo pacchetto.
- ICONA BATTERIA: Funziona dopo aver installato i kext presenti qui.
- SCHEDA GRAFICA: Funziona perfettamente dopo aver installato il bootloader clover e inserito questo file nella cartella /EFI.
- VGA/HDMI: L'HDMI funziona perfettamente dopo aver abilitato la scheda grafica (vedi sopra). La VGA non l'ho ancora testata.
- RESET CMOS: Non si verifica più utilizzando il DSDT patchato (vedi sotto).
- DSDT: Questo DSDT patchato risolve il problema dello sleep e del CMOS. Download qui.
- STOP: Funziona dopo aver installato il bootloader clover e inserito il DSDT patchato nella cartella /EFI/ACPI/patched/.

Potete scaricare il bootloader clover da qui: http://www.insanelym...2-instructions/.
Ringrazio giofrida per avermi patchato il DSDT mentre mmon per avermi aiutato nell'abilitare la scheda grafica.

COMBO UPDATE:
- COMBO UPDATE 10.8.1: Aggiornato senza problemi. Non bisogna reinstallare nessun kext.
- COMBO UPDATE 10.8.2: Aggiornato senza problemi. Se avete problemi con l'icona della batteria reinstallate i kext.
- COMBO UPDATE 10.8.3: Aggiornato senza problemi. Se avete problemi con l'icona della batteria reinstallate i kext.

LEGENDA:
- ROSSO: problema non risolto
- BLU: problema in parte risolto
- VERDE: problema risolto

-Claudio

Edited by claver, 15 March 2013 - 07:46 PM.


#2
claver

claver

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts
  • Gender:Male
  • Interests:Informatica, musica, cinema e amici
AGGIORNAMENTO 1: Risolto problema legato al reset del CMOS

#3
claver

claver

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts
  • Gender:Male
  • Interests:Informatica, musica, cinema e amici

AGGIORNAMENTO 2a: Aggiornamento a 10.8.1 tramite Mac App Store eseguito senza problemi. Non è necessario reinstallare nessun kext


AGGIORNAMENTO 2b: Audio perfettamente funzionante con VoodooHDA 2.7.4 (al posto del precedente 2.7.2)



#4
ShyMurder

ShyMurder

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
In particolare, per quanto riguarda la scheda grafica, ci vorrebbe qualcuno in grado di editare l' ID 717 per far si che venga riconosciuto non come lo schermo di un Mac Book Pro, ma bensì come quello di un Mac Book Air

#5
PortazRulez

PortazRulez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
Che SMBOS hai impostato?

#6
claver

claver

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts
  • Gender:Male
  • Interests:Informatica, musica, cinema e amici
Quello del MacBook Pro 6,1:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>SMbiosversion</key>
<string>######.tonymacx86.com</string>
<key>SMboardproduct</key>
<string>Mac-F22589C8</string>
<key>SMfamily</key>
<string>MacBook Pro</string>
<key>SMproductname</key>
<string>MacBookPro6,1</string>
<key>SMserial</key>
<string>C02CGEE6DC79</string>
</dict>
</plist>

L'ho installato con m u l t i b e a s t

#7
PortazRulez

PortazRulez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
Potresti provare a mettere quello dell'ultimo MacBook Air per vedere se si risolve il problema del monitor e se non risolve puoi sempre ripristinare quello attuale.

#8
claver

claver

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts
  • Gender:Male
  • Interests:Informatica, musica, cinema e amici
Sai dirmi dove lo posso trovare? Nè in m u l t i b e a s t e nè nella guida di Fiox c'è. Grazie

#9
ShyMurder

ShyMurder

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts

Potresti provare a mettere quello dell'ultimo MacBook Air per vedere se si risolve il problema del monitor e se non risolve puoi sempre ripristinare quello attuale.

Ho provato anch'io a fare come tu dici, ma non ha funzionato, comunque claver tu prova poi fammi sapere, sempre se possibile :)

#10
claver

claver

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts
  • Gender:Male
  • Interests:Informatica, musica, cinema e amici
ShyMurder,
dove l'hai preso l'smbios del mabook air?

#11
PortazRulez

PortazRulez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
Prova con questi. Li ho generati con champlist.

Prima prova i due dell'Air (Tra il 4,1 e il 4,2 cambia la grandezza del monitor per questo te li ho messi entrambi) e infine se non risolvi prova quello del PRO 6,1 e se non cambia ripristina il tuo.

Attached File  smbios Air 4,1.zip   468bytes   5 downloads Attached File  smbios Air4,2.zip   469bytes   4 downloads Attached File  smbios Pro6,1.zip   460bytes   3 downloads

PS. Hai provato a fare questo?

Andate in /System/Library/Displays/Overrides/DisplayVendorID-756e6b6e/ e copiateci dentro il file “DisplayProductID-717″ presente nella directory “Scheda Grafica” del pacchetto post-installazione. (Preso dalla guida nelle tua firma per Lion quindi il pacchetto dove c'è il file dovresti averlo)

#12
ShyMurder

ShyMurder

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
No scusa claver, era l'SMBIOS dell'iMac quello che ho provato... Comunque PortazRulez è proprio il fle

DisplayProductID-717

″ che da problemi, in quanto lo schermo viene riconosciuto come quello di un MacBook Pro, famoso per avere il difetto di uno schermo con soli 256.000 colori al posto dei 16.800.000 ai quali noi siamo abituati... Lo schermo in sè dell'Acer 5470 supporta questi colori su OSX, la prova è il fatto che le icone del Dock vengono visualizzate con gradienti praticamente uniformi all'occhio umano. Il resto del sistema, purtroppo, non lo è. Per tal proposito servirebbe l'ID 717 di un Mac Book Air, così i colori dovrebbero essere tutti



#13
claver

claver

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts
  • Gender:Male
  • Interests:Informatica, musica, cinema e amici
PortazRulez,
Ho provato i 3 smbios che hai postato ma la situazione non è cambiata. Il passaggio della mia guida che hai citato è proprio il metodo che ho seguito per avere la risoluzione nativa e i QE/CI abilitati (funziona sia su lion che su mountain lion).

ShyMurder,

Dubito che si possa modificare il DisplayProductID-717 in quanto contiene solo ProductID, VendorID e EDID della scheda grafica che sono unici (ovviamente potrei aver detto una fesseria). Comunque non penso che cambiare l'smbios influisca su questo nostro problema (come dimostrato dai test compiuti prima) allora mi viene da pensare che il tutto possa essere risolto da una bella modifica al DSDT. Non è che qualcuno, più esperto di me, ci possa aiutare?



#14
ShyMurder

ShyMurder

    InsanelyMac Protégé

  • Members
  • Pip
  • 49 posts
Ok, allora speriamo che qualcuno ci aiuti con il DSDT... Hai già provato a postare il problema nella sezione in lingua inglese? Sennò lo faccio subito :)

#15
claver

claver

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts
  • Gender:Male
  • Interests:Informatica, musica, cinema e amici
Ne ho fatto uno generico (identico a questo) per la post installazione di Mountain Lion:
http://www.insanelym...howtopic=282096

Però se ti va fanne uno specifico per la scheda video e, magari, uno nella sezione DSDT

#16
PortazRulez

PortazRulez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
Forse ho trovato la soluzione. Prova ad avviare con questa stringa AtiConfig=Shrike.
Se non funziona riprova rimuovendo il file (quello a cui mi riferivo prima).

#17
claver

claver

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts
  • Gender:Male
  • Interests:Informatica, musica, cinema e amici
Ciao ho provato a fare ciò che mi hai detto ma ho ottenuto solo uno schermo nero dopo il boot (lo stesso avviene eliminando l'id717). Allora mi è venuto in mente un vecchio post su OSx86.net per abilitare la mia scheda: http://www.osx86.net...c.._lio_...html ed è venuto fuori che AtiConfig=Shrike serve ad abilitare l'HDMI e la VGA ma non l'LVDS allora ho provato con AtiConfig=Eulemur e indovina un po'... non ha funzionato :P . In ultimo ho tentato di aggiungere il device id e il vendor id ai kext per le schede ATI ma l'esito non è stato positivo.

Prima di chiudere sfrutto questa risposta per postare il mio DSDT in caso qualcuno voglia aiutarmi a modificarlo: http://uploading.com...2e/DSDT.aml.zip

#18
claver

claver

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts
  • Gender:Male
  • Interests:Informatica, musica, cinema e amici
AGGIORNAMENTO 3: Ora il trackpad viene rilevato come tale e non come mouse (il download dei kext lo trovate nel primo post)

#19
PortazRulez

PortazRulez

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 125 posts
Hai provato AtiConfig=Hoolock ?

#20
claver

claver

    InsanelyMac Geek

  • Members
  • PipPipPip
  • 165 posts
  • Gender:Male
  • Interests:Informatica, musica, cinema e amici
Sì, è proprio il flag che uso per far funzionare la scheda (assieme a GraphicsEnabler=Yes)





Also tagged with one or more of these keywords: acer, aspire, 5740G, Mountain Lion, retail, mac os x, 10.8


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy