Jump to content

[Boot]PCI Configuration Begin

- - - - -

  • Please log in to reply
5 replies to this topic

#1
Alfabl0s

Alfabl0s

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts
Ciao a tutti!
Dopo un paio d'anni ho deciso di riprovarci, e ora ho installato OSX 10.8 sul mio ASUS M50Vn. L'installazione tramite ######, a patto di flaggare con PCIRootUID=0, va a buon fine e ora vi scrivo dal sistema operativo :)
Il problema ora è rendere stabile il boot senza bisogno di drive esterno col bootloader: devo installare correttamente il bootloader sul disco fisso. Ho provato a fare la procedura ###### con DSDT (Procuratomi da un utente di questo forum un paio d'anni fa ;)) ma l'errore che ottengo, anche con la flag PCIRootUID=0 è, in Verbose, "PCI Configuration Begin", e poi il nulla, resta così ad libitum.

Il sistema riconosce TUTTE le periferiche tranne l'audio.

Come posso fare per essere sicuro di avviare?
Vi ringrazio in anticipo
Antonio

P.S.: se c'è qualche regola che nel frattempo è cambiata, tipo mettere il mio hardware in firma, vi prego di farmelo presente, è un po' che non navigo da queste parti (anche se sarebbe più facile, come succede altrove, non rispondere :))

#2
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
try this kexts: Attached File  10.6.7 ACPI-PCI Kexts.zip   516.11KB   32 downloads

#3
Alfabl0s

Alfabl0s

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts

try this kexts: Attached File  10.6.7 ACPI-PCI Kexts.zip   516.11KB   32 downloads

Thank you very much! (Are you sure a 10.6.8 Kext will do the job? :))
I ask you because I don't have another way to modify the OS but inside of it, my whole HD has been formatted.

How am I supposed to install those kext? I remember Chameleon, but I don't know if they develope it anymore...
Thanks for your answer though :)

#4
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
this not my fix, for a lot of people works for PCI CONFIG BEGIN, use at your risk!!!! backup your kexts first!!!!!




http://netkas.org/?p=1053


These of you who are stuck at [PCI Configuration begin/end] and npci=0×3000 doesnt help, you had to use 10.6.7 IOPCIFamily and AppleACPIPlatform

and cant try Mountain [s]Dew[/s] Lion. Well, no more.

NETKAS

ported IOPCIFamily-115 kext to work with new AppleACPIPlatform.

So, you can use it and no need to replace AppleACPIPlatform with old one, a bit better then having to replace both.

Here is a link to a kext and sources -

http://rghost.ru/36725147

Also, here is version for Mountain Lion, which allowed my lappy to boot 10.8 -

http://rghost.ru/36725213

(both versions include fixes for ethernet and wifi on laptops lacking iomap addresses)


#5
Alfabl0s

Alfabl0s

    InsanelyMac Protégé

  • Members
  • PipPip
  • 80 posts
Thank you.
And, shouldn't I need a bootloader? What's on the scene now: chameleon?

#6
iFIRE

iFIRE

    InsanelyMacaholic

  • Banned
  • PipPipPipPipPipPipPipPipPipPipPip
  • 3,807 posts
  • Gender:Male
  • Location:Bcn-Spain
Enoch Bootloader





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

© 2014 InsanelyMac  |   News  |   Forum  |   Downloads  |   OSx86 Wiki  |   Mac Netbook  |   PHP hosting by CatN  |   Designed by Ed Gain  |   Logo by irfan  |   Privacy Policy